Want to subscribe to topics you're interested in?
Become a Member

[Solved] "redisbackend" not defined

Discussion in 'Bug Reports' started by GamerJota, Jun 1, 2016.

  1. GamerJota

    GamerJota New Member

    27
    4
    3
    Mar 1, 2016
    Chile
    Ratings:
    +12
    Local Time:
    7:31 PM
    1.11.2
    10.1.16-1
    Hey guys, please excuse my short explanation but I don't have much free time.
    I'm running on the beta branch and today I didn't update for like 1 month, today I updated because of the security patch in nginx 1.11.1.
    When the nginx instance restarted I was getting two errors at my WordPress Redis include file "/usr/local/nginx/conf/wpincludes/example.com/rediscache_example.com.conf" so it wasn't able to launch.
    The errors were both for the redis_pass argument: "no port in upstream 'redisbackend'".
    So yeah... I immediately thought that "redisbackend" was not declared or something and just replaced both lines with "localhost:6379".
    And it worked, dirty easy fix since I had no time to look into further.
    I'm running WordPress with redis cache at nginx level, I followed eva's tutorial.
    Thanks!
     
    • Informative Informative x 1
  2. eva2000

    eva2000 Administrator Staff Member

    30,194
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    8:31 AM
    Nginx 1.13.x
    MariaDB 5.5
    in /usr/local/nginx/conf/nginx.conf, ensure the redisupstream.conf is not commented out with a # in front
    uncommented
    Code (Text):
    include /usr/local/nginx/conf/redisupstream.conf;

    the redisupstream.conf include file is auto generated at /usr/local/nginx/conf/redisupstream.conf when you ran centmin.sh menu option 22 for wordpress setup usually and auto included into /usr/local/nginx/conf/nginx.conf
     
    Last edited: Jun 1, 2016
  3. GamerJota

    GamerJota New Member

    27
    4
    3
    Mar 1, 2016
    Chile
    Ratings:
    +12
    Local Time:
    7:31 PM
    1.11.2
    10.1.16-1
    Oh well, thank you hehe.
    That was it.
    No clue why that got commented during the update.
    Thanks eva!
     
    • Like Like x 1