Join the community today
Become a Member

Railgun RPM tries to install memcached

Discussion in 'Other Centmin Mod Installed software' started by BamaStangGuy, Jan 28, 2017.

  1. rdan

    rdan Well-Known Member

    4,983
    1,185
    113
    May 25, 2014
    Ratings:
    +1,804
    Local Time:
    10:38 AM
    Mainline
    10.2
    No, They also protect with layer 7 attacks.
    I encounter this last year when someone hit my site pretty bad and cloudflare direct all the request to my server.

    This is the sad thing of having Cloudflare Pro plan and Free only.
    If the attack is pretty hard already, Cloudflare will remove the firewall for your site and will direct all the attacks to your server.
     
  2. rdan

    rdan Well-Known Member

    4,983
    1,185
    113
    May 25, 2014
    Ratings:
    +1,804
    Local Time:
    10:38 AM
    Mainline
    10.2
    Basically all this will leak your IP:
    • Emails
    • Image & Link Proxy
    • Auto Link Title
    • Remote upload of images, video and avatars
     
  3. eva2000

    eva2000 Administrator Staff Member

    45,126
    10,269
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,915
    Local Time:
    12:38 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Good to know :)
     
  4. BamaStangGuy

    BamaStangGuy Premium Member Premium Member

    651
    189
    43
    May 25, 2014
    Ratings:
    +264
    Local Time:
    9:38 PM
    FYI since I had to do this for a customer again, here is how I did it:

    Code:
    yum install railgun-stable --downloadonly --downloaddir=/home/
    Code:
    cd /home/
    rpm -ivh --nodeps railgun-stable-5.3.0-1.el7.x86_64.rpm
     
  5. eva2000

    eva2000 Administrator Staff Member

    45,126
    10,269
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,915
    Local Time:
    12:38 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    thanks for sharing :)
     
  6. BamaStangGuy

    BamaStangGuy Premium Member Premium Member

    651
    189
    43
    May 25, 2014
    Ratings:
    +264
    Local Time:
    9:38 PM
    FYI normal yum updates seem to work without any manual interference:

    Code:
    [00:51][root@ovh-128.whippmedia.com ~]# rpm -qa | grep railgun
    railgun-stable-5.3.2-1.el7.x86_64
    
     
  7. eva2000

    eva2000 Administrator Staff Member

    45,126
    10,269
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,915
    Local Time:
    12:38 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    maybe they removed the memcached dependencies ?
     
  8. eva2000

    eva2000 Administrator Staff Member

    45,126
    10,269
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,915
    Local Time:
    12:38 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    seems that only applies to CentOS 7, for CentOS 6 memcached is still a dependency but your workaround worked fine too
    Code (Text):
    rpm -qa | grep railgun
    railgun-stable-5.3.2-1.el6.x86_64