Join the community today
Become a Member

[Solved] Python conflict on update

Discussion in 'Bug Reports' started by pamamolf, Apr 6, 2019.

  1. pamamolf

    pamamolf Premium Member Premium Member

    3,397
    320
    83
    May 31, 2014
    Ratings:
    +604
    Local Time:
    6:30 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.10
    • PHP Version Installed: 7.3.4
    • MariaDB MySQL Version Installed: 10.3.xx
    • When was last time updated Centmin Mod code base ? : just now

    Hello

    I just got this error on a test VPS server after exiting centmin menu and trying to use the recommended updated command:

    Code:
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi,city-fan.org
    and then i got an error like:

    Code:
      file /usr/lib64/python3.6/xml/sax/__pycache__/xmlreader.cpython-36.opt-2.pyc from install of python36-libs-3.6.6-5.el7.x86_64 conflicts with file from package python36u-libs-3.6.7-1.ius.centos7.x86_64
      file /usr/lib64/python3.6/xml/sax/__pycache__/xmlreader.cpython-36.pyc from install of python36-libs-3.6.6-5.el7.x86_64 conflicts with file from package python36u-libs-3.6.7-1.ius.centos7.x86_64
      file /usr/lib64/python3.6/xml/sax/expatreader.py from install of python36-libs-3.6.6-5.el7.x86_64 conflicts with file from package python36u-libs-3.6.7-1.ius.centos7.x86_64
      file /usr/lib64/python3.6/zipfile.py from install of python36-libs-3.6.6-5.el7.x86_64 conflicts with file from package python36u-libs-3.6.7-1.ius.centos7.x86_64
      file /usr/bin/python3.6m from install of python36-3.6.6-5.el7.x86_64 conflicts with file from package python36u-3.6.7-1.ius.centos7.x86_64
      file /usr/bin/python3.6 from install of python36-3.6.6-5.el7.x86_64 conflicts with file from package python36u-3.6.7-1.ius.centos7.x86_64
    
    Error Summary
    -------------
    Update then stopped there without updating anything from the list :(

    Thank you
     
  2. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    looks like EPEL repo python36 is conflicting with IUS Community's already installed python36u from addons/python36_install.sh addon you must of ran

    EPEL YUM repo reported python34 and python36 versions
    Code (Text):
    yum list python34 python35 python36 -q | tr -s ' ' | column -t
    Available        Packages
    python34.x86_64  3.4.9-2.el7  epel
    python36.x86_64  3.6.6-2.el7  epel
    

    Both EPEL and IUS Community YUM repo versions where IUS Community has suffix 'u'
    Code (Text):
    yum list python34 python35 python36 python34u python35u python36u -q --enablerepo=ius| tr -s ' ' | column -t
    Installed         Packages
    python34u.x86_64  3.4.8-1.ius.centos7  @ius
    Available         Packages
    python34.x86_64   3.4.9-3.el7          epel
    python35u.x86_64  3.5.6-1.ius.centos7  ius
    python36.x86_64   3.6.6-5.el7          epel
    python36u.x86_64  3.6.7-1.ius.centos7  ius
    

    all related packages
    Code (Text):
    yum list python34* python35* python36* python34u* python35u* python36u* -q --enablerepo=ius| tr -s ' ' | column -t
    Installed                                     Packages
    python34u.x86_64                              3.4.8-1.ius.centos7                 @ius
    python34u-devel.x86_64                        3.4.8-1.ius.centos7                 @ius
    python34u-libs.x86_64                         3.4.8-1.ius.centos7                 @ius
    python34u-pip.noarch                          9.0.1-1.ius.centos7                 @ius
    python34u-setuptools.noarch                   39.0.1-1.ius.centos7                @ius
    python34u-tkinter.x86_64                      3.4.8-1.ius.centos7                 @ius
    python34u-tools.x86_64                        3.4.8-1.ius.centos7                 @ius
    Available                                     Packages
    python34.x86_64                               3.4.9-3.el7                         epel
    python34-Cython.x86_64                        0.28.4-3.el7                        epel
    python34-PyYAML.x86_64                        3.11-4.el7                          epel
    python34-apsw.x86_64                          3.7.17.r1-3.el7                     epel
    python34-asn1crypto.noarch                    0.24.0-7.el7                        epel
    python34-backports-ssl_match_hostname.noarch
    3.5.0.1-1.el7                                 epel
    python34-blosc.x86_64                         1.2.8-5.el7                         epel
    python34-bsddb3.x86_64                        6.2.6-4.el7                         epel
    python34-chardet.noarch                       2.3.0-5.el7                         epel
    python34-click.noarch                         6.7-8.el7                           epel
    python34-coverage.x86_64                      4.0.3-5.el7                         epel
    python34-cups.x86_64                          1.9.74-4.el7                        epel
    python34-dateutil.noarch                      1:2.4.2-5.el7                       epel
    python34-debug.x86_64                         3.4.9-3.el7                         epel
    python34-devel.x86_64                         3.4.9-3.el7                         epel
    python34-docutils.noarch                      0.12-0.10.20140510svn7747.el7       epel
    python34-empy.noarch                          3.3.3-2.el7                         epel
    python34-fedfind.noarch                       4.2.0-1.el7                         epel
    python34-idna.noarch                          2.7-2.el7                           epel
    python34-jsmva.noarch                         6.16.00-4.el7                       epel
    python34-jupyroot.x86_64                      6.16.00-4.el7                       epel
    python34-lark-parser.noarch                   0.6.4-6.el7                         epel
    python34-leveldb.x86_64                       0.194-2.el7                         epel
    python34-lhapdf.x86_64                        6.2.1-6.el7                         epel
    python34-libs.x86_64                          3.4.9-3.el7                         epel
    python34-markdown.noarch                      2.4.1-4.el7                         epel
    python34-mock.noarch                          2.0.0-2.el7                         epel
    python34-nose.noarch                          1.3.7-4.el7                         epel
    python34-numpy.x86_64                         1.10.4-7.el7                        epel
    python34-numpy-f2py.x86_64                    1.10.4-7.el7                        epel
    python34-parso.noarch                         0.3.1-2.el7                         epel
    python34-pbr.noarch                           4.2.0-3.el7                         epel
    python34-pdir2.noarch                         0.3.0-6.el7                         epel
    python34-pip.noarch                           8.1.2-8.el7                         epel
    python34-process-tests.noarch                 1.0.0-11.el7                        epel
    python34-psutil.x86_64                        2.2.1-5.el7                         epel
    python34-psycopg2.x86_64                      2.7.7-1.el7                         epel
    python34-psycopg2-tests.x86_64                2.7.7-1.el7                         epel
    python34-py.noarch                            1.4.32-2.el7                        epel
    python34-py4j.noarch                          0.10.7-4.el7                        epel
    python34-pycryptodomex.x86_64                 3.7.3-2.el7                         epel
    python34-pygraphviz.x86_64                    1.3-2.rc2.el7.2                     epel
    python34-pysocks.noarch                       1.6.8-6.el7                         epel
    python34-pytest.noarch                        2.9.2-3.el7                         epel
    python34-pytest-cov.noarch                    2.5.1-3.el7                         epel
    python34-pythia8.x86_64                       8.2.35-6.el7                        epel
    python34-pyvirtualize.noarch                  0.9-5.20181003git57d2307.el7        epel
    python34-pyvmomi.noarch                       6.7.1-3.el7                         epel
    python34-requests.noarch                      2.12.5-3.el7                        epel
    python34-root.x86_64                          6.16.00-4.el7                       epel
    python34-setuptools.noarch                    39.2.0-3.el7                        epel
    python34-setuptools_scm.noarch                1.17.0-3.el7                        epel
    python34-six.noarch                           1.11.0-3.el7                        epel
    python34-slack_cleaner.noarch                 0.5.0-2.el7                         epel
    python34-slacker.noarch                       0.12.0-4.el7                        epel
    python34-snowballstemmer.noarch               1.2.1-9.el7                         epel
    python34-tabulate.noarch                      0.8.3-6.el7                         epel
    python34-test.x86_64                          3.4.9-3.el7                         epel
    python34-tkinter.x86_64                       3.4.9-3.el7                         epel
    python34-tools.x86_64                         3.4.9-3.el7                         epel
    python34-urllib3.noarch                       1.19.1-5.el7                        epel
    python34-uwsgidecorators.x86_64               2.0.17.1-2.el7                      epel
    python34-virtualenv.noarch                    15.1.0-3.el7                        epel
    python34-xrootd.x86_64                        1:4.9.0-2.el7                       epel
    python34u-debug.x86_64                        3.4.8-1.ius.centos7                 ius
    python34u-debuginfo.x86_64                    3.4.8-1.ius.centos7                 ius
    python34u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python34u-test.x86_64                         3.4.8-1.ius.centos7                 ius
    python34u-wheel.noarch                        0.30.0-1.ius.centos7                ius
    python35u.x86_64                              3.5.6-1.ius.centos7                 ius
    python35u-debug.x86_64                        3.5.6-1.ius.centos7                 ius
    python35u-debuginfo.x86_64                    3.5.6-1.ius.centos7                 ius
    python35u-devel.x86_64                        3.5.6-1.ius.centos7                 ius
    python35u-hiredis.x86_64                      0.2.0-1.ius.centos7                 ius
    python35u-hiredis-debuginfo.x86_64            0.2.0-1.ius.centos7                 ius
    python35u-libs.x86_64                         3.5.6-1.ius.centos7                 ius
    python35u-lxml.x86_64                         4.2.0-1.ius.centos7                 ius
    python35u-lxml-debuginfo.x86_64               4.2.0-1.ius.centos7                 ius
    python35u-mod_wsgi.x86_64                     4.6.2-1.ius.centos7                 ius
    python35u-mod_wsgi-debuginfo.x86_64           4.6.2-1.ius.centos7                 ius
    python35u-pip.noarch                          9.0.1-1.ius.centos7                 ius
    python35u-postgresql.x86_64                   1.2.1-1.ius.centos7                 ius
    python35u-postgresql-debuginfo.x86_64         1.2.1-1.ius.centos7                 ius
    python35u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python35u-setuptools.noarch                   39.0.1-1.ius.centos7                ius
    python35u-test.x86_64                         3.5.6-1.ius.centos7                 ius
    python35u-tkinter.x86_64                      3.5.6-1.ius.centos7                 ius
    python35u-tools.x86_64                        3.5.6-1.ius.centos7                 ius
    python36.x86_64                               3.6.6-5.el7                         epel
    python36-Cython.x86_64                        0.28.4-3.el7                        epel
    python36-PyMySQL.noarch                       0.9.2-2.el7                         epel
    python36-PyYAML.x86_64                        3.11-4.el7                          epel
    python36-aiosmtpd.noarch                      1.0-3.el7                           epel
    python36-arrow.noarch                         0.8.0-4.el7                         epel
    python36-asn1crypto.noarch                    0.24.0-7.el7                        epel
    python36-astroid.noarch                       1.4.9-3.el7                         epel
    python36-atpublic.x86_64                      0.5-2.el7                           epel
    python36-attrs.noarch                         17.4.0-4.el7                        epel
    python36-autowrap.noarch                      0.19.0-2.el7                        epel
    python36-backports_abc.noarch                 0.5-2.el7                           epel
    python36-bitarray.x86_64                      0.8.3-2.el7                         epel
    python36-blessed.noarch                       1.14.1-3.el7                        epel
    python36-blosc.x86_64                         1.2.8-5.el7                         epel
    python36-bottle.noarch                        0.12.13-2.el7                       epel
    python36-breathe.noarch                       4.2.0-4.el7                         epel
    python36-bsddb3.x86_64                        6.2.6-4.el7                         epel
    python36-cached_property.noarch               1.5.1-2.el7                         epel
    python36-cairo.x86_64                         1.10.0-25.el7                       epel
    python36-cairo-devel.x86_64                   1.10.0-25.el7                       epel
    python36-catkin-sphinx.noarch                 0.2.2-3.el7                         epel
    python36-certifi.noarch                       2018.10.15-4.el7                    epel
    python36-cffi.x86_64                          1.9.1-3.el7                         epel
    python36-chai.noarch                          1.1.1-5.el7                         epel
    python36-chardet.noarch                       2.3.0-5.el7                         epel
    python36-click.noarch                         6.7-8.el7                           epel
    python36-clustershell.noarch                  1.8.1-2.el7                         epel
    python36-clyent.noarch                        1.2.2-3.el7                         epel
    python36-collada.noarch                       0.4-16.el7                          epel
    python36-colorclass.noarch                    2.2.0-3.el7                         epel
    python36-contextlib2.noarch                   0.5.1-3.el7                         epel
    python36-cookies.noarch                       2.2.1-8.el7                         epel
    python36-cov-core.noarch                      1.15.0-9.el7                        epel
    python36-coverage.x86_64                      4.0.3-5.el7                         epel
    python36-crypto.x86_64                        2.6.1-16.el7                        epel
    python36-cryptography.x86_64                  2.3-2.el7                           epel
    python36-cryptography-vectors.noarch          2.3-1.el7                           epel
    python36-cups.x86_64                          1.9.74-4.el7                        epel
    python36-cytoolz.x86_64                       0.9.0.1-4.el7                       epel
    python36-datadog.noarch                       0.23.0-3.el7                        epel
    python36-dateutil.noarch                      1:2.4.2-5.el7                       epel
    python36-dbus.x86_64                          1.2.4-3.el7                         epel
    python36-ddt.noarch                           1.1.3-2.el7                         epel
    python36-debconf.noarch                       1.5.69-2.el7                        epel
    python36-debug.x86_64                         3.6.6-5.el7                         epel
    python36-decorator.noarch                     4.0.11-2.el7                        epel
    python36-defusedxml.noarch                    0.5.0-2.el7                         epel
    python36-devel.x86_64                         3.6.6-5.el7                         epel
    python36-distlib.noarch                       0.2.7-3.el7                         epel
    python36-distutils-extra.noarch               2.39-8.el7                          epel
    python36-dns.noarch                           1.15.0-8.el7                        epel
    python36-docker.noarch                        2.6.1-3.el7                         epel
    python36-docker-pycreds.noarch                0.2.1-2.el7                         epel
    python36-dockerpty.noarch                     0.4.1-10.el7                        epel
    python36-docopt.noarch                        0.6.2-8.el7                         epel
    python36-docutils.noarch                      0.12-0.10.20140510svn7747.el7       epel
    python36-easyargs.noarch                      0.9.4-3.el7                         epel
    python36-easygui.noarch                       0.96-20.el7                         epel
    python36-ecdsa.noarch                         0.13-10.el7                         epel
    python36-empy.noarch                          3.3.3-2.el7                         epel
    python36-enlighten.noarch                     1.1.0-2.el7                         epel
    python36-espresso-mpich.x86_64                4.0.1-2.el7                         epel
    python36-espresso-openmpi.x86_64              4.0.1-2.el7                         epel
    python36-execnet.noarch                       1.2.0-7.el7                         epel
    python36-falcon.x86_64                        1.4.1-2.el7                         epel
    python36-fido2.noarch                         0.5.0-4.el7                         epel
    python36-flexmock.noarch                      0.10.2-5.el7                        epel
    python36-flufl-bounce.noarch                  2.3-6.el7                           epel
    python36-flufl-i18n.noarch                    1.1.3-6.el7                         epel
    python36-flufl-lock.noarch                    2.4.1-6.el7                         epel
    python36-flufl-testing.noarch                 0.4-6.el7                           epel
    python36-freezegun.noarch                     0.1.19-2.el7                        epel
    python36-future.noarch                        0.16.0-7.el7                        epel
    python36-gammu.x86_64                         2.11-3.el7                          epel
    python36-gobject.x86_64                       3.22.0-6.el7                        epel
    python36-gobject-base.x86_64                  3.22.0-6.el7                        epel
    python36-gobject-devel.x86_64                 3.22.0-6.el7                        epel
    python36-greenlet.x86_64                      0.4.12-2.el7                        epel
    python36-greenlet-devel.x86_64                0.4.12-2.el7                        epel
    python36-gssapi.x86_64                        1.3.0-5.el7                         epel
    python36-hexdump.noarch                       3.4-0.3.20160818hg66325cb5fed8.el7  epel
    python36-hypothesis.noarch                    3.12.0-2.el7                        epel
    python36-idle.x86_64                          3.6.6-5.el7                         epel
    python36-idna.noarch                          2.7-2.el7                           epel
    python36-idstools.noarch                      0.6.3-2.el7                         epel
    python36-ipython_genutils.noarch              0.1.0-8.el7                         epel
    python36-iso8601.noarch                       0.1.11-8.el7                        epel
    python36-isort.noarch                         4.2.5-9.el7                         epel
    python36-ivi.noarch                           0.14.9-7.el7                        epel
    python36-jaydebeapi.noarch                    1.1.1-2.el7                         epel
    python36-jedi.noarch                          0.10.2-4.el7                        epel
    python36-jinja2.noarch                        2.8-3.el7                           epel
    python36-jpype.x86_64                         0.6.3-8.el7                         epel
    python36-jsmva.noarch                         6.16.00-4.el7                       epel
    python36-jsonschema.noarch                    2.5.1-4.el7                         epel
    python36-jupyroot.x86_64                      6.16.00-4.el7                       epel
    python36-jupyter-core.noarch                  4.3.0-2.el7                         epel
    python36-jwt.noarch                           1.6.4-2.el7                         epel
    python36-keyring.noarch                       5.0-4.el7                           epel
    python36-kitchen.noarch                       1.2.5-2.el7                         epel
    python36-lammps.x86_64                        20181212-2.el7                      epel
    python36-lark-parser.noarch                   0.6.4-6.el7                         epel
    python36-lazr-config.noarch                   2.1-6.el7                           epel
    python36-lazr-delegates.noarch                2.0.3-6.el7                         epel
    python36-lazr-smtptest.noarch                 2.0.3-7.el7                         epel
    python36-lazy-object-proxy.x86_64             1.2.2-2.el7                         epel
    python36-ldap3.noarch                         2.5.2-2.el7                         epel
    python36-lensfun.x86_64                       0.3.2-14.el7                        epel
    python36-leveldb.x86_64                       0.194-2.el7                         epel
    python36-lhapdf.x86_64                        6.2.1-6.el7                         epel
    python36-libdiscid.x86_64                     0.4.1-12.el7                        epel
    python36-libs.x86_64                          3.6.6-5.el7                         epel
    python36-llfuse.x86_64                        1.0-2.el7                           epel
    python36-locket.noarch                        0.2.0-3.el7                         epel
    python36-lxc.x86_64                           1.0.11-2.el7                        epel
    python36-lz4.x86_64                           0.8.2-2.el7                         epel
    python36-markdown.noarch                      2.4.1-4.el7                         epel
    python36-markupsafe.x86_64                    0.23-2.el7                          epel
    python36-maxminddb.x86_64                     1.4.0-3.el7                         epel
    python36-mccabe.noarch                        0.6.1-7.el7                         epel
    python36-mimeparse.noarch                     1.6.0-5.el7                         epel
    python36-mock.noarch                          2.0.0-2.el7                         epel
    python36-msgpack.x86_64                       0.5.6-5.el7                         epel
    python36-multilib.noarch                      1.2-3.el7                           epel
    python36-mysql.x86_64                         1.3.12-2.el7                        epel
    python36-mysql-debug.x86_64                   1.3.12-2.el7                        epel
    python36-nbformat.noarch                      4.4.0-2.el7                         epel
    python36-neovim.noarch                        0.3.1-3.el7                         epel
    python36-netaddr.noarch                       0.7.18-3.el7                        epel
    python36-netcdf4.x86_64                       1.2.7-4.el7                         epel
    python36-nordugrid-arc.x86_64                 5.4.4-1.el7                         epel
    python36-nose.noarch                          1.3.7-4.el7                         epel
    python36-nose2.noarch                         0.6.5-6.el7                         epel
    python36-numexpr.x86_64                       2.5.2-3.el7                         epel
    python36-numpy.x86_64                         1.10.4-7.el7                        epel
    python36-numpy-f2py.x86_64                    1.10.4-7.el7                        epel
    python36-olefile.noarch                       0.46-2.el7                          epel
    python36-openqa_client.noarch                 1.3.1-6.el7                         epel
    python36-pamela.noarch                        0.3.0-2.el7                         epel
    python36-paramiko.noarch                      2.1.1-0.10.el7                      epel
    python36-parso.noarch                         0.3.1-2.el7                         epel
    python36-pathspec.noarch                      0.5.3-2.el7                         epel
    python36-pbr.noarch                           4.2.0-3.el7                         epel
    python36-pdfminer.noarch                      20160614-5.el7                      epel
    python36-pdir2.noarch                         0.3.0-6.el7                         epel
    python36-petsc4py-mpich.x86_64                3.9.1-4.el7                         epel
    python36-petsc4py-openmpi.x86_64              3.9.1-4.el7                         epel
    python36-pg8000.noarch                        1.10.5-2.el7                        epel
    python36-pid.noarch                           2.2.3-2.el7                         epel
    python36-pika.noarch                          0.10.0-10.el7                       epel
    python36-pika-doc.noarch                      0.10.0-10.el7                       epel
    python36-pip.noarch                           8.1.2-8.el7                         epel
    python36-pkgconfig.noarch                     1.1.0-8.el7                         epel
    python36-pluginlib.noarch                     0.6.1-2.el7                         epel
    python36-ply.noarch                           3.9-2.el7                           epel
    python36-polib.noarch                         1.0.7-10.el7                        epel
    python36-prelude.x86_64                       4.1.0-3.el7                         epel
    python36-prelude-correlator.x86_64            4.1.1-4.el7                         epel
    python36-preludedb.x86_64                     4.1.0-2.el7                         epel
    python36-pretend.noarch                       1.0.8-4.el7                         epel
    python36-process-tests.noarch                 1.0.0-11.el7                        epel
    python36-productmd.noarch                     1.20-3.el7                          epel
    python36-prompt_toolkit.noarch                1.0.15-2.el7                        epel
    python36-psutil.x86_64                        2.2.1-5.el7                         epel
    python36-psycopg2.x86_64                      2.7.7-1.el7                         epel
    python36-psycopg2-tests.x86_64                2.7.7-1.el7                         epel
    python36-ptyprocess.noarch                    0.5.1-7.el7                         epel
    python36-py.noarch                            1.4.32-2.el7                        epel
    python36-py4j.noarch                          0.10.7-4.el7                        epel
    python36-pyOpenSSL.noarch                     17.3.0-1.el7                        epel
    python36-pyasn1.noarch                        0.1.9-2.el7                         epel
    python36-pyasn1-modules.noarch                0.1.9-2.el7                         epel
    python36-pycmd.noarch                         1.2-5.el7                           epel
    python36-pycodestyle.noarch                   2.0.0-6.el7                         epel
    python36-pycosat.x86_64                       0.6.3-2.el7                         epel
    python36-pycparser.noarch                     2.14-2.el7                          epel
    python36-pycryptodomex.x86_64                 3.7.3-2.el7                         epel
    python36-pycurl.x86_64                        7.43.0-6.el7                        epel
    python36-pyev.x86_64                          0.9.0-0.2.20130610gite31d137.el7    epel
    python36-pyflakes.noarch                      1.6.0-4.el7                         epel
    python36-pygithub.noarch                      1.39-5.el7                          epel
    python36-pygments.noarch                      2.2.0-2.el7                         epel
    python36-pygraphviz.x86_64                    1.3-2.rc2.el7.2                     epel
    python36-pyicu.x86_64                         1.5-26.el7                          epel
    python36-pylint.noarch                        1.6.5-5.el7                         epel
    python36-pylint-gui.noarch                    1.6.5-5.el7                         epel
    python36-pymilter.x86_64                      1.0.3-2.el7                         epel
    python36-pymssql.x86_64                       2.1.3-3.el7                         epel
    python36-pypandoc.noarch                      1.3.3-3.el7                         epel
    python36-pyroute2.noarch                      0.4.13-2.el7                        epel
    python36-pyside.x86_64                        1.2.4-2.el7                         epel
    python36-pysocks.noarch                       1.6.8-6.el7                         epel
    python36-pytest.noarch                        2.9.2-3.el7                         epel
    python36-pytest-catchlog.noarch               1.2.2-3.el7                         epel
    python36-pytest-cov.noarch                    2.5.1-3.el7                         epel
    python36-pytest-runner.noarch                 3.0-2.el7                           epel
    python36-pytest-xdist.noarch                  1.17.1-3.el7                        epel
    python36-pythia8.x86_64                       8.2.35-6.el7                        epel
    python36-pytz.noarch                          2017.2-3.el7                        epel
    python36-pyusb.noarch                         1.0.2-3.el7                         epel
    python36-pyvirtualize.noarch                  0.9-5.20181003git57d2307.el7        epel
    python36-pyvmomi.noarch                       6.7.1-3.el7                         epel
    python36-pyxdg.noarch                         0.25-7.el7                          epel
    python36-pyxs.noarch                          0.4.1-2.el7                         epel
    python36-qpid-proton.x86_64                   0.26.0-2.el7                        epel
    python36-regex.x86_64                         2019.03.09-1.el7                    epel
    python36-rencode.x86_64                       1.0.5-4.el7                         epel
    python36-requests.noarch                      2.12.5-3.el7                        epel
    python36-responses.noarch                     0.5.1-7.el7                         epel
    python36-root.x86_64                          6.16.00-4.el7                       epel
    python36-rope.noarch                          0.12.0-2.el7                        epel
    python36-rpm.x86_64                           4.11.3-3.el7                        epel
    python36-ruamel-yaml.x86_64                   0.13.14-2.el7                       epel
    python36-scandir.x86_64                       1.9.0-2.el7                         epel
    python36-scapy.noarch                         2.4.0-3.el7                         epel
    python36-scipy.x86_64                         0.18.1-2.el7                        epel
    python36-scons.noarch                         3.0.4-4.el7                         epel
    python36-scripttest.noarch                    1.3.0-10.el7                        epel
    python36-setproctitle.x86_64                  1.1.6-3.el7                         epel
    python36-setuptools.noarch                    39.2.0-3.el7                        epel
    python36-setuptools_scm.noarch                1.17.0-3.el7                        epel
    python36-sh.noarch                            1.12.14-7.el7                       epel
    python36-simplejson.x86_64                    3.10.0-2.el7                        epel
    python36-simplepam.noarch                     0.1.5-7.el7                         epel
    python36-simplepath.noarch                    0.3.4-2.el7                         epel
    python36-six.noarch                           1.11.0-3.el7                        epel
    python36-slacker.noarch                       0.12.0-4.el7                        epel
    python36-snowballstemmer.noarch               1.2.1-9.el7                         epel
    python36-spglib.x86_64                        1.11.1-2.el7                        epel
    python36-sphinx.noarch                        1.2.3-4.el7                         epel
    python36-sphinx-autobuild.noarch              0.7.1-9.el7                         epel
    python36-sphinx-latex.noarch                  1.2.3-4.el7                         epel
    python36-sphinx-theme-alabaster.noarch        0.7.9-2.el7                         epel
    python36-spur.noarch                          0.3.17-2.el7                        epel
    python36-sqlalchemy.x86_64                    1.1.3-2.el7                         epel
    python36-structlog.noarch                     17.2.0-2.el7                        epel
    python36-suds.noarch                          0.6-2.el7                           epel
    python36-terminado.noarch                     0.6-3.el7                           epel
    python36-test.x86_64                          3.6.6-5.el7                         epel
    python36-texttable.noarch                     1.4.0-2.el7                         epel
    python36-tinydb.noarch                        3.10.0-2.el7                        epel
    python36-tkinter.x86_64                       3.6.6-5.el7                         epel
    python36-toml.noarch                          0.9.4-4.el7                         epel
    python36-toolz.noarch                         0.9.0-8.el7                         epel
    python36-tornado.x86_64                       4.4.2-2.el7                         epel
    python36-traitlets.noarch                     4.3.2-3.el7                         epel
    python36-trololio.noarch                      1.0-2.el7                           epel
    python36-typing.noarch                        3.5.2.2-4.el7                       epel
    python36-unidiff.noarch                       0.5.4-2.el7                         epel
    python36-urllib3.noarch                       1.19.1-5.el7                        epel
    python36-uwsgidecorators.x86_64               2.0.17.1-2.el7                      epel
    python36-vcstools.noarch                      0.1.40-2.el7                        epel
    python36-virtualenv.noarch                    15.1.0-3.el7                        epel
    python36-vxi11.noarch                         0.9-2.el7                           epel
    python36-wcwidth.noarch                       0.1.7-3.el7                         epel
    python36-websocket-client.noarch              0.47.0-2.el7                        epel
    python36-whoosh.noarch                        2.7.4-4.el7                         epel
    python36-wrapt.x86_64                         1.10.4-8.el7                        epel
    python36-www-authenticate.noarch              0.9.2-4.el7                         epel
    python36-xapp.noarch                          1.0.1-9.el7                         epel
    python36-xapps-overrides.x86_64               1.0.4-14.el7                        epel
    python36-xlrd.noarch                          1.0.0-7.el7                         epel
    python36-xrootd.x86_64                        1:4.9.0-2.el7                       epel
    python36-yamlordereddictloader.noarch         0.4.0-2.el7                         epel
    python36-yara.x86_64                          3.8.1-2.el7.1                       epel
    python36-yubikey-piv-manager.noarch           1.4.2-6.el7                         epel
    python36-zope-component.noarch                1:4.1.0-5.el7                       epel
    python36-zope-configuration.noarch            4.0.3-13.el7                        epel
    python36-zope-event.noarch                    4.2.0-3.el7                         epel
    python36-zope-exceptions.noarch               4.0.5-6.el7                         epel
    python36-zope-i18nmessageid.x86_64            4.0.3-4.el7                         epel
    python36-zope-interface.x86_64                4.3.3-4.el7                         epel
    python36-zope-schema.noarch                   4.4.1-4.el7                         epel
    python36-zope-testing.noarch                  4.6.1-8.el7                         epel
    python36u.x86_64                              3.6.7-1.ius.centos7                 ius
    python36u-debug.x86_64                        3.6.7-1.ius.centos7                 ius
    python36u-debuginfo.x86_64                    3.6.7-1.ius.centos7                 ius
    python36u-devel.x86_64                        3.6.7-1.ius.centos7                 ius
    python36u-gunicorn.noarch                     19.8.1-1.ius.centos7                ius
    python36u-libs.x86_64                         3.6.7-1.ius.centos7                 ius
    python36u-lxml.x86_64                         4.2.0-1.ius.centos7                 ius
    python36u-lxml-debuginfo.x86_64               4.2.0-1.ius.centos7                 ius
    python36u-mod_wsgi.x86_64                     4.6.2-1.ius.centos7                 ius
    python36u-mod_wsgi-debuginfo.x86_64           4.6.2-1.ius.centos7                 ius
    python36u-pip.noarch                          9.0.1-1.ius.centos7                 ius
    python36u-psycopg2.x86_64                     2.7.4-1.ius.centos7                 ius
    python36u-psycopg2-debuginfo.x86_64           2.7.4-1.ius.centos7                 ius
    python36u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python36u-setproctitle.x86_64                 1.1.10-2.ius.centos7                ius
    python36u-setproctitle-debuginfo.x86_64       1.1.10-2.ius.centos7                ius
    python36u-setuptools.noarch                   39.0.1-1.ius.centos7                ius
    python36u-test.x86_64                         3.6.7-1.ius.centos7                 ius
    python36u-tkinter.x86_64                      3.6.7-1.ius.centos7                 ius
    python36u-tools.x86_64                        3.6.7-1.ius.centos7                 ius
    

    now the decision is to which to use python36 EPEL or python36u IUS Community versions of Python 3.6 and which to exclude in their respective yum config files at
    • /etc/yum.repos.d/ius.repo
    • /etc/yum.repos.d/epel.repo
    due to EPEL version looking to have more python-* related packages available and due to naming conventions it looks easier to exclude IUS Community YUM repo version of python36u as you just need to add to ius.repo python36u* exclusion wildcard so looks like for python 3.4 and 3.6 at least on centos 7, IUS Community versions are not required for addons/python36_install.sh and addons/python34_install.sh addons

    will have to look into the best solution for this

    what's output for this yum list command
    Code (Text):
    yum list python34* python35* python36* python34u* python35u* python36u* -q --enablerepo=ius| tr -s ' ' | column -t

    for now to do general yum updates you can just exclude python*
    Code (Text):
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi,city-fan.org --exclude=python*
    
     
  3. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Also did you specifically at one stage install python34 ? you can check yum history
    Code (Text):
    yum history list python34

    from output get transaction id and replace ID with that history list output ID(s)
    Code (Text):
    yum history info ID
     
  4. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Ok here's the solution I came up with.

    For CentOS 7, don't use IUS Community YUM Repo's python34u and python36u packages installed from addons/python34_install.sh and addons/python36_install.sh but instead use CentOS 7's EPEL yum repo versions of python34 and python36.

    So for CentOS 7 users, you can manually fix this if you had installed IUS Community python34u and/or python36u packages using commands below
    Code (Text):
    # remove ius community python34u
    yum -y remove python34u python34u-devel python34u-pip python34u-setuptools python34u-tools python34u-libs python34u-tkinter
    # remove ius community python36u
    yum -y remove python36u python36u-devel python36u-pip python36u-setuptools python36u-tools python36u-libs python36u-tkinter
    # install epel python34
    yum -y install python34 python34-devel python34-pip python34-setuptools python34-tools python34-libs python34-tkinter
    # install epel python36
    yum -y install python36 python36-devel python36-pip python36-setuptools python36-tools python36-libs python36-tkinter
    # reinstall removed dependencies from above removed ius community packages
    yum -y install cmake3 cmake3-data
    

    or you can use this quick bash script I wrote at fix python34/python34u and python36/python36u conflicts on centos 7
    Code (Text):
    curl -4s https://gist.github.com/centminmod/e050cf02794fb5bcdf3090c28efab202/raw/python-conflict-fix.sh | bash

    then for fresh 123.09beta01 installs, I could possible install EPEL yum repo's python34 by default ??? not sure on that one

    also seems centos 6 EPEL only has python34 and not python36 so IUS Community python36u would be needed on centos 6 but not centos 7 !
     
    Last edited: Apr 6, 2019
  5. pamamolf

    pamamolf Premium Member Premium Member

    3,397
    320
    83
    May 31, 2014
    Ratings:
    +604
    Local Time:
    6:30 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Code:
    Installed                                     Packages
    python34.x86_64                               3.4.9-2.el7                         @epel
    python34-libs.x86_64                          3.4.9-2.el7                         @epel
    python36u.x86_64                              3.6.7-1.ius.centos7                 @ius
    python36u-devel.x86_64                        3.6.7-1.ius.centos7                 @ius
    python36u-libs.x86_64                         3.6.7-1.ius.centos7                 @ius
    python36u-pip.noarch                          9.0.1-1.ius.centos7                 @ius
    python36u-setuptools.noarch                   39.0.1-1.ius.centos7                @ius
    python36u-tkinter.x86_64                      3.6.7-1.ius.centos7                 @ius
    python36u-tools.x86_64                        3.6.7-1.ius.centos7                 @ius
    Available                                     Packages
    python34.x86_64                               3.4.9-3.el7                         epel
    python34-Cython.x86_64                        0.28.4-3.el7                        epel
    python34-PyYAML.x86_64                        3.11-4.el7                          epel
    python34-apsw.x86_64                          3.7.17.r1-3.el7                     epel
    python34-asn1crypto.noarch                    0.24.0-7.el7                        epel
    python34-backports-ssl_match_hostname.noarch
    3.5.0.1-1.el7                                 epel
    python34-blosc.x86_64                         1.2.8-5.el7                         epel
    python34-bsddb3.x86_64                        6.2.6-4.el7                         epel
    python34-chardet.noarch                       2.3.0-5.el7                         epel
    python34-click.noarch                         6.7-8.el7                           epel
    python34-coverage.x86_64                      4.0.3-5.el7                         epel
    python34-cups.x86_64                          1.9.74-4.el7                        epel
    python34-dateutil.noarch                      1:2.4.2-5.el7                       epel
    python34-debug.x86_64                         3.4.9-3.el7                         epel
    python34-devel.x86_64                         3.4.9-3.el7                         epel
    python34-docutils.noarch                      0.12-0.10.20140510svn7747.el7       epel
    python34-empy.noarch                          3.3.3-2.el7                         epel
    python34-fedfind.noarch                       4.2.0-1.el7                         epel
    python34-idna.noarch                          2.7-2.el7                           epel
    python34-jsmva.noarch                         6.16.00-4.el7                       epel
    python34-jupyroot.x86_64                      6.16.00-4.el7                       epel
    python34-lark-parser.noarch                   0.6.4-6.el7                         epel
    python34-leveldb.x86_64                       0.194-2.el7                         epel
    python34-lhapdf.x86_64                        6.2.1-6.el7                         epel
    python34-libs.x86_64                          3.4.9-3.el7                         epel
    python34-markdown.noarch                      2.4.1-4.el7                         epel
    python34-mock.noarch                          2.0.0-2.el7                         epel
    python34-nose.noarch                          1.3.7-4.el7                         epel
    python34-numpy.x86_64                         1.10.4-7.el7                        epel
    python34-numpy-f2py.x86_64                    1.10.4-7.el7                        epel
    python34-parso.noarch                         0.3.1-2.el7                         epel
    python34-pbr.noarch                           4.2.0-3.el7                         epel
    python34-pdir2.noarch                         0.3.0-6.el7                         epel
    python34-pip.noarch                           8.1.2-8.el7                         epel
    python34-process-tests.noarch                 1.0.0-11.el7                        epel
    python34-psutil.x86_64                        2.2.1-5.el7                         epel
    python34-psycopg2.x86_64                      2.7.7-1.el7                         epel
    python34-psycopg2-tests.x86_64                2.7.7-1.el7                         epel
    python34-py.noarch                            1.4.32-2.el7                        epel
    python34-py4j.noarch                          0.10.7-4.el7                        epel
    python34-pycryptodomex.x86_64                 3.7.3-2.el7                         epel
    python34-pygraphviz.x86_64                    1.3-2.rc2.el7.2                     epel
    python34-pysocks.noarch                       1.6.8-6.el7                         epel
    python34-pytest.noarch                        2.9.2-3.el7                         epel
    python34-pytest-cov.noarch                    2.5.1-3.el7                         epel
    python34-pythia8.x86_64                       8.2.35-6.el7                        epel
    python34-pyvirtualize.noarch                  0.9-5.20181003git57d2307.el7        epel
    python34-pyvmomi.noarch                       6.7.1-3.el7                         epel
    python34-requests.noarch                      2.12.5-3.el7                        epel
    python34-root.x86_64                          6.16.00-4.el7                       epel
    python34-setuptools.noarch                    39.2.0-3.el7                        epel
    python34-setuptools_scm.noarch                1.17.0-3.el7                        epel
    python34-six.noarch                           1.11.0-3.el7                        epel
    python34-slack_cleaner.noarch                 0.5.0-2.el7                         epel
    python34-slacker.noarch                       0.12.0-4.el7                        epel
    python34-snowballstemmer.noarch               1.2.1-9.el7                         epel
    python34-tabulate.noarch                      0.8.3-6.el7                         epel
    python34-test.x86_64                          3.4.9-3.el7                         epel
    python34-tkinter.x86_64                       3.4.9-3.el7                         epel
    python34-tools.x86_64                         3.4.9-3.el7                         epel
    python34-urllib3.noarch                       1.19.1-5.el7                        epel
    python34-uwsgidecorators.x86_64               2.0.17.1-2.el7                      epel
    python34-virtualenv.noarch                    15.1.0-3.el7                        epel
    python34-xrootd.x86_64                        1:4.9.0-2.el7                       epel
    python34u.x86_64                              3.4.8-1.ius.centos7                 ius
    python34u-debug.x86_64                        3.4.8-1.ius.centos7                 ius
    python34u-debuginfo.x86_64                    3.4.8-1.ius.centos7                 ius
    python34u-devel.x86_64                        3.4.8-1.ius.centos7                 ius
    python34u-libs.x86_64                         3.4.8-1.ius.centos7                 ius
    python34u-pip.noarch                          9.0.1-1.ius.centos7                 ius
    python34u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python34u-setuptools.noarch                   39.0.1-1.ius.centos7                ius
    python34u-test.x86_64                         3.4.8-1.ius.centos7                 ius
    python34u-tkinter.x86_64                      3.4.8-1.ius.centos7                 ius
    python34u-tools.x86_64                        3.4.8-1.ius.centos7                 ius
    python34u-wheel.noarch                        0.30.0-1.ius.centos7                ius
    python35u.x86_64                              3.5.6-1.ius.centos7                 ius
    python35u-debug.x86_64                        3.5.6-1.ius.centos7                 ius
    python35u-debuginfo.x86_64                    3.5.6-1.ius.centos7                 ius
    python35u-devel.x86_64                        3.5.6-1.ius.centos7                 ius
    python35u-hiredis.x86_64                      0.2.0-1.ius.centos7                 ius
    python35u-hiredis-debuginfo.x86_64            0.2.0-1.ius.centos7                 ius
    python35u-libs.x86_64                         3.5.6-1.ius.centos7                 ius
    python35u-lxml.x86_64                         4.2.0-1.ius.centos7                 ius
    python35u-lxml-debuginfo.x86_64               4.2.0-1.ius.centos7                 ius
    python35u-mod_wsgi.x86_64                     4.6.2-1.ius.centos7                 ius
    python35u-mod_wsgi-debuginfo.x86_64           4.6.2-1.ius.centos7                 ius
    python35u-pip.noarch                          9.0.1-1.ius.centos7                 ius
    python35u-postgresql.x86_64                   1.2.1-1.ius.centos7                 ius
    python35u-postgresql-debuginfo.x86_64         1.2.1-1.ius.centos7                 ius
    python35u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python35u-setuptools.noarch                   39.0.1-1.ius.centos7                ius
    python35u-test.x86_64                         3.5.6-1.ius.centos7                 ius
    python35u-tkinter.x86_64                      3.5.6-1.ius.centos7                 ius
    python35u-tools.x86_64                        3.5.6-1.ius.centos7                 ius
    python36.x86_64                               3.6.6-5.el7                         epel
    python36-Cython.x86_64                        0.28.4-3.el7                        epel
    python36-PyMySQL.noarch                       0.9.2-2.el7                         epel
    python36-PyYAML.x86_64                        3.11-4.el7                          epel
    python36-aiosmtpd.noarch                      1.0-3.el7                           epel
    python36-arrow.noarch                         0.8.0-4.el7                         epel
    python36-asn1crypto.noarch                    0.24.0-7.el7                        epel
    python36-astroid.noarch                       1.4.9-3.el7                         epel
    python36-atpublic.x86_64                      0.5-2.el7                           epel
    python36-attrs.noarch                         17.4.0-4.el7                        epel
    python36-autowrap.noarch                      0.19.0-2.el7                        epel
    python36-backports_abc.noarch                 0.5-2.el7                           epel
    python36-bitarray.x86_64                      0.8.3-2.el7                         epel
    python36-blessed.noarch                       1.14.1-3.el7                        epel
    python36-blosc.x86_64                         1.2.8-5.el7                         epel
    python36-bottle.noarch                        0.12.13-2.el7                       epel
    python36-breathe.noarch                       4.2.0-4.el7                         epel
    python36-bsddb3.x86_64                        6.2.6-4.el7                         epel
    python36-cached_property.noarch               1.5.1-2.el7                         epel
    python36-cairo.x86_64                         1.10.0-25.el7                       epel
    python36-cairo-devel.x86_64                   1.10.0-25.el7                       epel
    python36-catkin-sphinx.noarch                 0.2.2-3.el7                         epel
    python36-certifi.noarch                       2018.10.15-4.el7                    epel
    python36-cffi.x86_64                          1.9.1-3.el7                         epel
    python36-chai.noarch                          1.1.1-5.el7                         epel
    python36-chardet.noarch                       2.3.0-5.el7                         epel
    python36-click.noarch                         6.7-8.el7                           epel
    python36-clustershell.noarch                  1.8.1-2.el7                         epel
    python36-clyent.noarch                        1.2.2-3.el7                         epel
    python36-collada.noarch                       0.4-16.el7                          epel
    python36-colorclass.noarch                    2.2.0-3.el7                         epel
    python36-contextlib2.noarch                   0.5.1-3.el7                         epel
    python36-cookies.noarch                       2.2.1-8.el7                         epel
    python36-cov-core.noarch                      1.15.0-9.el7                        epel
    python36-coverage.x86_64                      4.0.3-5.el7                         epel
    python36-crypto.x86_64                        2.6.1-16.el7                        epel
    python36-cryptography.x86_64                  2.3-2.el7                           epel
    python36-cryptography-vectors.noarch          2.3-1.el7                           epel
    python36-cups.x86_64                          1.9.74-4.el7                        epel
    python36-cytoolz.x86_64                       0.9.0.1-4.el7                       epel
    python36-datadog.noarch                       0.23.0-3.el7                        epel
    python36-dateutil.noarch                      1:2.4.2-5.el7                       epel
    python36-dbus.x86_64                          1.2.4-3.el7                         epel
    python36-ddt.noarch                           1.1.3-2.el7                         epel
    python36-debconf.noarch                       1.5.69-2.el7                        epel
    python36-debug.x86_64                         3.6.6-5.el7                         epel
    python36-decorator.noarch                     4.0.11-2.el7                        epel
    python36-defusedxml.noarch                    0.5.0-2.el7                         epel
    python36-devel.x86_64                         3.6.6-5.el7                         epel
    python36-distlib.noarch                       0.2.7-3.el7                         epel
    python36-distutils-extra.noarch               2.39-8.el7                          epel
    python36-dns.noarch                           1.15.0-8.el7                        epel
    python36-docker.noarch                        2.6.1-3.el7                         epel
    python36-docker-pycreds.noarch                0.2.1-2.el7                         epel
    python36-dockerpty.noarch                     0.4.1-10.el7                        epel
    python36-docopt.noarch                        0.6.2-8.el7                         epel
    python36-docutils.noarch                      0.12-0.10.20140510svn7747.el7       epel
    python36-easyargs.noarch                      0.9.4-3.el7                         epel
    python36-easygui.noarch                       0.96-20.el7                         epel
    python36-ecdsa.noarch                         0.13-10.el7                         epel
    python36-empy.noarch                          3.3.3-2.el7                         epel
    python36-enlighten.noarch                     1.1.0-2.el7                         epel
    python36-espresso-mpich.x86_64                4.0.1-2.el7                         epel
    python36-espresso-openmpi.x86_64              4.0.1-2.el7                         epel
    python36-execnet.noarch                       1.2.0-7.el7                         epel
    python36-falcon.x86_64                        1.4.1-2.el7                         epel
    python36-fido2.noarch                         0.5.0-4.el7                         epel
    python36-flexmock.noarch                      0.10.2-5.el7                        epel
    python36-flufl-bounce.noarch                  2.3-6.el7                           epel
    python36-flufl-i18n.noarch                    1.1.3-6.el7                         epel
    python36-flufl-lock.noarch                    2.4.1-6.el7                         epel
    python36-flufl-testing.noarch                 0.4-6.el7                           epel
    python36-freezegun.noarch                     0.1.19-2.el7                        epel
    python36-future.noarch                        0.16.0-7.el7                        epel
    python36-gammu.x86_64                         2.11-3.el7                          epel
    python36-gobject.x86_64                       3.22.0-6.el7                        epel
    python36-gobject-base.x86_64                  3.22.0-6.el7                        epel
    python36-gobject-devel.x86_64                 3.22.0-6.el7                        epel
    python36-greenlet.x86_64                      0.4.12-2.el7                        epel
    python36-greenlet-devel.x86_64                0.4.12-2.el7                        epel
    python36-gssapi.x86_64                        1.3.0-5.el7                         epel
    python36-hexdump.noarch                       3.4-0.3.20160818hg66325cb5fed8.el7  epel
    python36-hypothesis.noarch                    3.12.0-2.el7                        epel
    python36-idle.x86_64                          3.6.6-5.el7                         epel
    python36-idna.noarch                          2.7-2.el7                           epel
    python36-idstools.noarch                      0.6.3-2.el7                         epel
    python36-ipython_genutils.noarch              0.1.0-8.el7                         epel
    python36-iso8601.noarch                       0.1.11-8.el7                        epel
    python36-isort.noarch                         4.2.5-9.el7                         epel
    python36-ivi.noarch                           0.14.9-7.el7                        epel
    python36-jaydebeapi.noarch                    1.1.1-2.el7                         epel
    python36-jedi.noarch                          0.10.2-4.el7                        epel
    python36-jinja2.noarch                        2.8-3.el7                           epel
    python36-jpype.x86_64                         0.6.3-8.el7                         epel
    python36-jsmva.noarch                         6.16.00-4.el7                       epel
    python36-jsonschema.noarch                    2.5.1-4.el7                         epel
    python36-jupyroot.x86_64                      6.16.00-4.el7                       epel
    python36-jupyter-core.noarch                  4.3.0-2.el7                         epel
    python36-jwt.noarch                           1.6.4-2.el7                         epel
    python36-keyring.noarch                       5.0-4.el7                           epel
    python36-kitchen.noarch                       1.2.5-2.el7                         epel
    python36-lammps.x86_64                        20181212-2.el7                      epel
    python36-lark-parser.noarch                   0.6.4-6.el7                         epel
    python36-lazr-config.noarch                   2.1-6.el7                           epel
    python36-lazr-delegates.noarch                2.0.3-6.el7                         epel
    python36-lazr-smtptest.noarch                 2.0.3-7.el7                         epel
    python36-lazy-object-proxy.x86_64             1.2.2-2.el7                         epel
    python36-ldap3.noarch                         2.5.2-2.el7                         epel
    python36-lensfun.x86_64                       0.3.2-14.el7                        epel
    python36-leveldb.x86_64                       0.194-2.el7                         epel
    python36-lhapdf.x86_64                        6.2.1-6.el7                         epel
    python36-libdiscid.x86_64                     0.4.1-12.el7                        epel
    python36-libs.x86_64                          3.6.6-5.el7                         epel
    python36-llfuse.x86_64                        1.0-2.el7                           epel
    python36-locket.noarch                        0.2.0-3.el7                         epel
    python36-lxc.x86_64                           1.0.11-2.el7                        epel
    python36-lz4.x86_64                           0.8.2-2.el7                         epel
    python36-markdown.noarch                      2.4.1-4.el7                         epel
    python36-markupsafe.x86_64                    0.23-2.el7                          epel
    python36-maxminddb.x86_64                     1.4.0-3.el7                         epel
    python36-mccabe.noarch                        0.6.1-7.el7                         epel
    python36-mimeparse.noarch                     1.6.0-5.el7                         epel
    python36-mock.noarch                          2.0.0-2.el7                         epel
    python36-msgpack.x86_64                       0.5.6-5.el7                         epel
    python36-multilib.noarch                      1.2-3.el7                           epel
    python36-mysql.x86_64                         1.3.12-2.el7                        epel
    python36-mysql-debug.x86_64                   1.3.12-2.el7                        epel
    python36-nbformat.noarch                      4.4.0-2.el7                         epel
    python36-neovim.noarch                        0.3.1-3.el7                         epel
    python36-netaddr.noarch                       0.7.18-3.el7                        epel
    python36-netcdf4.x86_64                       1.2.7-4.el7                         epel
    python36-nordugrid-arc.x86_64                 5.4.4-1.el7                         epel
    python36-nose.noarch                          1.3.7-4.el7                         epel
    python36-nose2.noarch                         0.6.5-6.el7                         epel
    python36-numexpr.x86_64                       2.5.2-3.el7                         epel
    python36-numpy.x86_64                         1.10.4-7.el7                        epel
    python36-numpy-f2py.x86_64                    1.10.4-7.el7                        epel
    python36-olefile.noarch                       0.46-2.el7                          epel
    python36-openqa_client.noarch                 1.3.1-6.el7                         epel
    python36-pamela.noarch                        0.3.0-2.el7                         epel
    python36-paramiko.noarch                      2.1.1-0.10.el7                      epel
    python36-parso.noarch                         0.3.1-2.el7                         epel
    python36-pathspec.noarch                      0.5.3-2.el7                         epel
    python36-pbr.noarch                           4.2.0-3.el7                         epel
    python36-pdfminer.noarch                      20160614-5.el7                      epel
    python36-pdir2.noarch                         0.3.0-6.el7                         epel
    python36-petsc4py-mpich.x86_64                3.9.1-4.el7                         epel
    python36-petsc4py-openmpi.x86_64              3.9.1-4.el7                         epel
    python36-pg8000.noarch                        1.10.5-2.el7                        epel
    python36-pid.noarch                           2.2.3-2.el7                         epel
    python36-pika.noarch                          0.10.0-10.el7                       epel
    python36-pika-doc.noarch                      0.10.0-10.el7                       epel
    python36-pip.noarch                           8.1.2-8.el7                         epel
    python36-pkgconfig.noarch                     1.1.0-8.el7                         epel
    python36-pluginlib.noarch                     0.6.1-2.el7                         epel
    python36-ply.noarch                           3.9-2.el7                           epel
    python36-polib.noarch                         1.0.7-10.el7                        epel
    python36-prelude.x86_64                       4.1.0-3.el7                         epel
    python36-prelude-correlator.x86_64            4.1.1-4.el7                         epel
    python36-preludedb.x86_64                     4.1.0-2.el7                         epel
    python36-pretend.noarch                       1.0.8-4.el7                         epel
    python36-process-tests.noarch                 1.0.0-11.el7                        epel
    python36-productmd.noarch                     1.20-3.el7                          epel
    python36-prompt_toolkit.noarch                1.0.15-2.el7                        epel
    python36-psutil.x86_64                        2.2.1-5.el7                         epel
    python36-psycopg2.x86_64                      2.7.7-1.el7                         epel
    python36-psycopg2-tests.x86_64                2.7.7-1.el7                         epel
    python36-ptyprocess.noarch                    0.5.1-7.el7                         epel
    python36-py.noarch                            1.4.32-2.el7                        epel
    python36-py4j.noarch                          0.10.7-4.el7                        epel
    python36-pyOpenSSL.noarch                     17.3.0-1.el7                        epel
    python36-pyasn1.noarch                        0.1.9-2.el7                         epel
    python36-pyasn1-modules.noarch                0.1.9-2.el7                         epel
    python36-pycmd.noarch                         1.2-5.el7                           epel
    python36-pycodestyle.noarch                   2.0.0-6.el7                         epel
    python36-pycosat.x86_64                       0.6.3-2.el7                         epel
    python36-pycparser.noarch                     2.14-2.el7                          epel
    python36-pycryptodomex.x86_64                 3.7.3-2.el7                         epel
    python36-pycurl.x86_64                        7.43.0-6.el7                        epel
    python36-pyev.x86_64                          0.9.0-0.2.20130610gite31d137.el7    epel
    python36-pyflakes.noarch                      1.6.0-4.el7                         epel
    python36-pygithub.noarch                      1.39-5.el7                          epel
    python36-pygments.noarch                      2.2.0-2.el7                         epel
    python36-pygraphviz.x86_64                    1.3-2.rc2.el7.2                     epel
    python36-pyicu.x86_64                         1.5-26.el7                          epel
    python36-pylint.noarch                        1.6.5-5.el7                         epel
    python36-pylint-gui.noarch                    1.6.5-5.el7                         epel
    python36-pymilter.x86_64                      1.0.3-2.el7                         epel
    python36-pymssql.x86_64                       2.1.3-3.el7                         epel
    python36-pypandoc.noarch                      1.3.3-3.el7                         epel
    python36-pyroute2.noarch                      0.4.13-2.el7                        epel
    python36-pyside.x86_64                        1.2.4-2.el7                         epel
    python36-pysocks.noarch                       1.6.8-6.el7                         epel
    python36-pytest.noarch                        2.9.2-3.el7                         epel
    python36-pytest-catchlog.noarch               1.2.2-3.el7                         epel
    python36-pytest-cov.noarch                    2.5.1-3.el7                         epel
    python36-pytest-runner.noarch                 3.0-2.el7                           epel
    python36-pytest-xdist.noarch                  1.17.1-3.el7                        epel
    python36-pythia8.x86_64                       8.2.35-6.el7                        epel
    python36-pytz.noarch                          2017.2-3.el7                        epel
    python36-pyusb.noarch                         1.0.2-3.el7                         epel
    python36-pyvirtualize.noarch                  0.9-5.20181003git57d2307.el7        epel
    python36-pyvmomi.noarch                       6.7.1-3.el7                         epel
    python36-pyxdg.noarch                         0.25-7.el7                          epel
    python36-pyxs.noarch                          0.4.1-2.el7                         epel
    python36-qpid-proton.x86_64                   0.26.0-2.el7                        epel
    python36-regex.x86_64                         2019.03.09-1.el7                    epel
    python36-rencode.x86_64                       1.0.5-4.el7                         epel
    python36-requests.noarch                      2.12.5-3.el7                        epel
    python36-responses.noarch                     0.5.1-7.el7                         epel
    python36-root.x86_64                          6.16.00-4.el7                       epel
    python36-rope.noarch                          0.12.0-2.el7                        epel
    python36-rpm.x86_64                           4.11.3-3.el7                        epel
    python36-ruamel-yaml.x86_64                   0.13.14-2.el7                       epel
    python36-scandir.x86_64                       1.9.0-2.el7                         epel
    python36-scapy.noarch                         2.4.0-3.el7                         epel
    python36-scipy.x86_64                         0.18.1-2.el7                        epel
    python36-scons.noarch                         3.0.4-4.el7                         epel
    python36-scripttest.noarch                    1.3.0-10.el7                        epel
    python36-setproctitle.x86_64                  1.1.6-3.el7                         epel
    python36-setuptools.noarch                    39.2.0-3.el7                        epel
    python36-setuptools_scm.noarch                1.17.0-3.el7                        epel
    python36-sh.noarch                            1.12.14-7.el7                       epel
    python36-simplejson.x86_64                    3.10.0-2.el7                        epel
    python36-simplepam.noarch                     0.1.5-7.el7                         epel
    python36-simplepath.noarch                    0.3.4-2.el7                         epel
    python36-six.noarch                           1.11.0-3.el7                        epel
    python36-slacker.noarch                       0.12.0-4.el7                        epel
    python36-snowballstemmer.noarch               1.2.1-9.el7                         epel
    python36-spglib.x86_64                        1.11.1-2.el7                        epel
    python36-sphinx.noarch                        1.2.3-4.el7                         epel
    python36-sphinx-autobuild.noarch              0.7.1-9.el7                         epel
    python36-sphinx-latex.noarch                  1.2.3-4.el7                         epel
    python36-sphinx-theme-alabaster.noarch        0.7.9-2.el7                         epel
    python36-spur.noarch                          0.3.17-2.el7                        epel
    python36-sqlalchemy.x86_64                    1.1.3-2.el7                         epel
    python36-structlog.noarch                     17.2.0-2.el7                        epel
    python36-suds.noarch                          0.6-2.el7                           epel
    python36-terminado.noarch                     0.6-3.el7                           epel
    python36-test.x86_64                          3.6.6-5.el7                         epel
    python36-texttable.noarch                     1.4.0-2.el7                         epel
    python36-tinydb.noarch                        3.10.0-2.el7                        epel
    python36-tkinter.x86_64                       3.6.6-5.el7                         epel
    python36-toml.noarch                          0.9.4-4.el7                         epel
    python36-toolz.noarch                         0.9.0-8.el7                         epel
    python36-tornado.x86_64                       4.4.2-2.el7                         epel
    python36-traitlets.noarch                     4.3.2-3.el7                         epel
    python36-trololio.noarch                      1.0-2.el7                           epel
    python36-typing.noarch                        3.5.2.2-4.el7                       epel
    python36-unidiff.noarch                       0.5.4-2.el7                         epel
    python36-urllib3.noarch                       1.19.1-5.el7                        epel
    python36-uwsgidecorators.x86_64               2.0.17.1-2.el7                      epel
    python36-vcstools.noarch                      0.1.40-2.el7                        epel
    python36-virtualenv.noarch                    15.1.0-3.el7                        epel
    python36-vxi11.noarch                         0.9-2.el7                           epel
    python36-wcwidth.noarch                       0.1.7-3.el7                         epel
    python36-websocket-client.noarch              0.47.0-2.el7                        epel
    python36-whoosh.noarch                        2.7.4-4.el7                         epel
    python36-wrapt.x86_64                         1.10.4-8.el7                        epel
    python36-www-authenticate.noarch              0.9.2-4.el7                         epel
    python36-xapp.noarch                          1.0.1-9.el7                         epel
    python36-xapps-overrides.x86_64               1.0.4-14.el7                        epel
    python36-xlrd.noarch                          1.0.0-7.el7                         epel
    python36-xrootd.x86_64                        1:4.9.0-2.el7                       epel
    python36-yamlordereddictloader.noarch         0.4.0-2.el7                         epel
    python36-yara.x86_64                          3.8.1-2.el7.1                       epel
    python36-yubikey-piv-manager.noarch           1.4.2-6.el7                         epel
    python36-zope-component.noarch                1:4.1.0-5.el7                       epel
    python36-zope-configuration.noarch            4.0.3-13.el7                        epel
    python36-zope-event.noarch                    4.2.0-3.el7                         epel
    python36-zope-exceptions.noarch               4.0.5-6.el7                         epel
    python36-zope-i18nmessageid.x86_64            4.0.3-4.el7                         epel
    python36-zope-interface.x86_64                4.3.3-4.el7                         epel
    python36-zope-schema.noarch                   4.4.1-4.el7                         epel
    python36-zope-testing.noarch                  4.6.1-8.el7                         epel
    python36u-debug.x86_64                        3.6.7-1.ius.centos7                 ius
    python36u-debuginfo.x86_64                    3.6.7-1.ius.centos7                 ius
    python36u-gunicorn.noarch                     19.8.1-1.ius.centos7                ius
    python36u-lxml.x86_64                         4.2.0-1.ius.centos7                 ius
    python36u-lxml-debuginfo.x86_64               4.2.0-1.ius.centos7                 ius
    python36u-mod_wsgi.x86_64                     4.6.2-1.ius.centos7                 ius
    python36u-mod_wsgi-debuginfo.x86_64           4.6.2-1.ius.centos7                 ius
    python36u-psycopg2.x86_64                     2.7.4-1.ius.centos7                 ius
    python36u-psycopg2-debuginfo.x86_64           2.7.4-1.ius.centos7                 ius
    python36u-redis.noarch                        2.10.6-1.ius.centos7                ius
    python36u-setproctitle.x86_64                 1.1.10-2.ius.centos7                ius
    python36u-setproctitle-debuginfo.x86_64       1.1.10-2.ius.centos7                ius
    python36u-test.x86_64                         3.6.7-1.ius.centos7                 ius
    Code:
    Loaded plugins: fastestmirror, priorities, versionlock
    ID     | Command line             | Date and time    | Action(s)      | Altered
    -------------------------------------------------------------------------------
        77 | -y install cmake3        | 2019-03-12 20:46 | Install        |    8
    history list
    Code:
    Loaded plugins: fastestmirror, priorities, versionlock
    Transaction ID : 77
    Begin time     : Tue Mar 12 20:46:40 2019
    Begin rpmdb    : 797:9e6c6b04a7841537cb0e8a9e65f800d2f7552904
    End time       :            20:46:48 2019 (8 seconds)
    End rpmdb      : 805:dfb8dcb90d9e494c25309fcc97cb2fac3fb06518
    User           : root <root>
    Return-Code    : Success
    Command Line   : -y install cmake3
    Transaction performed with:
        Installed     rpm-4.11.3-35.el7.x86_64                      @base
        Installed     yum-3.4.3-161.el7.centos.noarch               @base
        Installed     yum-metadata-parser-1.1.4-10.el7.x86_64       installed
        Installed     yum-plugin-fastestmirror-1.1.31-50.el7.noarch @base
        Installed     yum-plugin-versionlock-1.1.31-50.el7.noarch   @base
    Packages Altered:
        Install     cmake3-3.13.4-1.el7.x86_64            @epel
        Dep-Install cmake3-data-3.13.4-1.el7.noarch       @epel
        Dep-Install emacs-filesystem-1:24.3-22.el7.noarch @base
        Dep-Install jsoncpp-0.10.5-2.el7.x86_64           @epel
        Dep-Install libuv-1:1.26.0-1.el7.x86_64           @epel
        Dep-Install python34-3.4.9-2.el7.x86_64           @epel
        Dep-Install python34-libs-3.4.9-2.el7.x86_64      @epel
        Dep-Install rhash-1.3.4-2.el7.x86_64              @epel
    history info
     
  6. pamamolf

    pamamolf Premium Member Premium Member

    3,397
    320
    83
    May 31, 2014
    Ratings:
    +604
    Local Time:
    6:30 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Running cmupdate and then centmin and exiting with 24 now the issue is fixed on that server without any errors but on the other servers that was ok i am getting this error now:

     
  7. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    interesting, cmake3 install, installed python34 as a dependency ! and cmake3 install is part of libzip install for php 7.3.3 usage of libzip

    ok will look into that
     
  8. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    try running centmin.sh menu option 24 in debug mode logged to debug.txt text file in /root/centminlogs directory by running these 3 commands
    Code (Text):
    cd /usr/local/src/centminmod
    echo 24 | bash -x centmin.sh 2>&1 | awk '{ print strftime("%Y-%m-%d %H:%M:%S"), $0; fflush(); }' | tee /root/centminlogs/debug.txt && echo "debug log saved at /root/centminlogs/debug.txt"
    sed -i "s|$(hostname)|hostname|g" /root/centminlogs/debug.txt
    

    Then copy the contents of /root/centminlogs/debug.txt into a pastebin.com or gist.github.com shared link - with an sensitive info masked. At least server hostname will be replaced with word hostname instead via last sed replacement line.
     
  9. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,174
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,078
    Local Time:
    1:30 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    fixed now :)
     
    • Like Like x 1
  10. pamamolf

    pamamolf Premium Member Premium Member

    3,397
    320
    83
    May 31, 2014
    Ratings:
    +604
    Local Time:
    6:30 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    All good now except Centos server 6.X :

    Code:
    -------------------------------------------------------------
      To list available YUM Updates type:
    -------------------------------------------------------------
      yum list updates --disableplugin=priorities,versionlock --setopt=deltarpm=0 --enablerepo=remi,city-fan.org --exclude=python34-*,python35-*,python36-*
    -------------------------------------------------------------
      Following Updates are available:
    -------------------------------------------------------------
    Main config did not have a deltarpm attr. before setopt
    ImageMagick6.x86_64                       6.9.10.37-1.el6.remi              remi
    ImageMagick6-c++.x86_64                   6.9.10.37-1.el6.remi              remi
    ImageMagick6-c++-devel.x86_64             6.9.10.37-1.el6.remi              remi
    ImageMagick6-devel.x86_64                 6.9.10.37-1.el6.remi              remi
    ImageMagick6-libs.x86_64                  6.9.10.37-1.el6.remi              remi
    Code:
    Main config did not have a deltarpm attr. before setopt
    It is a very old setup and maybe i miss something related .....?
     
    • Informative Informative x 1