Welcome to Centmin Mod Community
Register Now

pyOpenSSL module

Discussion in 'Install & Upgrades or Pre-Install Questions' started by pamamolf, Nov 30, 2018.

  1. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    9:20 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Hello

    I just got this:

    Updating : kernelcare-2.16-2.x86_64 1/2
    pyOpenSSL module is not found. To be able to validate SSL certificates of hosts with SNI support please, install pyOpenSSL >= 0.13

    Maybe it will be a good idea to add a check and install pyOpenSSL on Centminmod installations?

    Thank you
     
  2. eva2000

    eva2000 Administrator Staff Member

    37,227
    8,133
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,521
    Local Time:
    5:20 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what command was that from ?
     
  3. eva2000

    eva2000 Administrator Staff Member

    37,227
    8,133
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,521
    Local Time:
    5:20 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    updated 123.09beta01 to install pyOpenSSL on fresh installs by default :)
     
    • Like Like x 1
  4. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    9:20 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    yum update --disableplugin=priorities --enablerepo=remi,city-fan.org

    Then a kernel care update was there and when it tries to update it i got that message...
     
  5. eva2000

    eva2000 Administrator Staff Member

    37,227
    8,133
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,521
    Local Time:
    5:20 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    should be sorted for future 123.09beta01 fresh installs now :)
     
    • Like Like x 1
..