Want more timely Centmin Mod News Updates?
Become a Member

Problem with FTP

Discussion in 'Other Centmin Mod Installed software' started by SnowyDane, Feb 6, 2016.

  1. SnowyDane

    SnowyDane New Member

    9
    3
    3
    Feb 6, 2016
    Denmark
    Ratings:
    +4
    Local Time:
    12:46 AM
    1.9.10
    5.5
    Hi!

    So i've got a problem with the FTP server. I created my nginx vhost via menu option #2 - in the centmin menu, and while that's working fine. I can't login to the FTP server.

    I'm using the auto generated password for logging in. And connecting via the domain, assigned to the vhost. This is the Filezilla log:

    Code:
    Status:    TLS connection established.
    Command:    USER dev-sno
    Response:    331 User dev-sno OK. Password required
    Command:    PASS *********************
    Response:    530 Login authentication failed
    Error:    Critical error: Could not connect to server
    I have accepted the custom ssl certificate in filezilla.

    Anyone that has an idea what i should do? Thanks.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    8:46 AM
    Nginx 1.13.x
    MariaDB 5.5
    Which version of centmin mod are you using ? 123.08 or 123.09beta01 ? There are a few bugs with the auto generated passwords having characters that pure-ftpd doesn't accept but i believe i already fixed them. But could be others.
    • Did you make sure to enable explicit TLS/SSL mode and enable PASV passive mode like in 1st post here.
    From 1st post here, try the pure-pw commands to display pure-ftpd user details and change the user password. Also pure-pw manual is here and http://download.pureftpd.org/pub/pure-ftpd/doc/README.Virtual-Users

    list all pure-ftpd created virtual FTP users
    Code:
    pure-pw list
    Code:
    pure-pw list
    ftpuser /usr/local/nginx/html/./ 
    ftpuser2 /usr/local/nginx/html/./ 
    ftpuser3 /usr/local/nginx/html/./ 
    ftpuser4 /home/nginx/domains/domain1.com/./ 
    ftpuser6 /home/nginx/domains/sub.domain1.com/./ 
    ftpuser5 /home/nginx/domains/domain2.com/./
    to delete virtual FTP user
    Code:
    pure-pw userdel FTPUSERNAME
    pure-pw mkdb
    change virtual FTP user's password
    Code:
    pure-pw passwd FTPUSERNAME
    pure-pw mkdb
    show full details for an specific pure-ftpd virtual FTP user
    Code:
    pure-pw show FTPUSERNAME
    password is encrypted

    Code:
    pure-pw show ftpuser5
    
    Login : ftpuser5
    Password : $1$msgfvdN0$51dhLdPGiCQpQEwtZ30kF1
    UID : 500 (nginx)
    GID : 500 (nginx)
    Directory : /home/nginx/domains/domain2.com/./
    Full name :
    Download bandwidth : 0 Kb (unlimited)
    Upload bandwidth : 0 Kb (unlimited)
    Max files : 0 (unlimited)
    Max size : 0 Mb (unlimited)
    Ratio : 0:0 (unlimited:unlimited)
    Allowed local IPs :
    Denied local IPs :
    Allowed client IPs :
    Denied client IPs :
    Time restrictions : 0000-0000 (unlimited)
    Max sim sessions : 0 (unlimited)
    Let me know if changing the password for your pure-ftpd virtual username works and allows you to connect. If it works, can you share the old non-working password here so I can see if i need to filter out other characters.
     
    • Informative Informative x 2
    • Agree Agree x 1
  3. Ahmad

    Ahmad Active Member

    209
    80
    28
    Apr 13, 2015
    Ratings:
    +150
    Local Time:
    12:46 AM
    1.9.9
    10.1.10
    That means your username/password is wrong.

    Run
    Code:
    pure-pw passwd dev-sno
    to change your ftp password for the user "dev-sno".
    Then after that, run
    Code:
    pure-pw mkdb
    to write the changes to the database and try again.
    (Do not copy/past passwords as that is likely to add some whitespace which results in an invalid pass.

    Edit: too slow, can't beat eva :(
     
    • Informative Informative x 4
  4. ModeltogTossen

    ModeltogTossen I wish I could??

    313
    97
    28
    Dec 20, 2015
    Denmark
    Ratings:
    +143
    Local Time:
    12:46 AM
    1.9.12
    10.0.23
    Yeah - That man is everywhere anytime - I do, and perhaps others love him for it ;-) .. @Ahmad Have a nice weekend.
     
    • Like Like x 2
    • Agree Agree x 1
  5. SnowyDane

    SnowyDane New Member

    9
    3
    3
    Feb 6, 2016
    Denmark
    Ratings:
    +4
    Local Time:
    12:46 AM
    1.9.10
    5.5
    @Ahmad - Thanks anyway mate! :)

    @eva2000 - Thanks for post, will check out those threads for sure.
    I'm running 1.2.3-eva2000.08

    I changed the password on the user, using a combination of letters and numbers. But still face the same error. FileZilla is setup to require explicit FTP over TLS, and set to PASV mode.

    Also tried restarting pure-ftp, but didn't change anything. What's the path to the pure-ftp log file? Maybe that has some clues.
     
  6. Ahmad

    Ahmad Active Member

    209
    80
    28
    Apr 13, 2015
    Ratings:
    +150
    Local Time:
    12:46 AM
    1.9.9
    10.1.10
    /var/log/pureftpd.log
     
    • Like Like x 1
  7. SnowyDane

    SnowyDane New Member

    9
    3
    3
    Feb 6, 2016
    Denmark
    Ratings:
    +4
    Local Time:
    12:46 AM
    1.9.10
    5.5
    Heureka! I solved the problem.

    It was the auto generated password that was the issue. I changed it, but didn't write the
    Code:
    pure-pw mkdb
    command.

    Thanks for the help guys, really appreciate it. :)
     
    • Like Like x 1
    • Optimistic Optimistic x 1
  8. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    8:46 AM
    Nginx 1.13.x
    MariaDB 5.5
  9. SnowyDane

    SnowyDane New Member

    9
    3
    3
    Feb 6, 2016
    Denmark
    Ratings:
    +4
    Local Time:
    12:46 AM
    1.9.10
    5.5
    @eva2000 - It was:

    Code:
    fkaBNiu9cZpujKR7vDMoz
    Strange it didn't work, as it only consists of small/big letters and numbers.
     
  10. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    8:46 AM
    Nginx 1.13.x
    MariaDB 5.5
    strange indeed.. could be your SSH clients characterset / character encoding and copy and paste ?
     
  11. Ahmad

    Ahmad Active Member

    209
    80
    28
    Apr 13, 2015
    Ratings:
    +150
    Local Time:
    12:46 AM
    1.9.9
    10.1.10
    It happens sometimes when you double click to copy/paste the password, it marks whitespace at the end/front too and copies it.
    Really nothing you can do about this, other than copying carefully.
     
    • Agree Agree x 1
  12. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    8:46 AM
    Nginx 1.13.x
    MariaDB 5.5
    interesting never done that before, i also highlight with my mouse and copy and paste :)
     
  13. SnowyDane

    SnowyDane New Member

    9
    3
    3
    Feb 6, 2016
    Denmark
    Ratings:
    +4
    Local Time:
    12:46 AM
    1.9.10
    5.5
    Could be the encoding, but dosen't quite make sense as i copied all the default messages after the install completed. Cant really notice any errors, but oh well. Magic Leprechauns in the computer again lol. :p
     
  14. Ahmad

    Ahmad Active Member

    209
    80
    28
    Apr 13, 2015
    Ratings:
    +150
    Local Time:
    12:46 AM
    1.9.9
    10.1.10
    It happened to me but I cannot remember on which OS it happens (windows 8/10, ubuntu or debian).
    I don't think it was ubuntu/debian but cannot say for sure.
     
    • Informative Informative x 1
  15. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    6:46 AM
    1.11
    10.2
    I encounter it sometimes on my Linux Mint, that's why I use mouse to highlight. :)
     
    • Informative Informative x 1
  16. hardousse

    hardousse Member

    84
    25
    18
    Dec 15, 2015
    Sweden
    Ratings:
    +37
    Local Time:
    1:46 AM
    1.11.*
    10.1*
    hi
    i still have this problem about password generate by centmin option 2 i use the last beta and centos 7.2 the ftp connection fail with generated password but after i change it everything work fine, its a bug ?