Join the community today
Become a Member

Problem with an update

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Peter Downey, Jun 3, 2014.

  1. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    4:48 AM
    Hey guys,

    I'm getting an error when I try to do a yum update. I'm still pretty new to this whole Linux thing, so I was hoping somebody could give me advice before I try to fix this myself by trial and error :(

    Error: Package: glibc-2.12-1.132.el6.i686 (@base)
    Requires: glibc-common = 2.12-1.132.el6
    Removing: glibc-common-2.12-1.132.el6.x86_64 (@base)
    glibc-common = 2.12-1.132.el6
    Updated By: glibc-common-2.12-1.132.el6_5.2.x86_64 (updates)
    glibc-common = 2.12-1.132.el6_5.2
    Available: glibc-common-2.12-1.132.el6_5.1.x86_64 (updates)
    glibc-common = 2.12-1.132.el6_5.1
    You could try using --skip-broken to work around the problem
    ** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
    gamin-0.1.10-9.el6.i686 has missing requires of libglib-2.0.so.0
    glibc-2.12-1.132.el6.i686 has missing requires of libfreebl3.so
    glibc-2.12-1.132.el6.i686 has missing requires of libfreebl3.so(NSSRAWHASH_3.12.3)

    It would be awesome if somebody could help explain the error so I can learn how to fix something like this myself.

    Also, when I do yum update --skip-broken I get this.

    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

    1. You have an upgrade for libxml2 which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of libxml2 of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude libxml2.otherarch ... this should give you an error
    message showing the root cause of the problem.

    2. You have multiple architectures of libxml2 installed, but
    yum can only see an upgrade for one of those arcitectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

    3. You have duplicate versions of libxml2 installed already.
    You can use "yum check" to get yum show these errors.

    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).

    Protected multilib versions: libxml2-2.7.6-14.el6_5.1.x86_64 != libxml2-2.7.6-14.el6.i686
    ** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
    gamin-0.1.10-9.el6.i686 has missing requires of libglib-2.0.so.0
    glibc-2.12-1.132.el6.i686 has missing requires of libfreebl3.so
    glibc-2.12-1.132.el6.i686 has missing requires of libfreebl3.so(NSSRAWHASH_3.12.3)
     
  2. eva2000

    eva2000 Administrator Staff Member

    27,719
    6,331
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,332
    Local Time:
    6:48 PM
    Nginx 1.13.x
    MariaDB 5.5
    @Peter Downey what type of VPS - Xen, KVN, OpenVZ ? or dedicated server you using ?

    Some web hosts VPS OS templates might have mixed .i686 and x86_64 YUM installed pages out of the box which can cause these problems

    First, check which type of server you have with command whether it's i686 or x86_64 based

    Code:
    uname -m
    if it's x86_x64 based, then remove .i686 packages before doing yum update with command

    Code:
    yum erase \*.i686
    then do update

    Code:
    yum clean all
    yum -y update
     
    • Like Like x 2
  3. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    4:48 AM
    Thanks, that makes so much sense. It's not the first time I've had trouble with the *.i686 stuff and I couldn't understand if I had done something incorrect.

    I really appreciate the explaination.
     
  4. RoldanLT

    RoldanLT Well-Known Member

    3,785
    928
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,252
    Local Time:
    4:48 PM
    1.11
    10.2
    Maybe add this to CentminMod? :)
    On first install.
     
    • Like Like x 1
  5. eva2000

    eva2000 Administrator Staff Member

    27,719
    6,331
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,332
    Local Time:
    6:48 PM
    Nginx 1.13.x
    MariaDB 5.5
    nice suggestion !

    would have to exclude Xen 32bit VPS from such as it can get confused

     
    • Like Like x 1