Welcome to Centmin Mod Community
Become a Member

POPUP Inside website is not working anymore.

Discussion in 'Install & Upgrades or Pre-Install Questions' started by EckyBrazzz, Mar 22, 2019.

  1. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7.5 64bit ?
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: i.e. 1.15.9 with latest mod pagespeed
    • PHP Version Installed: PHP 7.3.3 (cli)
    • MariaDB MySQL Version Installed:10.2.xx
    • When was last time updated Centmin Mod code base ? : yesteday
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      MARCH_TARGETNATIVE='n'
      LETSENCRYPT_DETECT='y'
      NGXDYNAMIC_NGXPAGESPEED='y'
      NGINX_PAGESPEED='y'
      PHP_PGO='y'
      NGXDYNAMIC_BROTLI='y'
      NGINX_LIBBROTLI='y'
      ENABLE_MARIADBTENTWOUPGRADE='y'
      

    I have several domains and one is hosted with centmindmod with wordpress. The domain is Melhor Cupom site do Brasil - Melhor Cupom site do Brasil and the problem is that the popups don´t work anymore with this domain like with Coupons Nederland -

    If you wan´t to close the page a popup should appear from mailchimp. Also if you click GET OFFER there should be an popuop but on my fresh and modified install it won´t work.

    I think this is a NGINX issue but I´m not sure about that.

    I hope that someone can give me a helping hand to resolve this issue because I really like the system.

    I also tried it with ISPCONFIG and had no problems with it.
     
    Last edited: Mar 22, 2019
  2. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    https://brasilcupom.com.br/ and https://nederland.gratis.coupons/
    don't seem to be using Centmin Mod as headers return PHP version info which Centmin Mod doesn't do by default so make sure the DNS for that domain is pointing to correct server IP running Centmin Mod
    Code (Text):
    HTTP/2 200
    date: Fri, 22 Mar 2019 16:51:32 GMT
    content-type: text/html; charset=UTF-8
    set-cookie: __cfduid=d5c7309bec72061ea09fa308defe782da1553273492; expires=Sat, 21-Mar-20 16:51:32 GMT; path=/; domain=.brasilcupom.com.br; HttpOnly
    x-powered-by: PHP/7.2.13
    last-modified: Wed, 13 Mar 2019 09:30:26 GMT
    vary: Accept-Encoding
    cache-control: max-age=0
    expires: Fri, 22 Mar 2019 16:51:32 GMT
    expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    server: cloudflare
    cf-ray: 4bb9abbfac60cce0-EWR
    

    Also try with ngx_pagespeed disabled as some filters may interfere with your site design. You'd have to troubleshoot and tweak it yourself following these guides and info outlined below
    Yes you can disable ngx_pagespeed integration if you are not using it, see ngx_pagespeed install on Centmin Mod - how to disable.
     
  3. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
     
  4. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Sorry Eva, just changed the DNS back to the old one. Gona change it now so you can have a look again.

    Alread tried to disable pagespeed but that does not make any difference so I turned it on again.
     
  5. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    see centmin mod headers now
    Code (Text):
    HTTP/2 200
    date: Fri, 22 Mar 2019 17:12:24 GMT
    content-type: text/html; charset=UTF-8
    set-cookie: __cfduid=ddd62c9b1263dc9fe985ca45506b39abf1553274742; expires=Sat, 21-Mar-20 17:12:22 GMT; path=/; domain=.brasilcupom.com.br; HttpOnly
    vary: Accept-Encoding
    x-cf-powered-by: WP Rocket 3.2.4
    link: <https://brasilcupom.com.br/wp-json/>; rel="https://api.w.org/"
    x-powered-by: centminmod
    x-xss-protection: 1; mode=block
    x-content-type-options: nosniff
    x-page-speed: 1.13.35.2-0
    cache-control: max-age=0, no-cache
    expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    server: cloudflare
    cf-ray: 4bb9ca44ea4bc5ee-EWR
    

    is javascript on 3rd party domains for popups or on your domain served javascript urls ? could be security headers
    Code (Text):
    x-xss-protection: 1; mode=block
    x-content-type-options: nosniff
    

    or could be wp rocket related and/or cloudflare i.e. cloudflare rocketloader https://support.cloudflare.com/hc/en-us/articles/200168056-What-does-Rocket-Loader-do-
     
  6. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    try disabling wp-rocket and ngx_pagespeed and cloudflare rocket loader if enabled first
     
  7. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    also if you disable wp-rocket and ngx_pagespeed might need to clear cloudflare's cache site wide too
     
  8. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Already tried to disable it but now I will disable wp-rocket also.
    Code (Text):
    # ngx_pagespeed & ngx_pagespeed handler
    #include /usr/local/nginx/conf/pagespeed.conf;
    pagespeed unplugged;
    #include /usr/local/nginx/conf/pagespeedhandler.conf;
    #include /usr/local/nginx/conf/pagespeedstatslog.conf;
    


    As you can see it is disabled
    Code (Text):
    [17:44][[email protected] conf.d]# curl -I https://brasilcupom.com.br
    HTTP/1.1 200 OK
    Date: Fri, 22 Mar 2019 17:44:45 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Set-Cookie: __cfduid=daa91d1966bd3b3d7ede44b49f7bdee731553276684; expires=Sat, 21-Mar-20 17:44:44 GMT; path=/; domain=.brasilcupom.com.br; HttpOnly
    Vary: Accept-Encoding
    Link: <https://brasilcupom.com.br/wp-json/>; rel="https://api.w.org/"
    X-Powered-By: centminmod
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    Server: cloudflare
    CF-RAY: 4bb9f9ad79a3c773-AMS
    


    But the effect keeps the same. No popup. Also disable the minify options in CloudFlare.

    I did some testing with another panel namely ISPConfig with NGINX and did not have this problem, but I like to be able to compile to get some extra preformance.

    Btw I installed the wordpress with option 2 to create a new site.
     
  9. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    There's huge differences in using centmin.sh menu option 2 versus menu option 22's dedicated wordpress installer outlined at https://community.centminmod.com/th...l-vs-centmin-sh-menu-option-22-install.15435/

    You could be missing some wordpress related nginx rules if you did not use centmin.sh menu option 22.

    When you create a new nginx vhost domain via centmin.sh menu option 2 or menu option 22 or via /usr/bin/nv cli command line, you will create the Nginx vhost files and directories. You will get an outputted the path location where it will create the domain name's vhost conf file named newdomain.com.conf (and newdomain.com.ssl.conf if you selected yes to self signed SSL)
    • Nginx vhost conf path will be at /usr/local/nginx/conf/conf.d/newdomain.com.conf
    • Nginx HTTP/2 SSL vhost conf path will be at /usr/local/nginx/conf/conf.d/newdomain.com.ssl.conf
    • Nginx Self-Signed SSL Certificate Directory at /usr/local/nginx/conf/ssl/newdomain.com
    • Vhost public web root will be at /home/nginx/domains/newdomain.com/public
    • Vhost log directory will be at /home/nginx/domains/newdomain.com/log
    Please post the contents of /usr/local/nginx/conf/conf.d/newdomain.com.conf and if applicable /usr/local/nginx/conf/conf.d/newdomain.com.ssl.conf wrapped in CODE tags (outlined at How to use forum BBCODE code tags)

    what is output of these commands in ssh
    Code (Text):
    curl -I https://domain.com
    

    Code (Text):
    curl -I https://www.domain.com
    

    Code (Text):
    curl -I http://domain.com
    

    Code (Text):
    curl -I http://www.domain.com
    

    wrap output in CODE tags
     
  10. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Created a new domain with option 22 without any changes to the configuration files and the result is the same, still no pop up. Uploaded the missing template, missing images and missing plugins and synced the dbase. Site is messed up a little bit also when I look it up in a private window. (cookies fighting and cach)


    HTTP
    Code:
    # Centmin Mod Getting Started Guide
    # must read http://centminmod.com/getstarted.html
    
    # redirect from non-www to www
    # uncomment, save file and restart Nginx to enable
    # if unsure use return 302 before using return 301
    #server {
    #            listen   80;
    #            server_name cupomportugal.pt www.cupomportugal.pt;
    #            return 301 $scheme://www.cupomportugal.pt$request_uri;
    #       }
    
    server {
    
      server_name cupomportugal.pt www.cupomportugal.pt;
    
    # ngx_pagespeed & ngx_pagespeed handler
    #include /usr/local/nginx/conf/pagespeed.conf;
    #include /usr/local/nginx/conf/pagespeedhandler.conf;
    #include /usr/local/nginx/conf/pagespeedstatslog.conf;
    
      #add_header X-Frame-Options SAMEORIGIN;
      add_header X-Xss-Protection "1; mode=block" always;
      add_header X-Content-Type-Options "nosniff" always;
      #add_header Referrer-Policy "strict-origin-when-cross-origin";
    
      # limit_conn limit_per_ip 16;
      # ssi  on;
    
      access_log /home/nginx/domains/cupomportugal.pt/log/access.log combined buffer=256k flush=5m;
      error_log /home/nginx/domains/cupomportugal.pt/log/error.log;
    
      include /usr/local/nginx/conf/autoprotect/cupomportugal.pt/autoprotect-cupomportugal.pt.conf;
      root /home/nginx/domains/cupomportugal.pt/public;
      # uncomment cloudflare.conf include if using cloudflare for
      # server and/or vhost site
      #include /usr/local/nginx/conf/cloudflare.conf;
      include /usr/local/nginx/conf/503include-main.conf;
    
      #include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpcacheenabler_cupomportugal.pt.conf;
      include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpsupercache_cupomportugal.pt.conf;
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/rediscache_cupomportugal.pt.conf;
    
      location / {
      include /usr/local/nginx/conf/503include-only.conf;
    
    
      # Enables directory listings when index file not found
      #autoindex  on;
    
      # for wordpress super cache plugin
      try_files /wp-content/cache/supercache/$http_host/$cache_uri/index.html $uri $uri/ /index.php?q=$uri&$args;
    
      # for wp cache enabler plugin
      #try_files $cache_enabler_uri $uri $uri/ $custom_subdir/index.php?$args;
    
      # Wordpress Permalinks
      #try_files $uri $uri/ /index.php?q=$uri&$args;
    
      # Nginx level redis Wordpress
      # https://community.centminmod.com/posts/18828/
      #try_files $uri $uri/ /index.php?$args;
    
      }
    
    location ~* /(wp-login\.php) {
        limit_req zone=xwplogin burst=1 nodelay;
        #limit_conn xwpconlimit 30;
        auth_basic "Private";
        auth_basic_user_file /home/nginx/domains/cupomportugal.pt/htpasswd_wplogin;
        include /usr/local/nginx/conf/php-wpsc.conf;
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /(xmlrpc\.php) {
        limit_req zone=xwprpc burst=45 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-scripts\.php) {
        limit_req zone=xwprpc burst=5 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-styles\.php) {
        limit_req zone=xwprpc burst=5 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
      include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpsecure_cupomportugal.pt.conf;
      include /usr/local/nginx/conf/php-wpsc.conf;
    
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/php-rediscache.conf;
      include /usr/local/nginx/conf/pre-staticfiles-local-cupomportugal.pt.conf;
      include /usr/local/nginx/conf/pre-staticfiles-global.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      include /usr/local/nginx/conf/drop.conf;
      #include /usr/local/nginx/conf/errorpage.conf;
      include /usr/local/nginx/conf/vts_server.conf;
    }
    
    HTTPS
    Code:
    # Centmin Mod Getting Started Guide
    # must read http://centminmod.com/getstarted.html
    # For HTTP/2 SSL Setup
    # read http://centminmod.com/nginx_configure_https_ssl_spdy.html
    
    # redirect from www to non-www  forced SSL
    # uncomment, save file and restart Nginx to enable
    # if unsure use return 302 before using return 301
    # server {
    #   server_name cupomportugal.pt www.cupomportugal.pt;
    #    return 302 https://$server_name$request_uri;
    # }
    
    server {
      listen 443 ssl http2;
      server_name cupomportugal.pt www.cupomportugal.pt;
    
      include /usr/local/nginx/conf/ssl/cupomportugal.pt/cupomportugal.pt.crt.key.conf;
      include /usr/local/nginx/conf/ssl_include.conf;
    
      # cloudflare authenticated origin pull cert community.centminmod.com/threads/13847/
      #ssl_client_certificate /usr/local/nginx/conf/ssl/cloudflare/cupomportugal.pt/origin.crt;
      #ssl_verify_client on;
      http2_max_field_size 16k;
      http2_max_header_size 32k;
      # mozilla recommended
      ssl_ciphers TLS13-AES-128-GCM-SHA256:TLS13-AES-256-GCM-SHA384:TLS13-CHACHA20-POLY1305-SHA256:TLS13-AES-128-CCM-8-SHA256:TLS13-AES-128-CCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS;
      ssl_prefer_server_ciphers   on;
      #add_header Alternate-Protocol  443:npn-spdy/3;
    
      # before enabling HSTS line below read centminmod.com/nginx_domain_dns_setup.html#hsts
      #add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";
      #add_header X-Frame-Options SAMEORIGIN;
      add_header X-Xss-Protection "1; mode=block" always;
      add_header X-Content-Type-Options "nosniff" always;
      #add_header Referrer-Policy "strict-origin-when-cross-origin";
      #spdy_headers_comp 5;
      ssl_buffer_size 1369;
      ssl_session_tickets on;
    
      # enable ocsp stapling
      resolver 8.8.8.8 8.8.4.4 1.1.1.1 1.0.0.1 valid=10m;
      resolver_timeout 10s;
      ssl_stapling on;
      ssl_stapling_verify on;
    
    # ngx_pagespeed & ngx_pagespeed handler
    #include /usr/local/nginx/conf/pagespeed.conf;
    #include /usr/local/nginx/conf/pagespeedhandler.conf;
    #include /usr/local/nginx/conf/pagespeedstatslog.conf;
    
      # limit_conn limit_per_ip 16;
      # ssi  on;
    
      access_log /home/nginx/domains/cupomportugal.pt/log/access.log combined buffer=256k flush=5m;
      error_log /home/nginx/domains/cupomportugal.pt/log/error.log;
    
      include /usr/local/nginx/conf/autoprotect/cupomportugal.pt/autoprotect-cupomportugal.pt.conf;
      root /home/nginx/domains/cupomportugal.pt/public;
      # uncomment cloudflare.conf include if using cloudflare for
      # server and/or vhost site
      #include /usr/local/nginx/conf/cloudflare.conf;
      include /usr/local/nginx/conf/503include-main.conf;
    
      #include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpcacheenabler_cupomportugal.pt.conf;
      include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpsupercache_cupomportugal.pt.conf;
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/rediscache_cupomportugal.pt.conf;
    
      location / {
      include /usr/local/nginx/conf/503include-only.conf;
    
    
      # Enables directory listings when index file not found
      #autoindex  on;
    
      # for wordpress super cache plugin
      try_files /wp-content/cache/supercache/$http_host/$cache_uri/index.html $uri $uri/ /index.php?q=$uri&$args;
    
      # for wp cache enabler plugin
      #try_files $cache_enabler_uri $uri $uri/ $custom_subdir/index.php?$args;
    
      # Wordpress Permalinks
      #try_files $uri $uri/ /index.php?q=$uri&$args;
    
      # Nginx level redis Wordpress
      # https://community.centminmod.com/posts/18828/
      #try_files $uri $uri/ /index.php?$args;
    
      }
    
    location ~* /(wp-login\.php) {
        limit_req zone=xwplogin burst=1 nodelay;
        #limit_conn xwpconlimit 30;
        auth_basic "Private";
        auth_basic_user_file /home/nginx/domains/cupomportugal.pt/htpasswd_wplogin;
        include /usr/local/nginx/conf/php-wpsc.conf;
    
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /(xmlrpc\.php) {
        limit_req zone=xwprpc burst=45 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
    
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-scripts\.php) {
        limit_req zone=xwprpc burst=5 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
    
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-styles\.php) {
        limit_req zone=xwprpc burst=5 nodelay;
        #limit_conn xwpconlimit 30;
        include /usr/local/nginx/conf/php-wpsc.conf;
    
        # https://community.centminmod.com/posts/18828/
        #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
      include /usr/local/nginx/conf/wpincludes/cupomportugal.pt/wpsecure_cupomportugal.pt.conf;
      include /usr/local/nginx/conf/php-wpsc.conf;
    
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/php-rediscache.conf;
      include /usr/local/nginx/conf/pre-staticfiles-local-cupomportugal.pt.conf;
      include /usr/local/nginx/conf/pre-staticfiles-global.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      include /usr/local/nginx/conf/drop.conf;
      #include /usr/local/nginx/conf/errorpage.conf;
      include /usr/local/nginx/conf/vts_server.conf;
    }
    
    Code:
    [19:52][[email protected] conf.d]# curl -I https://cupomportugal.pt
    HTTP/1.1 200 OK
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Vary: Accept-Encoding
    Server: nginx centminmod
    X-Powered-By: centminmod
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Date: Fri, 22 Mar 2019 19:53:53 GMT
    X-Page-Speed: 1.13.35.2-0
    Cache-Control: max-age=0, no-cache
    
    Code:
    [19:54][[email protected] conf.d]# curl -I https://www.cupomportugal.pt
    HTTP/1.1 200 OK
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Vary: Accept-Encoding
    Vary: Accept-Encoding, Cookie
    Link: <https://cupomportugal.pt/wp-json/>; rel="https://api.w.org/"
    Server: nginx centminmod
    X-Powered-By: centminmod
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Date: Fri, 22 Mar 2019 19:56:38 GMT
    X-Page-Speed: 1.13.35.2-0
    Cache-Control: max-age=0, no-cache
    
    Code:
    [19:56][[email protected] conf.d]# curl -I http://cupomportugal.pt
    HTTP/1.1 200 OK
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Vary: Accept-Encoding
    Server: nginx centminmod
    X-Powered-By: centminmod
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Date: Fri, 22 Mar 2019 19:58:13 GMT
    X-Page-Speed: 1.13.35.2-0
    Cache-Control: max-age=0, no-cache
    
    Code:
    [19:58][[email protected] conf.d]# curl -I http://www.cupomportugal.pt
    HTTP/1.1 200 OK
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Vary: Accept-Encoding
    Vary: Accept-Encoding, Cookie
    Link: <https://cupomportugal.pt/wp-json/>; rel="https://api.w.org/"
    Server: nginx centminmod
    X-Powered-By: centminmod
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Date: Fri, 22 Mar 2019 19:59:08 GMT
    X-Page-Speed: 1.13.35.2-0
    Cache-Control: max-age=0, no-cache
    
     
  11. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Is the site HTTPS default as seems you might need the http to https redirects otherwise may have mixed content HTTPS issues as those curl header checks for non-https ones should do a 302/301 redirect to https ones

    Posted at centminmod.com/nginx_domain_dns_setup.html#httpsredirect is the correct way to set it up - pay attention to different way if you want redirect target being www version instead of non-www and vice versa and that the target version www or non-www is the only version listed in server_name for the 2nd/main server {} context.

    key to testing is using 302 temp redirect first in a private incognito browser session otherwise the problems you can experience may end up being due to browser caching or 301 permanent redirects unless you clear browser cache and reboot local computer(s) and even then some web browsers don't let go of 301 permanent redirect browser cache that willingly :)

    You may have mixed content issue so need to adjust your web app and/or web site style itself see What Is Mixed Content? - KeyCDN Support. Though test at Test Results: brasilcupom.com.br - Why No Padlock? says no mixed content issues as you have cloudflare in front.
     
  12. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    One thing you don't have enabled if using wordpress permalinks is the rule for both non-https and https vhosts for
    Code (Text):
      # Wordpress Permalinks
      #try_files $uri $uri/ /index.php?q=$uri&$args;
    

    change and uncomment the try_files
    Code (Text):
      # Wordpress Permalinks
      try_files $uri $uri/ /index.php?q=$uri&$args;
    

    restart nginx and php-fpm
    Code (Text):
    nprestart
     
  13. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Is mailchimp via a wordpress plugin ? if it is then it runs php and it could be caught up in centmin mod's autoprotect routines too blocking php running for the wordpress plugin so need to whitelist the wordpress plugin directory.

    If on Centmin Mod 123.09beta01, you may have ran into the new tools/autoprotect.sh cronjob feature outlined at Beta Branch - autoprotect.sh - apache .htaccess check & migration to nginx deny all | Centmin Mod Community You uploaded scripts may have .htaccess deny from all type files in their directories which may need bypassing autoprotect. It's a security feature that no other nginx based stack has as far as I know :)

    So instead, all .htaccess 'deny from all' detected directories now get auto generated Nginx equivalent location match and deny all setups except if you want to manually bypass the directory from auto protection via a .autoprotect-bypass file - details below here.

    You can read a few threads below on how autoprotect.sh may have caught some folks web apps falsely and the workarounds or improvements made to autoprotect.sh with the help of users feedback and troubleshooting.
    Check if your nginx vhost at either or both /usr/local/nginx/conf/conf.d/domain.com.conf and/or /usr/local/nginx/conf/conf.d/domain.com.ssl.conf has include file for autoprotect example
    Code (Text):
    include /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf;
    

    see if your directory for the script which has issues is caught in an autoprotect include entry in /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf which has a deny all entry
    Code (Text):
    cat /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf
    

    i.e.
    Code (Text):
    # /home/nginx/domains/domain.com/public/subdirectory/js
    location ~* ^/subdirectory/js/ { allow 127.0.0.1; deny all; }
    

    If caught you can whitelist it by autoprotect bypass .autoprotect-bypass file - details below here. So if problem js file is at domain.com/subdirectory/js/file.js then it is likely /subdirectory/js has a .htaccess with deny all in it - make sure that directory is meant to be publicly accessible by contacting author of script and if so, you can whitelist it and re-run autoprotect script to regenerate your /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf include file
    Code (Text):
    cd /home/nginx/domains/domain.com/public/subdirectory/js
    touch .autoprotect-bypass
    /usr/local/src/centminmod/tools/autoprotect.sh
    nprestart
    

    it maybe you need to also whitelist /subdirectory then it would be as follows creating bypass files at /home/nginx/domains/domain.com/public/subdirectory/.autoprotect-bypass and /home/nginx/domains/domain.com/public/subdirectory/js/.autoprotect-bypass
    Code (Text):
    cd /home/nginx/domains/domain.com/public/subdirectory/
    touch .autoprotect-bypass
    cd /home/nginx/domains/domain.com/public/subdirectory/js
    touch .autoprotect-bypass
    /usr/local/src/centminmod/tools/autoprotect.sh
    nprestart
    

    then double check to see if updated /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf include file now doesn't show an entry for /subdirectory/js
     
  14. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    If I use this it gives me an error on nginx -t because I have try_files also for the caching. If I am correct the below quote gives the same as the Permalinks

    The autoprotect is enabeld but the content is like this.

    Code:
     /home/nginx/domains/cupomportugal.pt/public/wp-content/plugins/akismet
    
    location /wp-content/plugins/akismet/ {
      location ~ ^/wp-content/plugins/akismet/(.+/)?(form|akismet)\.(css|js)$ { all$
      location ~ ^/wp-content/plugins/akismet/(.+/)?(.+)\.(png|gif)$ { allow all; e$
      location ~* /wp-content/plugins/akismet/.*\.php$ {
        include /usr/local/nginx/conf/php.conf;
        allow 127.0.0.1;
        deny all;
      }
    }
    
    # /home/nginx/domains/cupomportugal.pt/public/wp-content/uploads/sucuri
    location ~* ^/wp-content/uploads/sucuri/ { allow 127.0.0.1; deny all; }
    
    As far as I can see there is no js script blocked.
    In my theme is a directory JS, but it does not have a .htaccess file.
    The only .htaccess file of my wordpress instalation lives in the root of the public directory
     
  15. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    oh yes you're using super cache so do not need the uncommented try_files I suggested.. my bad :eek:

    yeah doesn't look like autoprotect related so probably you need to investigate some more yourself

    is mailchimp via wordpress plugin though ? which plugin ?
     
  16. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    I use the theme and plugin from https://mythemeshop.com
    PLUGIN = WP Subscribe Pro – License
    THEME = Coupon – License

    The Plugin has some tabs that don´t respond when clicking on them.
    For example I can´t switch to another tab like the ones in the screenshot (sorry for posting a link to prtnscr but I don´t know how to post it here
    http://prntscr.com/n1oqyi

    I realy like centminmid because of the security and the ability to compile. You made a great and safe product.

    But I am affraid it won´t work on my setup. I don´t need a control panel like ISPconfig becuase I am only hosting domains with the same content, only for my business, but when I use that it works out of the box.

    I am going to build a new droplet with centminmod and do some new testing. Maybe I did something wrong with the setup, too exiting to experiment. My bad....
     
    Last edited: Mar 23, 2019
  17. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  18. EckyBrazzz

    EckyBrazzz Active Member

    747
    149
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +274
    Local Time:
    8:30 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Thanks for the sugestion but I am affraid they won´t help.
    The setup on the current server works fine. See https://belgië.gratis.coupons as example.
     
  19. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    one thing make sure file/directory permissions are correct as per getting started guide step 2 https://centminmod.com/getstarted.html - whenever you upload files via root sftp user, you need to chown and make files owned by nginx user/group
    replace newdomain.com with your domain name for path to public for chown command
     
  20. eva2000

    eva2000 Administrator Staff Member

    42,028
    9,474
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,582
    Local Time:
    8:30 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    FYI seems you have some javascript errors in browser console display too

    upload_2019-3-23_9-56-13.png