Learn about Centmin Mod LEMP Stack today
Become a Member

pip will change the way that it resolves dependency conflicts

Discussion in 'Bug Reports' started by pamamolf, Nov 12, 2020.

  1. pamamolf

    pamamolf Premium Member Premium Member

    3,883
    381
    83
    May 31, 2014
    Ratings:
    +741
    Local Time:
    2:00 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Hello

    Today i got on one server by running Centminmod this warning :

    Code:
    ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.
    
    We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.
    
    botocore 1.13.26 requires urllib3<1.26,>=1.20; python_version == "2.7", but you'll have urllib3 1.26.1 which is incompatible.
    Don't know if any adjustments will be needed for Centminmod :)

    Thanks
     
    Last edited: Nov 12, 2020
  2. eva2000

    eva2000 Administrator Staff Member

    45,633
    10,356
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,070
    Local Time:
    10:00 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    thanks for the heads up. Was that the entire message or some parts you left out?

    Saw something similar the other day

    In which case you need to run
    Code (Text):
    /usr/bin/python2 -m pip install --upgrade pip
     
  3. pamamolf

    pamamolf Premium Member Premium Member

    3,883
    381
    83
    May 31, 2014
    Ratings:
    +741
    Local Time:
    2:00 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    It was the entire message for my case :)