Learn about Centmin Mod LEMP Stack today
Register Now

phpmyadmin

Discussion in 'Add Ons' started by Matt Williams, May 19, 2022.

  1. Matt Williams

    Matt Williams WordPress Fanatic

    537
    104
    43
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +157
    Local Time:
    10:37 PM
    latest
    10
    Is it possible to install an SSL ( Purchased ) for phpmyadmin instead of using the self-signed? If so, what are the steps to do this?

     
  2. eva2000

    eva2000 Administrator Staff Member

    49,300
    11,296
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,575
    Local Time:
    12:37 PM
    Nginx 1.21.x
    MariaDB 10.x
  3. Matt Williams

    Matt Williams WordPress Fanatic

    537
    104
    43
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +157
    Local Time:
    10:37 PM
    latest
    10
    Well, that's enough for me to not even bother looking at the mentioned post lol!
    I just keep getting redirect loop errors when CF is enabled. I've tried everything ( turning on, turning off various functions in CF ) nothing..
     
  4. eva2000

    eva2000 Administrator Staff Member

    49,300
    11,296
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,575
    Local Time:
    12:37 PM
    Nginx 1.21.x
    MariaDB 10.x
    CF Always Use HTTPS setting will force a non-https to https redirect while phpmyadmin.sh nginx vhost already has a non-https to https redirect. You don't want main hostname to be Cloudflare Orange cloud proxied as that prevents email deliverability when mail servers to a PTR reverse DNS lookup for your Centmin Mod Postfix MTA mail server outbound emails https://community.centminmod.com/th...ver-email-doesnt-end-up-in-spam-inboxes.6999/

    Unless, you setup Postfix on server to use a 3rd party SMTP transactional email provider like Amazon SES as a Postfix relay configuration, then all sent outbound emails go via Amazon SES instead of Centmin Mod's Postfix then you can orange cloud enable Cloudflare on mainhostname and then setup a Cloudflare Page rule to disable Always Use HTTPS for the main hostname.
     
  5. Matt Williams

    Matt Williams WordPress Fanatic

    537
    104
    43
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +157
    Local Time:
    10:37 PM
    latest
    10
    Ahh, I see. So the main hostname should never have cloudflare turned on. Gotcha. But when I turn it off then access phpmyadmin, my browser does not allow me to connect to it because it's an insecure connection. I tried in Chrome, Firefox and safari
     
  6. eva2000

    eva2000 Administrator Staff Member

    49,300
    11,296
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,575
    Local Time:
    12:37 PM
    Nginx 1.21.x
    MariaDB 10.x
    That's normal for self-signed ssl certs, you should have a link to continue through the warning page.
     
  7. Matt Williams

    Matt Williams WordPress Fanatic

    537
    104
    43
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +157
    Local Time:
    10:37 PM
    latest
    10
    I usually do but I don't this time which is weird..