Discover Centmin Mod today
Register Now

phpmyadmin.sh installed 404 error when accessed

Discussion in 'Add Ons' started by YuchiRO, Jul 6, 2016.

  1. YuchiRO

    YuchiRO Member

    92
    6
    8
    Jan 12, 2015
    Ratings:
    +8
    Local Time:
    1:43 PM
    5.5.4
    Hi

    I try to install phpmyadmin on both my vps.
    One is working perfect :( but the second "404 Not Found". I try to uninstall and re-install but same problem :( - Centmin Mod 1.2.3-eva2000.08

    How to fix this problem ?
     
  2. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    404 for the phpmyadmin url ? did you restart nginx and php-fpm services ?

    check phpmyadmin log (centminmod_phpmyadmin_install_*.log) in /etc/centminlogs output and share on pastebin.com or gist.github.com
     
  3. YuchiRO

    YuchiRO Member

    92
    6
    8
    Jan 12, 2015
    Ratings:
    +8
    Local Time:
    1:43 PM
    5.5.4
  4. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    is THBX-Cloud001-I002 a legit web browsable hostname ? or you just replaced it for public posting ? as you need to ensure the the main hostname of the server is resolvable as per Getting Started Guide Step 1 - phpmyadmin installer uses the main hostname of the server to server the phpmyadmin direct off of
     
  5. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    also check the phpmyadmin access and error logs for clues from your vhost file for phpmyadmin
    Code (Text):
            access_log              /var/log/nginx/localhost_ssl.access.log     main buffer=32k;
            error_log               /var/log/nginx/localhost_ssl.error.log      error;
     
  6. YuchiRO

    YuchiRO Member

    92
    6
    8
    Jan 12, 2015
    Ratings:
    +8
    Local Time:
    1:43 PM
    5.5.4
    I replace host name by ip address, and this method work fine on first vps, but the second has 404.
     
  7. YuchiRO

    YuchiRO Member

    92
    6
    8
    Jan 12, 2015
    Ratings:
    +8
    Local Time:
    1:43 PM
    5.5.4
    localhost_ssl.access.log and localhost_ssl.error.log show nothing, blank :(
     
  8. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    2nd vps a newer install of centmin mod than 1st vps that is working ?

    newer installs need working main hostname in server_name and must not match domain set in server_name in any other created nginx site domains via centmin.sh menu option 2 otherwise yes you will get 404

    main hostname's server_name needs to unique
     
  9. YuchiRO

    YuchiRO Member

    92
    6
    8
    Jan 12, 2015
    Ratings:
    +8
    Local Time:
    1:43 PM
    5.5.4
    Let me show you again :)
    2nd vps is newer and working with https://ip/xxphpmyadmin_xx while 1st vps is older and i try https://ip/phpmyadmin show error 404.

    I dont use server host name, i always use option 22 :) instead of 2, each vps has 3-4 wordpress site.
     
  10. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    both vps have multiple wordpress sites ?

    probably need to enable nginx debug mode to troubleshoot so moving your posts to own thread in addon forums
     
  11. eva2000

    eva2000 Administrator Staff Member

    29,053
    6,594
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,790
    Local Time:
    4:43 PM
    Nginx 1.13.x
    MariaDB 5.5
    Latest update on September 14, 2015 to Centmin Mod 1.2.3-eva2000.08 stable (123.08stable) and higher has added Nginx debug mode support. Nginx debug mode is disabled by default.

    To enable, edit centmin.sh and change variable NGINX_DEBUG=n default to NGINX_DEBUG=y and recompile Nginx via centmin.sh menu option 4 and then setting error_log in nginx vhosts to debug as outlined at nginx.org/en/docs/debugging_log.html & wiki.nginx.org/Debugging.

    You do not want to leave Nginx debug mode running forever, so after debugging, set NGINX_DEBUG=n in centmin.sh and recompile Nginx again via centmin.sh menu option 4 and remove error_log debugging mode to disable Nginx debug mode again.

    To update your Centmin Mod builds code for Nginx debug mode support if you do not have a NGINX_DEBUG variable in centmin.sh, follow instructions at centminmod.com/upgrade.html and respective version threads below:

    Centmin Mod is provided as is, but you can try debugging mode for Nginx for further troubleshooting if you have problems with Nginx (i.e. segfaults / signal 11 issues) as outlined at nginx.org/en/docs/debugging_log.html & wiki.nginx.org/Debugging.