Join the community today
Register Now

phpmyadmin.sh Addon

Discussion in 'Add Ons' started by eva2000, May 25, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    clear browser/restart browser and restart nginx and php-fpm
    Code:
    nprestart


     
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I found the problem :)

    Code:
    C:\Users\Myname>ping 163.172.xx.xx
    
    Pinging 163.172.xx.xx with 32 bytes of data:
    Reply from 163.172.xx.xx: bytes=32 time=125ms TTL=49
    Request timed out.
    Reply from 163.172.xx.xx: bytes=32 time=126ms TTL=49
    Reply from 163.172.xx.xx: bytes=32 time=126ms TTL=49
    
    Ping statistics for 163.172.xx.xx:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 125ms, Maximum = 126ms, Average = 125ms
    Server from Online.net :(
     
  3. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    ah ha !
     
  4. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    /etc/hosts was revert to default and missing server ip entry but don't know how :(

    Anyway i am checking it :)

    Thanks George and sorry for the trouble :)
     
  5. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Is it recommended to have this:

    Code:
    search mydomain.com
    in
    Code:
    /etc/resolv.conf
    ?
     
  6. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    not needed
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    If you have php-fpm pools enabled the phpmyadmin installation fails always at the end when it try to restart Nginx:

    Code:
    Restarting nginx (via systemctl):  Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.
    [FAILED]
    Reason is here Line 6 needs a comment but is not there by default generation :

    Code:
    /usr/local/nginx/conf/phpmyadmin.conf

    Code:
    location ~ \.php$ {
      try_files $uri =404;
      fastcgi_split_path_info ^(.+\.php)(/.+)$;
      ##fastcgi_pass  127.0.0.1:9001;
      fastcgi_next_upstream error timeout http_500 http_503;
      fastcgi_pass phpbackend;
      fastcgi_keep_conn on;
      fastcgi_pass  unix:/tmp/phpfpm_myadmin.sock;
      fastcgi_index  index.php;
      #fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
      fastcgi_param  SCRIPT_FILENAME  $request_filename;
      fastcgi_param PHP_ADMIN_VALUE open_basedir=$document_root/:/usr/local/lib/php/:/tmp/;

    Can you please add a check in the installation process if a user is using php-fpm pools and disable it?

    Thank you
     
    Last edited: Feb 5, 2016
  8. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    No no.. phpmyadmin is never intended to use php-fpm pools, it uses it's own socket for a reason as phpmyadmin has it's own php-fpm settings and limit separate from all other php-fpm TCP based pools

    please keep phpmyadmin to use default unix socket and not php-fpm pools
     
  9. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    You didn't understand me :) Sorry for my bad english.

    When you enable php-fpm pools before installation of phpmyadmin then the generated for e.x php_27831_mysqladmin29782.conf file has inside as default:

    Code:
    location ~ \.php$ {
      try_files $uri =404;
      fastcgi_split_path_info ^(.+\.php)(/.+)$;
      ##fastcgi_pass  127.0.0.1:9001;
      fastcgi_next_upstream error timeout http_500 http_503;
      fastcgi_pass phpbackend;
      fastcgi_keep_conn on;
      fastcgi_pass  unix:/tmp/phpfpm_myadmin.sock;
      fastcgi_index  index.php;
      #fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
      fastcgi_param  SCRIPT_FILENAME  $request_filename;
      fastcgi_param PHP_ADMIN_VALUE open_basedir=$document_root/:/usr/local/lib/php/:/tmp/;
    And with this line 6 enabled by default:
    Code:
      fastcgi_pass phpbackend;
    it will fail to restart Nginx before installation finished and then is not working.
     
  10. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    ah i see.. i'll double check :)

    thanks
     
  11. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
  12. ekayulia

    ekayulia New Member

    5
    0
    1
    Jan 25, 2015
    Indonesia
    Ratings:
    +4
    Local Time:
    3:24 AM
    1.9.10
    MariaDB 10
    I am still curious how you fix "logout issue on any click" problem.
    I'm having the exact same problem as you experienced. I am using Mod 1.2.3 Centmin-eva2000.08.
    Everything's fine before. But when I've update phpmyadmin to version 4.6.0-dev (latest) from update script phpmyadmin_update.sh the exact problem came. :(
    My guess is it seems this problem occurs in phpMyAdmin updates that download from the official git.
     
  13. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Hi ekayulia :)

    I found the problem with my network connection and lost packets but i was not able to find a fix for the logout on any click issue :(

    Yes older versions of phpmyadmin was ok.

    Using the latest version the problem exist on every new installation that i try :(

    The problem that i have is exactly the same as you describe it!

    It looks like a session problem but don't know what exactly is :(
     
  14. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    unfortunately i am not able to reproduce this

    does uninstall and reinstall of phpmyadmin fix it ?
    Code:
    /root/tools/phpmyadmin_uninstall.sh
    what php versions you using ?

    also can you post contents of your /etc/centminmod/php.d/igbinary.ini file

    how long have you logged into phpmyadmin as it has a default LoginCookieValidity of 1440 seconds Configuration — phpMyAdmin 4.7.0-dev documentation
     
    Last edited: Feb 9, 2016
  15. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
  16. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    No :(

    PHP 5.5.31



    Code:
    [igbinary]
    extension=igbinary.so
    ;Use igbinary as session serializer
    session.serialize_handler=igbinary
    
    ;Enable or disable compacting of duplicate strings
    igbinary.compact_strings=On
    
    ;Use igbinary as serializer in APC cache
    ;apc.serializer=igbinary
    A few seconds less than 20 (just login and click on a link without waiting and boom log out :(
     
  17. eva2000

    eva2000 Administrator Staff Member

    49,223
    11,291
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,566
    Local Time:
    6:24 AM
    Nginx 1.21.x
    MariaDB 10.x
    in igbinary.ini file comment out with semi-colon and restart nginx and php-fpm
    Code:
    ;session.serialize_handler=igbinary
    see if that helps
     
  18. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I am at the office and i can't test it now :(

    Maybe @ekayulia can test it???
     
  19. ekayulia

    ekayulia New Member

    5
    0
    1
    Jan 25, 2015
    Indonesia
    Ratings:
    +4
    Local Time:
    3:24 AM
    1.9.10
    MariaDB 10
    No, it's not fix it.

    PHP version 5.6.18

    Code:
    [igbinary]
    extension=igbinary.so
    ;Use igbinary as session serializer
    session.serialize_handler=igbinary
    
    ;Enable or disable compacting of duplicate strings
    igbinary.compact_strings=On
    
    ;Use igbinary as serializer in APC cache
    ;apc.serializer=igbinary
    
    a few seconds after login, and when I do click anywhere, instantly I was immediately thrown to the login page

    here's the gif image that I record with the process
    http://i.imgur.com/7r2AjdE.gif
     
  20. pamamolf

    pamamolf Premium Member Premium Member

    3,991
    416
    83
    May 31, 2014
    Ratings:
    +806
    Local Time:
    11:24 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Yup that's exactly the problem that i have also as your gif presentation :(