Welcome to Centmin Mod Community
Become a Member

phpmyadmin.sh Addon

Discussion in 'Add Ons' started by eva2000, May 25, 2014.

  1. Earl

    Earl New Member

    7
    4
    3
    Sep 17, 2015
    Ratings:
    +5
    Local Time:
    2:23 PM
    Trying this addon on my server with freshly installed centminmod
    And I get this error
    Code (Text):
    # /root/tools/phpmyadmin_update.sh
    cd /usr/local/nginx/html/4198_mysqladmin20445
    git pull
    Already up-to-date.
    2020-04-08 16:27:05 URL:https://getcomposer.org/composer.phar [2061262/2061262] -> "composer.phar" [1]
    Do not run Composer as root/super user! See https://getcomposer.org/root for details
    Continue as root/super user [yes]?
    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - phpstan/phpstan 0.11.19 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.18 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.17 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.16 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.15 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.14 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.13 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.12 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.11 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.10 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.9 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.8 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.7 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.6 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.5 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - jean85/pretty-package-versions 1.2 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.8.0, 1.7.0, 1.6.0, 1.5.1, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.0, 1.2.0].
        - jean85/pretty-package-versions 1.1 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.8.0, 1.7.0, 1.6.0, 1.5.1, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.0, 1.2.0].
        - jean85/pretty-package-versions 1.0.3 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.8.0, 1.7.0, 1.6.0, 1.5.1, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.0, 1.2.0].
        - ocramius/package-versions 1.2.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.3.0 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.0 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.1 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.2 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.5.0 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.5.1 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.6.0 requires php ^7.4.0 -> your php version (7.3.16) does not satisfy that requirement.
        - ocramius/package-versions 1.7.0 requires php ^7.4.0 -> your php version (7.3.16) does not satisfy that requirement.
        - ocramius/package-versions 1.8.0 requires php ^7.4.0 -> your php version (7.3.16) does not satisfy that requirement.
        - Root composer.json requires phpstan/phpstan ^0.11.5 -> satisfiable by phpstan/phpstan[0.11.19, 0.11.18, 0.11.17, 0.11.16, 0.11.15, 0.11.14, 0.11.13, 0.11.12, 0.11.11, 0.11.10, 0.11.9, 0.11.8, 0.11.7, 0.11.6, 0.11.5].
    
    You are using a snapshot build of Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report an issue to them to ask them to support Composer 2. To work around this you can run Composer with --ignore-platform-reqs, but this will also ignore your PHP version and may result in bigger problems down the line.
    Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    

     
  2. eva2000

    eva2000 Administrator Staff Member

    44,780
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    6:53 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    what PHP version you using ?

    output for
    Code (Text):
    php -v


    edit: hmm I see in your output
    In the /root/tools/phpmyadmin_update.sh if you edit the 2 references for
    Code (Text):
    php composer.phar update --no-dev

    to
    Code (Text):
    echo y | php composer.phar update --no-dev

    and run /root/tools/phpmyadmin_update.sh does it work ?
     
    Last edited: Apr 9, 2020
  3. Earl

    Earl New Member

    7
    4
    3
    Sep 17, 2015
    Ratings:
    +5
    Local Time:
    2:23 PM
    I'm so sorry for the delayed response.
    I erased everything on the server and installed centminmod again. Still getting the same result
    and it's already in phpmyadmin_update.sh

    Code (Text):
    # php -v
    PHP 7.3.16 (cli) (built: Apr  9 2020 18:22:42) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.16, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.16, Copyright (c) 1999-2018, by Zend Technologies
    
    

    Code (Text):
    # cat /root/tools/phpmyadmin_update.sh
    #!/bin/bash                                                                                                                                                                                              [0/34]
    export PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin"
    DT=$(date +"%d%m%y-%H%M%S")
    ##############################################
    CENTMINLOGDIR='/root/centminlogs'
    
    if [ ! -d "/root/centminlogs" ]; then
    mkdir /root/centminlogs
    fi
    ##############################################
    starttime=$(date +%s.%N)
    {
    echo "cd /usr/local/nginx/html/20103_mysqladmin11558"
    cd /usr/local/nginx/html/20103_mysqladmin11558
    rm -rf composer.lock
    echo "git pull"
    git pull
    rm -rf composer.phar
    wget -cnv https://getcomposer.org/composer.phar -O composer.phar
    echo y | php composer.phar update --no-dev
    
    if [ ! -f "$(which npm)" ]; then
            /usr/local/src/centminmod/addons/nodejs.sh install
    fi
    if [ ! -f /usr/bin/yarn ]; then
            npm install --global yarn
    fi
    # https://docs.phpmyadmin.net/en/latest/setup.html#installing-from-git
    if [ ! -f /usr/local/nginx/html/20103_mysqladmin11558/themes/pmahomme/css/theme.css ]; then
            yarn install
    elif [ -f /usr/local/nginx/html/20103_mysqladmin11558/themes/pmahomme/css/theme.css ]; then
            yarn run --silent css-compile --quiet --style=compressed
    fi
    chown nginx:nginx /usr/local/nginx/html/20103_mysqladmin11558
    chown -R nginx:nginx /usr/local/nginx/html/20103_mysqladmin11558
    
    } 2>&1 | tee ${CENTMINLOGDIR}/centminmod_phpmyadmin_update-${DT}.log
    
    endtime=$(date +%s.%N)
    
    INSTALLTIME=$(echo "scale=2;$endtime - $starttime"|bc )
    echo "" >> ${CENTMINLOGDIR}/centminmod_phpmyadmin_update-${DT}.log
    echo "Total phpmyadmin Update Time: $INSTALLTIME seconds" >> ${CENTMINLOGDIR}/centminmod_phpmyadmin_update-${DT}.log
    
    
    

    ss: https://imgur.com/FD3yd6M.png
     
  4. eva2000

    eva2000 Administrator Staff Member

    44,780
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    6:53 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Ah fixed and updated phpmyadmin.sh so try again. The composer folks updated latest to 2.x snapshot branch which doesn't work so I use older 1.10 branch on updated phpmyadmin.sh now
     
  5. Earl

    Earl New Member

    7
    4
    3
    Sep 17, 2015
    Ratings:
    +5
    Local Time:
    2:23 PM
    Awesome. I can see It's working now!
     
  6. eva2000

    eva2000 Administrator Staff Member

    44,780
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    6:53 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Glad to hear :)
     
  7. noly

    noly Member

    98
    16
    8
    Jul 24, 2017
    Germany
    Ratings:
    +28
    Local Time:
    10:53 AM
    1.18.x
    10.2.x
    PHP 7.1.33, up to date centmin mod
    --
    Getting the same error here...

    Code (Text):
    # /root/tools/phpmyadmin_update.sh
    cd /usr/local/nginx/html/32346_mysqladmin30344
    git pull
    Already up-to-date.
    2020-04-23 06:43:29 URL:https://getcomposer.org/composer.phar [2063240/2063240] -> "composer.phar" [1]
    Do not run Composer as root/super user! See https://getcomposer.org/root for details
    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - phpstan/phpstan 0.11.19 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.18 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.17 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.16 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.15 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.14 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.13 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.12 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.11 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.10 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.9 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.8 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.7 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.6 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - phpstan/phpstan 0.11.5 requires jean85/pretty-package-versions ^1.0.3 -> satisfiable by jean85/pretty-package-versions[1.2, 1.1, 1.0.3].
        - jean85/pretty-package-versions 1.2 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.2.0, ..., 1.8.0].
        - jean85/pretty-package-versions 1.1 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.2.0, ..., 1.8.0].
        - jean85/pretty-package-versions 1.0.3 requires ocramius/package-versions ^1.2.0 -> satisfiable by ocramius/package-versions[1.2.0, ..., 1.8.0].
        - ocramius/package-versions 1.2.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.3.0 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.0 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.1 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.4.2 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
        - ocramius/package-versions 1.5.0 requires php ^7.3.0 -> your php version (7.1.33) does not satisfy that requirement.
        - ocramius/package-versions 1.5.1 requires php ^7.3.0 -> your php version (7.1.33) does not satisfy that requirement.
        - ocramius/package-versions 1.6.0 requires php ^7.4.0 -> your php version (7.1.33) does not satisfy that requirement.
        - ocramius/package-versions 1.7.0 requires php ^7.4.0 -> your php version (7.1.33) does not satisfy that requirement.
        - ocramius/package-versions 1.8.0 requires php ^7.4.0 -> your php version (7.1.33) does not satisfy that requirement.
        - Root composer.json requires phpstan/phpstan ^0.11.5 -> satisfiable by phpstan/phpstan[0.11.5, ..., 0.11.19].
    
    You are using a snapshot build of Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report an issue to them to ask them to support Composer 2. To work around this you can run Composer with --ignore-platform-reqs, but this will also ignore your PHP version and may result in bigger problems down the line.
    Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
    
     
    Last edited: Apr 23, 2020
  8. pamamolf

    pamamolf Premium Member Premium Member

    3,831
    374
    83
    May 31, 2014
    Ratings:
    +718
    Local Time:
    11:53 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Did you download and use the latest fixed phpmyadmin sh file?
     
  9. noly

    noly Member

    98
    16
    8
    Jul 24, 2017
    Germany
    Ratings:
    +28
    Local Time:
    10:53 AM
    1.18.x
    10.2.x
    Actually i hadn't -_-

    THANK YOU for the hint!