Join the community today
Become a Member

phpmyadmin.sh Addon

Discussion in 'Add Ons' started by eva2000, May 25, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    no semi-colon as it's php-fpm config file not nginx

    phpmyadmin.sh addon needs to uncomment and enable in php-fpm.conf (does it automatically on phpmyadmin.sh install runs) as phpmyadmin.sh's unix socket for php is located at /usr/local/nginx/conf/phpfpmd/phpfpm_myadmin.conf
    Code (Text):
    include=/usr/local/nginx/conf/phpfpmd/*.conf
    


    if it's commented out, phpmyadmin unix socket in /usr/local/nginx/conf/phpfpmd/phpfpm_myadmin.conf will fail to load and php will be down for phpmyadmin = 502 error
     
  2. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    i just tested myself install phpmyadmin.sh and then upgrade php and it works fine for me, login and log out etc
     
  3. pamamolf

    pamamolf Well-Known Member

    2,378
    211
    63
    May 31, 2014
    Ratings:
    +356
    Local Time:
    6:46 PM
    Nginx-1.11.x
    MariaDB 10
    confused :(

    Code:
    /usr/local/etc/php-fpm.conf 
    That file is using ; for commenting correct?

    So having uncomment :
    Code:
    include=/usr/local/nginx/conf/phpfpmd/*.conf
    it will be ok if i use or not phpmyadmin and doesn't mean that i use multiple pools and will not cause any issues?

    As at this path are:
    Code:
    phpfpm_pool2.conf  phpfpm_pool3.conf  phpfpm_pool4.conf  phpfpm_pool5.conf
    and will be loaded....
     
  4. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    oh i thought you mean ending semi-colon as in nginx synax

    commenting in front with semi-colon ; is correct for php-fpm.conf
     
  5. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    uncommented then multiple php-fpm pools AND phpmyadmin.sh installed instance all work

    multiple php-fpm pools only work if you configure them as per https://community.centminmod.com/th...03-multiple-php-fpm-pools-support-added.3672/
     
  6. pamamolf

    pamamolf Well-Known Member

    2,378
    211
    63
    May 31, 2014
    Ratings:
    +356
    Local Time:
    6:46 PM
    Nginx-1.11.x
    MariaDB 10
    So if i have the include line enabled to get the phpmyadmin work and have the rest edits for multiple pools disabled that means that multiple pools config files will be loaded but multiple pools will not work?

    Is there a way for you to separate the phpmyadmin and multiple pools or the configs of them maybe?
     
  7. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    yup
    no way
     
    • Informative Informative x 1
  8. pamamolf

    pamamolf Well-Known Member

    2,378
    211
    63
    May 31, 2014
    Ratings:
    +356
    Local Time:
    6:46 PM
    Nginx-1.11.x
    MariaDB 10
    Please verify that having:

    Code:
    include=/usr/local/nginx/conf/phpfpmd/*.conf
    and

    Code:
        fastcgi_pass   127.0.0.1:9000;
        #fastcgi_next_upstream error timeout http_500 http_503;
        #fastcgi_pass phpbackend;
        #fastcgi_keep_conn on;
    Multiple pools will be disabled ...... ?
     
  9. eva2000

    eva2000 Administrator Staff Member

    26,465
    6,078
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +8,896
    Local Time:
    1:46 AM
    Nginx 1.11.x
    MariaDB 5.5
    yup