Want more timely Centmin Mod News Updates?
Become a Member

phpmyadmin.sh Addon

Discussion in 'Add Ons' started by eva2000, May 25, 2014.

  1. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I want to recommend to have phpmyadmin addon as default to latest Centminmod /addons folder with correct permissions ready to run :)


    Thank you
     
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Any thoughts for this?

    Yes or No ?

    :)
     
  3. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    planned for though i am weighing up whether main hostname should also default to https with letsencrypt ssl if it ends up as such then phpmyadmin.sh https routine would need updating too
     
  4. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Updating to latest version has some errors on login page :(

    [​IMG]
     
  5. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
  6. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    @pamamolf what if you try these commands
    Code (Text):
    cd /path/to/phpmyadmin/install
    git remote update origin
    git rebase origin/STABLE
    nprestart

    where /path/to/phpmyadmin/install would be something like /usr/local/nginx/html/14589_mysqladmin28939 though each install random digits are unique to each phpmyadmin.sh install
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I update it using:

    Code:
    /root/tools/phpmyadmin_update.sh
     
  8. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Yup that one works now with no errors :)

    Thanks !
     
  9. ndha

    ndha Member

    82
    10
    8
    Sep 28, 2014
    Ratings:
    +29
    Local Time:
    9:53 PM
    Latest
    10
    Hi @eva2000 i also got problem when installing PMA using your addons script,
    here it's error said :
    "File ./vendor/autoload.php missing or not readable.
    Most likely you did not run Composer to install library files. "

    i also tried to resolve with your way above (quote) but still error..
    what was happen actually??
     
  10. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    try updating centmin mod first via centmin.sh menu option 23 submenu option 2

    then uninstall phpmyadmin.sh via uninstall script at Addon phpmyadmin.sh - CentminMod.com LEMP Nginx web stack for CentOS and reinstall again but with updated phpmyadmin.sh

    download latest version of phpmyadmin.sh
    Code (Text):
    cd /usr/local/src/centminmod/addons
    rm -rf phpmyadmin.sh
    wget --no-check-certificate https://github.com/centminmod/phpmyadmin/raw/master/phpmyadmin.sh
    
     
  11. ndha

    ndha Member

    82
    10
    8
    Sep 28, 2014
    Ratings:
    +29
    Local Time:
    9:53 PM
    Latest
    10
    Hi @eva2000 i already do what you said but it's still same error i got..
    also i check 2 other vps using this centmin script, badly all PMA got same error..
    using centos 6 and 7 + php7 all update using centmin 23+2..

    I'm googling and see this :
    http://stackoverflow.com/questions/...oad-php-missing-or-not-readable-in-phpmyadmin
    PHP Fatal error: require_once(): Failed opening required './vendor/autoload.php' · Issue #12011 · phpmyadmin/phpmyadmin · GitHub
     
  12. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x

    phpmyadmin.sh 0.1.0 Update



    You can check your existing /usr/local/src/centminmod/addons/phpmyadmin.sh version via command
    Code (Text):
    grep -w VER /usr/local/src/centminmod/addons/phpmyadmin.sh
    

    example
    Code (Text):
    grep -w VER /usr/local/src/centminmod/addons/phpmyadmin.sh
    VER='0.1.0'
    


    phpmyadmin.sh addon installs phpmyadmin via git so it can do update updates via git pull. However, phpmyadmin git stable branch is now 4.7.0. phpyadmin 4.7.0 requires composer so the updated phpmyadmin.sh 0.1.0 script does a local composer.phar install to phpmyadmin git cloned directory for the required composer updates to missing files like "./vendor/autoload.php missing" as seen at https://community.centminmod.com/th...php-missing-or-not-readable.10997/#post-47170.

    Auto Fix



    Easiest way to update is uninstall your existing phpmyadmin install using uninstall script listed at Addon phpmyadmin.sh - CentminMod.com LEMP Nginx web stack for CentOS and then download latest phpmyadmin.sh addon script
    Code (Text):
    cd /usr/local/src/centminmod/addons
    rm -rf phpmyadmin.sh
    wget --no-check-certificate https://github.com/centminmod/phpmyadmin/raw/master/phpmyadmin.sh
    

    and then reinstall phpmyadmin.sh as per instructions at Addon phpmyadmin.sh - CentminMod.com LEMP Nginx web stack for CentOS

    Manual Fix



    If you don't want to uninstall, you can manually update your phpmyadmin install to the new requirements. Using below steps.

    Step 1. If your phpmyadmin install is at say /usr/local/nginx/html/2040_mysqladmin14941 go into that directory and type these commands
    Code (Text):
    cd /usr/local/nginx/html/2040_mysqladmin14941
    git pull
    rm -rf composer.phar
    wget -cnv https://getcomposer.org/composer.phar -O composer.phar
    php composer.phar update --no-dev
    


    Step 2. Edit the phpmyadmin_update.sh script at /root/tools/phpmyadmin_update.sh, edit /root/tools/phpmyadmin_update.sh and add after the git pull line, these 3 additional lines
    Code (Text):
    git pull
    rm -rf composer.phar
    wget -cnv https://getcomposer.org/composer.phar -O composer.phar
    php composer.phar update --no-dev
    


    Then restart nginx and php services
    Code (Text):
    nprestart
    


    Folks curious of the actual committed update can see it at phpmyadmin.sh 0.1.0 update for composer requirements · centminmod/phpmyadmin@82b0d02 · GitHub
     
    Last edited: Mar 31, 2017
  13. ndha

    ndha Member

    82
    10
    8
    Sep 28, 2014
    Ratings:
    +29
    Local Time:
    9:53 PM
    Latest
    10
    or for manual way :
    Edit the phpmyadmin_update.sh script at /root/tools/phpmyadmin_update.sh, and add after the git pull line, these 3 additional lines
    Code (Text):
    git pull
    rm -rf composer.phar
    wget -cnv https://getcomposer.org/composer.phar -O composer.phar
    php composer.phar update --no-dev
    


    then run : /root/tools/phpmyadmin_update.sh
     
  14. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    you don't need to run phpmyadmin_update.sh if you did the 1st step of manual fix
     
  15. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Latest Centminmod beta menu 23 submenu 2 shouldn't update phpmyadmin.sh ?

    After updating i can see v 0.8.0 and not 0.1.0 :(

    Ok i did it manually but i think Centminmod should update it as i was read that it does for other addons like nodejs.sh ......
     
  16. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
  17. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Nice :)
     
  18. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    When i install Phpmyadmin latest 0.1.0 (problem exist with the old version also 0.8.0) and then update php and nginx to new versions after the first phpmyadmin login i am getting a 502 error and there is no way to fix :(

    Reinstalling phpmyadmin is working great again....

    I have that problem on all servers so it is not specific to a server or configuration.....I use default configuration and no changes at all.....

    If you try the above and it works for you then try again to login after 15 days and see.....

    As i don't remember exact how i was able to reproduce that.....

    Centminmod latest 09 beta....
     
  19. eva2000

    eva2000 Administrator Staff Member

    47,474
    10,760
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,718
    Local Time:
    12:53 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    are you using multiple php-fpm pools ? on upgrades do you answer yes to rewrite php-fpm.conf ? when you rewrite php-fpm.conf you reset multiple php-fpm pools to disable via line in php-fpm.conf as it's commented out
    Code (Text):
    ;include=/usr/local/nginx/conf/phpfpmd/*.conf
    

    but i fixed that in 123.09beta01 on php upgrades to re-enable that line (uncomment)
     
    Last edited: Apr 17, 2017
  20. pamamolf

    pamamolf Premium Member Premium Member

    3,950
    402
    83
    May 31, 2014
    Ratings:
    +782
    Local Time:
    4:53 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I do not use anymore multiple phpfpm pools for most of my servers.

    On upgrades i always answer no as i do not want to overwrite my edits for pool settings most....

    But i think that on both servers that i had that issue i am using multiple pools.....as i can see there is no ; there ?

    Code:
    include=/usr/local/nginx/conf/phpfpmd/*.conf
    But on:

    Code:
    /usr/local/nginx/conf/php.conf
    the three lines related to multiple pools are commented and only the fastcgi_pass 127.0.0.1:9000; is enabled....

    Should i add the ; at include line?

    I just read that:

    But in my opinion that should be commented as multiple pools are disabled by default.

    So if a user want to enable the multiple pools he must enable also that one.....but not have it as enabled by default....

    Don't know if having enabled only the include line without the three needed lines for multiple pools can that cause any issues....
     
    Last edited: Apr 17, 2017