Learn about Centmin Mod LEMP Stack today
Register Now

phpmyadmin not working on Firefox

Discussion in 'Add Ons' started by sepulchre, Feb 13, 2020.

  1. sepulchre

    sepulchre Member

    163
    22
    18
    Dec 22, 2014
    Ratings:
    +28
    Local Time:
    4:05 AM
    If I try to access phpmyadmin via Firefox, it goes to an no-ending page reload with never being able to accessing it. I think it has something to do with it being not secure for whatever reason.

    If I try with Google Chrome, then it tells me it is not secure but I can access it.

    What could be the problem?

    Also I had this problem too but I reinstalled it.


    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: nginx/1.17.7
    • PHP Version Installed: 7.3.11
    • MariaDB MySQL Version Installed: 10.3.20 (10.3.20-MariaDB)
    • When was last time updated Centmin Mod code base ? : a month ago
     
  2. sepulchre

    sepulchre Member

    163
    22
    18
    Dec 22, 2014
    Ratings:
    +28
    Local Time:
    4:05 AM
    Bump.
     
  3. eva2000

    eva2000 Administrator Staff Member

    44,691
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,793
    Local Time:
    12:05 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    What's output for this command in SSH - just replace the 1st line's domain variable yourdomain.com with your domain name for your phpmyadmin hostname and keep 2nd line as is the sed replacement tries to replace your domain with domain.com dummy name
    Code (Text):
    domain=yourdomain.com
    curl -sIL https://$domain 2>&1 | sed -e "s|$domain|domain.com|g"
    

    for posting code or output from commands to keep the formatting, you might want to use CODE tags for code How to use forum BBCODE code tags :)

    Are you accessing phpmyadmin via hostname or IP address ? if you access via server IP address, does it work ?
     
  4. sepulchre

    sepulchre Member

    163
    22
    18
    Dec 22, 2014
    Ratings:
    +28
    Local Time:
    4:05 AM
    Code (Text):
    HTTP/1.1 200 OK
    Date: Fri, 06 Mar 2020 03:06:59 GMT
    Content-Type: text/html; charset=utf-8
    Content-Length: 114488
    Connection: keep-alive
    Vary: Accept-Encoding
    X-Frame-Options: SAMEORIGIN
    X-Content-Type-Options: nosniff
    Last-Modified: Fri, 06 Mar 2020 03:06:59 GMT
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: private, no-cache, max-age=0
    Set-Cookie: xf_csrf=RObQSPqWMvbwgIq6; path=/; secure
    Server: nginx centminmod
    X-Powered-By: centminmod
    Strict-Transport-Security: max-age=31536000;


    I tried to replace hostname with ip address, same result. It keeps loading and loading but never finds something. I was using the url which phpmyadmin installation gave me, which is with hostname.

    The expiry date looks funny, not sure if that is supposed to be.
     
  5. eva2000

    eva2000 Administrator Staff Member

    44,691
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,793
    Local Time:
    12:05 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Code (Text):
    Strict-Transport-Security: max-age=31536000;
    

    It could be related to enabling HSTS see below info and last sentence link to how to clear your browser's HSTS cache and see if that gives you access.

    Are the host.domain.com and HTTPS enabled site also on same top level domain.com ? did you enable HSTS with include subdomain too ? if you did then you're telling browsers to force HTTP to HTTPS redirected connections for domain.com and any *.domain.com subdomain as well

    see Enabling HSTS for SSL for specifics
    As accessing host.domain.com is usually reserved for stats and admin pages the Centmin Mod LEMP stack owner only needs to access, you can just clear your web browser's HSTS record for the domain.com and host.domain.com so the web browser no longer redirects from HTTP to HTTPS. I posted a thread at SSL - How to clear HSTS browser cache | Centmin Mod Community specifically for this :)