Want more timely Centmin Mod News Updates?
Become a Member

Install phpMyAdmin Installation

Discussion in 'Add Ons' started by tdubs, Dec 11, 2016.

  1. tdubs

    tdubs Member

    77
    11
    8
    Apr 10, 2015
    Ratings:
    +14
    Local Time:
    9:50 AM
    1.7.12
    10.0.17
    Hey,

    So installing the phpMyAdmin addon has been a hit or miss for me on quite a bit of machines now that I've installed this addon to. It's getting to the point that I'd like a final answer as to what I'm doing incorrectly causing it to not work for me properly. Anyways, whenever I visit the designated URL given in the installation, I get the following:

    Code:
    The page nexus.bobbaforums.pro is not working.
    nexus.bobbaforums.pro redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS
    
    Troubleshooting steps I have performed:
    1. Made sure I was updated to the most updated version of Centmin Mod.
    2. I have a static IP address. Before the installation, I changed STATICIP='y'.
    3. I double checked Step 1 of Getting Started.
    4. Used my raw server IP with HTTPS:// to access phpMyAdmin, still no luck.
    5. Ran nprestart and even did a server reboot just to make sure.

    Hostname setup:
    Code:
    uname -u
    Output: nexus.bobbaforums.pro

    Code:
    nano -w /etc/hostname
    Output: nexus.bobbaforums.pro

    Code:
    hostnamectl status
    
    Output:
    Code:
    nano /etc/hosts
    Output:
    144.21x.xx.x nexus.bobbaforums.pro nexus

    Cloudflare: Setup an A Record called 'nexus' pointing to 144.21x.xx.x

    So all in all, I'm not sure what I'm missing here.

    Any ideas? Thanks!
     
  2. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    9:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    As you are behind Cloudflare, do you have Cloudflare HTTPS enabled with HTTP to HTTPS redirect ? That might cause problems as phpmyadmin.sh addon has it's own HTTP to HTTPS redirect so you'd be going into a redirect loop I think. Maybe setup a Cloudflare page rule to the phpmyadmin url /yourphpmyadmin to disable HTTPS redirect and see

    A few things to try
    • If you upgraded PHP after you installed phpmyadmin addon, try clearing browser cache and restarting nginx and php-fpm
    • Check nginx error and access log - FAQ item 19 and Config Files page for overview.
    • Ensure you have a valid DNS for the main hostname pointing to your server's IP address
    • Ensure main hostname is setup as per step 1 of Getting Started Guide where main hostname is not the same as a site's nginx vhost domain name. They have to be different as outlined in the difference and summary of Getting Started Guide.
      This allows the main hostname vhost to house all the PHP and nginx statistic pages and phpmyadmin urls.
    • So ensure the server_name listed in main hostname vhost at /usr/local/nginx/conf/conf.d/virtual.conf isn't referenced in other nginx domain vhost files.
    Post contents of these files wrapped in BBCODE CODE tags
    • /usr/local/nginx/conf/conf.d/virtual.conf
    • /usr/local/nginx/conf/conf.d/phpmyadmin_ssl.conf
    • /usr/local/nginx/conf/phpmyadmin.conf
     
  3. elargento

    elargento Member

    284
    16
    18
    Jan 4, 2016
    Ratings:
    +37
    Local Time:
    8:50 PM
    10
    I was getting same error, after upgraded centmin I can't reproduce it.