Join the community today
Register Now

Sysadmin php upgrade

Discussion in 'System Administration' started by dotpro, Nov 28, 2019.

Tags:
  1. dotpro

    dotpro New Member

    11
    0
    1
    Dec 5, 2017
    Ratings:
    +0
    Local Time:
    8:01 AM
    CentOS Version: CentOS Linux 7.4.1708, 64Bit
    Centmin Mod Version Installed: 123.09beta01.b337
    Nginx Version Installed: 1.17.5
    PHP Version Installed: 5.6.32
    MariaDB MySQL Version Installed: 10.1.30
    When was last time updated Centmin Mod code base: today, latest version

    I've recently started receiving php version warnings in wordpress (cURL error 77 errors on the wordpress site) and have plans to upgrade to xenforo 2.x soon so it seems like I will have to upgrade php to latest version. Currently running 5.6.32.

    My question is that, are there any gotchas which I need to be aware of if I run the php upgrade option? Any settings which need to be changed after the upgrade? Or will everything work after the upgrade, baring any compatibility issues with particular plugins, etc.?


    thanks
     
  2. eva2000

    eva2000 Administrator Staff Member

    44,750
    10,205
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,816
    Local Time:
    10:01 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Not much on Centmin Mod side. Though 5.6.32 is ancient and insecure. Centmin Mod 123.09beta01 backports security fixes from PHP 7.1.33+ to PHP 5.6.40 so that would be minimum version you'd want to run on EOL PHP 5.6 branch.

    But compatibility for yoru wordpress and php plugins/code depends. Safest version to try would be PHP 7.2.25 first or 7.3.12. If stuff breaks just downgrade PHP version and/or contact wordpress plugin author.