Want to subscribe to topics you're interested in?
Become a Member

PHP-FPM PHP upgrade prompts ?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Sunka, Dec 3, 2016.

  1. Sunka

    Sunka Active Member

    917
    240
    43
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +388
    Local Time:
    11:50 PM
    Nginx 1.13.3
    MariaDB 10.1.24
    When upgrading, what to choose for overwrite php.ini?
    Should we choose classic steps (yum check YES, overwrite php.ini NO, zend opcache YES, php 7.1.0) - if I remember correctly
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    7:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    For major php versions you can answer yes to overwrite php.ini make sure it's php.ini not php-fpm.conf which may not need overwriting
     
  3. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    12:50 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Why i don't remember to get that question prompt ever?

     
  4. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    7:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    php upgrade routine does a diff check against php.ini you use and one available from php upgrade version, if they differ i.e if you manually edited php.ini then there maybe a prompt. If no difference, then no prompt.

    Generally you should not be directly editing php.ini but using custom .ini file as outlined at PHP-FPM - CentminMod.com LEMP Nginx web stack for CentOS
     
  5. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    12:50 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I am always using the custom ini file that's why then :)
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    7:50 AM
    Nginx 1.13.x
    MariaDB 5.5
  7. Sunka

    Sunka Active Member

    917
    240
    43
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +388
    Local Time:
    11:50 PM
    Nginx 1.13.3
    MariaDB 10.1.24
    Ah, now I found. I wrote incorrect, I mean php-fpm.conf
    So, when upgrading to 7.1, choose NO for Update & overwrite your existing php-fpm.conf ?
     
  8. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    7:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    yup.. only need to answer yes if you see a github commit talk about updating php-fpm.conf heh
     
    • Winner Winner x 1