Want to subscribe to topics you're interested in?
Become a Member

PHP-FPM Php Recompile Error

Discussion in 'Install & Upgrades or Pre-Install Questions' started by jsx, Jan 23, 2024.

  1. jsx

    jsx New Member

    2
    0
    1
    Jan 23, 2024
    Ratings:
    +0
    Local Time:
    9:58 PM
    1.25.3
    10.4.32
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 124.00stable
    • Nginx Version Installed: 1.25.3
    • PHP Version Installed: 7.4.32
    • MariaDB MySQL Version Installed: 10.4.32-MariaDB
    • When was last time updated Centmin Mod code base ? : today
    • Persistent Config:
      Code (Text):
      NGINX_GEOIPTWOLITE='y'
      NGXDYNAMIC_GEOIPTWOLITE='y'
      NGXDYNAMIC_VHOSTSTATS='y'
      NGINX_VHOSTSTATS='y'
      #PHPSNMP='n'
      PHPFINFO='y'
      

      All First Log : /etc/security/limits.conf


      An error occurred while adding the php fileinfo plugin. to customconfig file

      PHPFINFO='y'

      I added.


      The first time I tried it this way;
      configure: error: "SNMP sanity check failed. Please check config.log for more information." it showed this error.

      After that
      to customconfig file
      PHPSNMP='n'
      I added.
      Other Log : https://www.paste.tc/err-79858


     
    Last edited by a moderator: Feb 23, 2024
  2. eva2000

    eva2000 Administrator Staff Member

    52,657
    12,071
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,597
    Local Time:
    4:58 AM
    Nginx 1.25.x
    MariaDB 10.x
    Ah your thread was caught in moderation. Any reason why you're using PHP 7.4.32 and not 7.4.33 ?

    Code (Text):
    Current PHP Version: 7.4.32
    Latest PHP Version Installable: 7.4.33
    
    Enter PHP Version number you want to upgrade/downgrade to: 7.4.32
    

    Try updating 124.00stable via cmupdate command and ensure glibc is up to date
    Code (Text):
    yum -y update
    

    Code (Text):
    yum list installed glibc* -q
    

    should output
    Code (Text):
    yum list installed glibc* -q
    Installed Packages
    glibc.x86_64                         2.17-326.el7_9                 @updates
    glibc-common.x86_64                  2.17-326.el7_9                 @updates
    glibc-devel.x86_64                   2.17-326.el7_9                 @updates
    glibc-headers.x86_64                 2.17-326.el7_9                 @updates
    

    ensure in particular glibc-devel RPM YUM package is installed
    Code (Text):
    yum -y install glibc-devel

    and then run centmin.sh menu option 5 and use PHP 7.4.33