Want to subscribe to topics you're interested in?
Become a Member

php opcache / 0.8?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Oxide, Aug 7, 2015.

  1. Oxide

    Oxide Active Member

    504
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    9:36 PM
    Is this enabled by default? I have to restart php-fpm to see changes XD caching is real..
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,180
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    9:36 PM
    Nginx 1.13.x
    MariaDB 5.5
  3. Oxide

    Oxide Active Member

    504
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    9:36 PM
    How can I disable this temporarily?

    i think its causing ipboard issues

    Code:
    [09-Aug-2015 22:27:25 UTC] PHP Fatal error:  Uncaught exception 'IPS\Db\Exception' with message 'Column 'session_log_in_time' cannot be null' in /home/nginx/domains/domain.net/public/system/Db/Db.php:412
    
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,180
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    9:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    find your apc.ini or zendopcache.ini via command
    Code:
    php --ini
    the edit that file and comment out the apc.so or opcache.so load extension line with hash # in front and save .ini file and restart php-fpm

    to reverse and re-enable, uncomment and remove hash and restart php-fpm