Join the community today
Become a Member

PHP-FPM PHP Make Failure for PHP 7.4.x

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by gawk, May 23, 2021.

  1. gawk

    gawk New Member

    12
    7
    3
    Feb 24, 2018
    Ratings:
    +9
    Local Time:
    11:50 AM
    nginx-1.13.9
    MariaDB 10.3.4
    I'm trying to upgrade my centmin box to PHP 7.4.19 (also tried 7.4.18) but I keep getting the same failures. Tried a few debugging steps but nothing helped?

    Updating 7.3.x versions works.

    I'm using a dedicated server from Online.net with boxes in Proxmox. 8 cores are available for this box and 8GB of RAM.


    Software versions:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.19.10
    • PHP Version Installed: 7.3.27
    • MariaDB MySQL Version Installed: 10.1.xx
    • When was last time updated Centmin Mod code base: today
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command
    Custom_config:
    Code (Text):
    LIBRESSL_SWITCH='n'
    
    CLANG='n'
    DEVTOOLSETSIX='n'
    DEVTOOLSETSEVEN='y'
    DEVTOOLSETEIGHT='n'
    NGINX_DEVTOOLSETGCC='y'
    
    PHP_PGO='n'
    

    PHP Install log:
    Code (Text):
    https://pastebin.com/Kc8gtcyL
    
     
    Last edited: May 23, 2021
  2. Matt

    Matt Well-Known Member

    867
    393
    63
    May 25, 2014
    Rotherham, UK
    Ratings:
    +613
    Local Time:
    10:50 AM
    1.5.15
    MariaDB 10.2
    Code:
    No package 'libffi' found
    Code:
    [17:36][root@hz1.mattwservices.co.uk ~]# yum list installed | grep libffi
    libffi.x86_64                         3.0.13-19.el7              installed     
    libffi-devel.x86_64                   3.0.13-19.el7              @base      
    Looks like you have a repo mirror failing as well, so probably couldn't install the required package.
     
  3. gawk

    gawk New Member

    12
    7
    3
    Feb 24, 2018
    Ratings:
    +9
    Local Time:
    11:50 AM
    nginx-1.13.9
    MariaDB 10.3.4
    Thanks Matt, that was the issue!

    I removed the failing repo, and all the other sources started working and I managed to install libffi. Afterwards, I could also install PHP 7.4.19.
     
  4. eva2000

    eva2000 Administrator Staff Member

    46,851
    10,627
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,493
    Local Time:
    7:50 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    @Matt nice work! @gawk glad to see it's sorted :)