Join the community today
Register Now

PHP-FPM PHP 7?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Oxide, Jan 19, 2016.

  1. Oxide

    Oxide Active Member

    505
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    2:14 AM
    I am currently running 1.2.3-eva2000.08, i made a topic before regarding this or replied one..

    I want to upgrade, is it safe yet? I use PHP Suohshin & Zend OP Cache.

    Code:
    php --ini
    Configuration File (php.ini) Path: /usr/local/lib
    Loaded Configuration File:         /usr/local/lib/php.ini
    Scan for additional .ini files in: /etc/centminmod/php.d
    Additional .ini files parsed:      /etc/centminmod/php.d/a_customphp.ini,
    /etc/centminmod/php.d/curlcainfo.ini,
    /etc/centminmod/php.d/geoip.ini,
    /etc/centminmod/php.d/igbinary.ini,
    /etc/centminmod/php.d/imagick.ini,
    /etc/centminmod/php.d/memcache.ini,
    /etc/centminmod/php.d/memcached.ini,
    /etc/centminmod/php.d/mongodb.ini,
    /etc/centminmod/php.d/redis.ini,
    /etc/centminmod/php.d/suhosin.ini,
    /etc/centminmod/php.d/zendopcache.ini
    
    If it's safe, could anyone provide me some 'basic' steps on what I should do? anything i should backup etc before doing so?

    I assume I can just use the php upgrade option.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,898
    6,908
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,403
    Local Time:
    2:14 AM
    Nginx 1.13.x
    MariaDB 5.5
    fyi, suhosin doesn't work for php 7

    as to upgrade just upgrade and see if it doesn't work just downgrade php again.. nothing lost really
     
  3. Oxide

    Oxide Active Member

    505
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    2:14 AM
    Alright, well as long as nothing breaks permanent when upgrading/downgrading I'll give it a go.. when suhoshin is compatible.