Want more timely Centmin Mod News Updates?
Become a Member

PHP-FPM PHP 7 compatibility wrapper for deprecated mysql extension

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by joshuah, Apr 27, 2017.

  1. eva2000

    eva2000 Administrator Staff Member

    49,005
    11,230
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,481
    Local Time:
    6:20 AM
    Nginx 1.21.x
    MariaDB 10.x
    did you exit centmin.sh menu as instructed after menu option 23 submenu option 2 update and re-run centmin.sh for menu option 5 php update ? if not then the updated code doesn't register with centmin.sh until re-running centmin.sh again after exiting

    try
    Code (Text):
    cd /usr/local/src/centminmod
    ./centmin.sh
    

    menu option 5 to php recompile for 7.0.18

     
  2. joshuah

    joshuah Member

    121
    14
    18
    Apr 3, 2017
    Ratings:
    +17
    Local Time:
    6:20 AM
    Yep, perfecto. My mistake. Thanks.
     
  3. eva2000

    eva2000 Administrator Staff Member

    49,005
    11,230
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,481
    Local Time:
    6:20 AM
    Nginx 1.21.x
    MariaDB 10.x
    Great to hear :D
     
  4. joshuah

    joshuah Member

    121
    14
    18
    Apr 3, 2017
    Ratings:
    +17
    Local Time:
    6:20 AM
    FYI - it seems that the 7.1.5 upgrade breaks the legacy support (even when you choose "y").
     
  5. eva2000

    eva2000 Administrator Staff Member

    49,005
    11,230
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,481
    Local Time:
    6:20 AM
    Nginx 1.21.x
    MariaDB 10.x
    it worked with 7.1.4 ?
     
  6. joshuah

    joshuah Member

    121
    14
    18
    Apr 3, 2017
    Ratings:
    +17
    Local Time:
    6:20 AM
    Not sure. I went from 7.0.x straight to 7.1.5 and it did not work.
     
  7. eva2000

    eva2000 Administrator Staff Member

    49,005
    11,230
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,481
    Local Time:
    6:20 AM
    Nginx 1.21.x
    MariaDB 10.x
    PHP 7.1 branch totally removed mysql legacy extension support
    when updating PHP 7.1.5 with mysql legacy enabled
    Code (Text):
    configure: WARNING: unrecognized options: --with-mysql, --with-t1lib
    

    so stick with PHP 7.0.x branch
     
  8. pamamolf

    pamamolf Premium Member Premium Member

    3,989
    414
    83
    May 31, 2014
    Ratings:
    +804
    Local Time:
    11:20 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Maybe to add a check at the php upgrade prompt when a user add 7.1.x then the script to not ask about legacy support as it will not work anyway ? :)