Learn about Centmin Mod LEMP Stack today
Register Now

php 7.3.8 make error

Discussion in 'Install & Upgrades or Pre-Install Questions' started by steph40, Aug 12, 2019.

  1. steph40

    steph40 Premium Member Premium Member

    57
    11
    8
    Jan 28, 2019
    Ratings:
    +23
    Local Time:
    12:56 PM
    1.1.5
    mariadb 10
    Please fill in any relevant information that applies to you:
    • CentOS Version: centos 7
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.17.2
    • PHP Version Installed: 7.3.8
    • MariaDB MySQL Version Installed: 10.3
    • When was last time updated Centmin Mod code base ? : every day, sometime twice lol
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      cat /etc/centminmod/custom_config.inc
      
    • Code (Text):
      [*]LETSENCRYPT_DETECT='y'
      ENABLE_MARIADBTENTWOUPGRADE='y'
      ENABLE_MARIADBTENTHREEUPGRADE='y'
      NGXDYNAMIC_NGXPAGESPEED='y'
      NGINX_PAGESPEED='y'
      PHP_PGO='y'
      SWITCH_PHPFPM_SYSTEMD='y'
      NGINX_DYNAMICTLS='y'
      MEMCACHED_TLS='y'
      
      LIBRESSL_SWITCH='n'
      CLANG='n'
      DEVTOOLSETSIX='n'
      DEVTOOLSETSEVEN='n'
      DEVTOOLSETEIGHT='y'
      NGINX_DEVTOOLSETGCC='y'
      NGINX_FATLTO_OBJECTS='n'
      NGINXOPENSSL_FATLTO_OBJECTS='n'
      NGINX_IOURING_PATCH='y' 
      AUTOHARDTUNE_NGINXBACKLOG='y'
      NGINX_SSLCACHE_ALLOWOVERRIDE='y' 
      NGINX_ALLOWOVERRIDE='y'
      
      CLOUDFLARE_ZLIBPHP='y'
      CLOUDFLARE_ZLIB='y'
      NGINX_HPACK='y'
      
      PHP_LIBZIP='y'
      PHP_ARGON='y'
      PHP_BROTLI='y'
      PHP_LZFOUR='y'
      PHP_LZF='y' 
      PHP_ZSTD='y'
      AUTODETECPHP_OVERRIDE='y'
      
      NGXDYNAMIC_BROTLI='y'
      NGINX_LIBBROTLI='y'
      
      NGINX_MODSECURITY_MAXMIND='N'
      
    • attaching log file
    • https://pastebin.com/4bDyGFr9

     
    Last edited: Aug 12, 2019
  2. EckyBrazzz

    EckyBrazzz Active Member

    538
    112
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +207
    Local Time:
    1:56 PM
    1.17.x
    10.3.x
    report errors on the forums at community.centminmod.com/forums/8/
    with info asked at community.centminmod.com/threads/17857/
     
  3. steph40

    steph40 Premium Member Premium Member

    57
    11
    8
    Jan 28, 2019
    Ratings:
    +23
    Local Time:
    12:56 PM
    1.1.5
    mariadb 10
    My bad was distracted
     
  4. eva2000

    eva2000 Administrator Staff Member

    41,088
    9,195
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,105
    Local Time:
    2:56 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    does php 7.3.7 work ?

    what happens if you disable from persistent config file CLOUDFLARE_ZLIBPHP='y'

    when you re-run centmin.sh menu option 5 at yum check prompt enter = n and see if that works too
     
  5. steph40

    steph40 Premium Member Premium Member

    57
    11
    8
    Jan 28, 2019
    Ratings:
    +23
    Local Time:
    12:56 PM
    1.1.5
    mariadb 10
    Sorry for the wait shower is leaking 2 floors down.

    I ended up doing a reinstall and the only persistent config I got now is
    Code (Text):
    LETSENCRYPT_DETECT='y'
    


    When I get more time will test a little more.

    Thanks
     
    • Informative Informative x 1