Want to subscribe to topics you're interested in?
Become a Member

PHP PHP 5.6.17 is available

Discussion in 'Nginx and PHP-FPM news & discussions' started by eva2000, Jan 8, 2016.

  1. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
  2. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    security fixes so get updating via centmin.sh menu option 5 !

     
    • Informative Informative x 1
    • Useful Useful x 1
  3. ndha

    ndha Member

    54
    11
    8
    Sep 28, 2014
    Ratings:
    +24
    Local Time:
    11:00 AM
    Latest
    10
    @eva2000 is it normal every php update, phpmyadmin got 502 Bad Gateway??
    before update i see 5 php-fpm listen port 9000-9005, after update only port 9000 is up..
    so i must reinstall phpmyadmin again and again..
    is it any trick to avoid that???
    so it's only as simple as update using menu option 5 and don't worry other's apps is error..
     
  4. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    it's not normal but can happen especially if you use zend opcache/php7 (in which case restart php-fpm should fix it)

    did you enable multiple php-fpm pools for port 9000-9005 ? edit: okay phpmyadmin.sh would of inadvertently enabled multiple php-fpm pools due to needing to enable support for phpmyadmin pool at /usr/local/nginx/conf/phpfpmd/phpfpm_myadmin.conf via phpmyadmin/phpmyadmin.sh at master · centminmod/phpmyadmin · GitHub

    also FYI, phpmyadmin.sh addon uses unix socket at /tmp/phpfpm_myadmin.sock and not TCP port anyway
     
  5. ndha

    ndha Member

    54
    11
    8
    Sep 28, 2014
    Ratings:
    +24
    Local Time:
    11:00 AM
    Latest
    10
    I'm using standard config for this testing server, only add phpmyadmin and custom curl..
    so before update in production vps, i update in testing first to see what impact on it.
    Using Zend Opcache and php 5.6.16 before..Update using menu no.5..
    yes, install phpmyadmin enable multiple php-fpm pools itself..
    nah i also see that phpmyadmin uses unix socket, but it's weird every i updating php it always 502,
    before update multiple php-fpm pools is enable, after update only port 9000 is active,
    happen 2 times before and must reinstall phpmyadmin again..
     
    • Informative Informative x 1
  6. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    interesting check for me after you update php, in the file /usr/local/etc/php-fpm.conf is this line commented out or enabled (without semi-colon ;)
    Code:
    ;include=/usr/local/nginx/conf/phpfpmd/*.conf
    edit: i can see this happening if you answer yes to overwrite php-fpm.conf on php updates as it disables multiple pools by commenting out
    Code:
    ;include=/usr/local/nginx/conf/phpfpmd/*.conf
    Code:
    Want to update to latest php-fpm.conf ? (overwrites will auto backup existing php-fpm.conf)
    i'll add a before and after check to inc/php_upgrade.inc to ensure if you overwrite php-fpm.conf then multi-pool support gets re-enabled
    Code:
    include=/usr/local/nginx/conf/phpfpmd/*.conf
     
    • Like Like x 1
  7. ndha

    ndha Member

    54
    11
    8
    Sep 28, 2014
    Ratings:
    +24
    Local Time:
    11:00 AM
    Latest
    10
    Nah, you absolutely right...
    i do like that, after i enable, phpmyadmin can be access again..
    Thanks for you help.. :D
     
  8. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 2
    • Informative Informative x 1
  9. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 2
  10. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
  11. deltahf

    deltahf Active Member

    207
    101
    43
    Jun 8, 2014
    Ratings:
    +154
    Local Time:
    12:00 AM
    Just completed the upgrade, but noticed this warning as PHP-FPM was restarting. It appears every time I try to restart the service:
    Code:
    $ service php-fpm restart
    
    Gracefully shutting down php-fpm . done
    
    Starting php-fpm [30-Jan-2016 02:30:40] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/imagick.so' - libMagickWand.so.2: cannot open shared object file: No such file or directory in Unknown on line 0
    
    done
    During the install I chose the option to not use a new php.ini.

    Any way to fix this?
     
  12. eva2000

    eva2000 Administrator Staff Member

    29,732
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    2:00 PM
    Nginx 1.13.x
    MariaDB 5.5
    run centmin.sh menu option 15 to recompile imagick php extension
     
    • Like Like x 1
    • Agree Agree x 1
  13. deltahf

    deltahf Active Member

    207
    101
    43
    Jun 8, 2014
    Ratings:
    +154
    Local Time:
    12:00 AM
    Oh! If only everything was so easy. :)

    Thanks!
     
    • Like Like x 1