Get the most out of your Centmin Mod LEMP stack
Become a Member

Wordpress Optimus could not find images. cURL library not detected?

Discussion in 'Blogs & CMS usage' started by Doni, Mar 9, 2018.

  1. Doni

    Doni Member

    32
    1
    8
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    10:47 AM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Hi Eva,

    I have a lil bit problem with Optimus plugins that comes with the default instalation of the wordpress. Its seems that the plugins could not find the images, so it could not optimize it.

    Ive got a warning on wordpress dashboard that optimus cUrl library is need.

    Optimus requires the cURL-Library. Please contact your hosting provider to get cURL installed.

    I check on my server it seemd the curl library is installed properly.

    Code:
    [17:58]# curl -V
    curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.28.4 zlib/1.2.7 libidn/1.28 libssh2/1.4.3
    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
    Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz unix-sockets 
    Can you help me with this. Thanks

    Screen Shot 2018-03-09 at 1.24.08 AM.png
     
    Last edited: Mar 9, 2018
  2. eva2000

    eva2000 Administrator Staff Member

    36,055
    7,910
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,192
    Local Time:
    1:47 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Does the plugin require shell_exec php function ? Centmin Mod disables shell_exec php function by default for security in your PHP-FPM config file at /usr/local/etc/php-fpm.conf (you can use command shortcut fpmconf to invoke nano text editor opening & editing /usr/local/etc/php-fpm.conf )

    to disable command out the line with semi-colon
    Code (Text):
    ;php_admin_value[disable_functions] = shell_exec
    

    restart php-fpm with command shortcut
    Code (Text):
    fpmrestart
    

    or usual service restart
    Code (Text):
    service php-fpm restart
    

    Also check if PHP was compiled with curl support which it should do using phpinfo page for curl section or php command below
    Code (Text):
    php --ri curl
    

    output if curl exists and supported in PHP
    Code (Text):
    php --ri curl
    
    curl
    
    cURL support => enabled
    cURL Information => 7.29.0
    Age => 3
    Features
    AsynchDNS => Yes
    CharConv => No
    Debug => No
    GSS-Negotiate => Yes
    IDN => Yes
    IPv6 => Yes
    krb4 => No
    Largefile => Yes
    libz => Yes
    NTLM => Yes
    NTLMWB => Yes
    SPNEGO => No
    SSL => Yes
    SSPI => No
    TLS-SRP => No
    Protocols => dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
    Host => x86_64-redhat-linux-gnu
    SSL Version => NSS/3.28.4
    ZLib Version => 1.2.7
    libSSH Version => libssh2/1.4.3
    
     
  3. Doni

    Doni Member

    32
    1
    8
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    10:47 AM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    I've check /usr/local/etc/php-fpm.conf and the shell_exec php function is not disable
    Code (Text):
    php_admin_value[disable_functions] = shell_exec
    


    And php --ri curl give me this:
    Code (Text):
    curl
    
    cURL support => enabled
    cURL Information => 7.29.0
    Age => 3
    Features
    AsynchDNS => Yes
    CharConv => No
    Debug => No
    GSS-Negotiate => Yes
    IDN => Yes
    IPv6 => Yes
    krb4 => No
    Largefile => Yes
    libz => Yes
    NTLM => Yes
    NTLMWB => Yes
    SPNEGO => No
    SSL => Yes
    SSPI => No
    TLS-SRP => No
    Protocols => dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
    Host => x86_64-redhat-linux-gnu
    SSL Version => NSS/3.28.4
    ZLib Version => 1.2.7
    libSSH Version => libssh2/1.4.3
    


    I'm really not sure whats the problem, because i've done instalation with centmin menu 22, and the optimus plugin that come along with the instalation never gave me a problem.

    Oh fyi, i'm using Centmin Mod Menu 123.09beta01
     
  4. pamamolf

    pamamolf Well-Known Member

    3,113
    295
    83
    May 31, 2014
    Ratings:
    +530
    Local Time:
    6:47 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    It is disabled:
    You may want to remove the shell_exec and restart phpfpm...
     
    • Agree Agree x 1
  5. eva2000

    eva2000 Administrator Staff Member

    36,055
    7,910
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,192
    Local Time:
    1:47 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Might want to contact Optimus developers and see if something changed code detection wise at their end
     
..