Want to subscribe to topics you're interested in?
Become a Member

open_basedir = No input file specified.

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Oxide, Aug 27, 2015.

Tags:
  1. Oxide

    Oxide Active Member

    503
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    4:21 AM
    Commenting it out or removing it then use ngxrestart, makes certain pages give "No input file specified.".. the page where i have CURLOPT_FOLLOWLOCATION which is required for it to be disabled.. gives that error lol

    #fastcgi_param PHP_ADMIN_VALUE open_basedir=$document_root/:/usr/local/lib/php/:/tmp/;
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,156
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    4:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    tried restarting php-fpm as well

    this cmd restarts both nginx + php-fpm
    Code:
    nprestart
     
  3. Oxide

    Oxide Active Member

    503
    29
    28
    Mar 19, 2015
    Ratings:
    +54
    Local Time:
    4:21 AM
    wow that solved it, sorry.. thanks
     
    • Like Like x 1
  4. eva2000

    eva2000 Administrator Staff Member

    30,156
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    4:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    yup, because open_basedir is a php setting just set in nginx :)
     
    • Informative Informative x 1