Learn about Centmin Mod LEMP Stack today
Register Now

PHP-FPM No PHP GD installed?

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by rdan, Jan 15, 2020.

  1. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • PHP Version Installed: 7.3.13
    • When was last time updated Centmin Mod code base ? : cmupdate command
    I tried switching back 7.3 and 7.2, deleted all files under svr-setup.. but still no GD module :/.

    Where should I start debugging this?
    Thanks a lot!
     
  2. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    php -m, doesn't return GD
     
  3. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    I notice this error:
     
  4. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    Seems only applicable to PHP 7.4, not with 7.3 and below.
     
  5. eva2000

    eva2000 Administrator Staff Member

    42,833
    9,705
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,970
    Local Time:
    11:23 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    you set PHP_VERSION to PHP_VERSION='7.4.2' in your persistent config file at /etc/centminmod/custom_config.inc so centmin.sh menu option 5 picked that as PHP = 7.4 so installed PHP 7.4's different configure flag for GD etc. Remove PHP_VERSION='7.4.2' and try again

    though I guess it's still a bug if it's ran on centmin.sh menu option 5, as PHP version specified there should take priority.
     
    • Agree Agree x 1
  6. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    Yeah suspected that, and I'm running centmin menu 5 right now.
    Hopefully get's resolve.
     
  7. rdan

    rdan Well-Known Member

    4,802
    1,153
    113
    May 25, 2014
    Ratings:
    +1,728
    Local Time:
    9:23 PM
    Mainline
    10.2
    Yes, it's solved now.
    Agree it still considered as bug though.

    Thanks!
     
  8. eva2000

    eva2000 Administrator Staff Member

    42,833
    9,705
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,970
    Local Time:
    11:23 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x