Welcome to Centmin Mod Community
Become a Member

[Solved] No File or Directory

Discussion in 'Bug Reports' started by Jimmy, Mar 22, 2019.

  1. Jimmy

    Jimmy Well-Known Member

    1,638
    351
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +876
    Local Time:
    9:17 AM
    1.17.x
    MariaDB 10.3.x
    This isn't an error, but rather a server without any domains on it.

    Every time I enter the CMM menu, I get this warning:

    Code:
    find: ‘/home/nginx/domains/*/public’: No such file or directory
    Screenshot from 2019-03-21 13-45-16.png

    Not a big deal, but maybe you want to put something else there instead of showing the find error, IDK. Maybe something like, "There are currently no sites / domains on this server." or just omit it completely.

    Just wanted to let you know.
     
  2. eva2000

    eva2000 Administrator Staff Member

    42,077
    9,497
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,613
    Local Time:
    12:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    that seems like you enabled AUTOTUNE_CLIENTMAXBODY='y' in persistent config file /etc/centminmod/custom_config.inc ? as it's disabled by default
     
  3. Jimmy

    Jimmy Well-Known Member

    1,638
    351
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +876
    Local Time:
    9:17 AM
    1.17.x
    MariaDB 10.3.x
    Yea, I have that enabled. I only have 1 server without anything which this appears, wanted to let you know about it incase it was something you wanted to change.
     
  4. eva2000

    eva2000 Administrator Staff Member

    42,077
    9,497
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,613
    Local Time:
    12:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    yeah needs an update to take into account empty /home/nginx/domains when AUTOTUNE_CLIENTMAXBODY='y' is enabled

    what's output for this command
    Code (Text):
    if [[ -z "$(find /home/nginx/domains/ -maxdepth 1 -type d \( ! -wholename /home/nginx/domains/ \))" ]]; then CHECKMAXFILESIZE_VHOSTS=0; echo $CHECKMAXFILESIZE_VHOSTS; else echo "/home/nginx/domains/ not empty"; fi
    
     
  5. Jimmy

    Jimmy Well-Known Member

    1,638
    351
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +876
    Local Time:
    9:17 AM
    1.17.x
    MariaDB 10.3.x
    Output: 0
     
  6. eva2000

    eva2000 Administrator Staff Member

    42,077
    9,497
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,613
    Local Time:
    12:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    ok updated 123.09beta01 with fix, just run cmupdate and re-run centmin.sh and it should be fixed now :)
     
    • Like Like x 2
  7. Jimmy

    Jimmy Well-Known Member

    1,638
    351
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +876
    Local Time:
    9:17 AM
    1.17.x
    MariaDB 10.3.x
    Works perfect! Thanks!
     
    • Like Like x 1