Learn about Centmin Mod LEMP Stack today
Register Now

Nginx Nginx upgrade problem

Discussion in 'Install & Upgrades or Pre-Install Questions' started by dce, Jun 9, 2020.

  1. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Last edited: Jun 14, 2020
  2. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Thanks a bunch eva2000. I will try tonight. I will report back the results. We will see if f I also get the new error that brijendrasial has recently reported on.
     
  3. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Thanks eva2000. I use pagespeed. I am assuming I comment out the entries you indicate, compile and then individually re-enable and re-compile for each one in a process of elimation?

    I will try the newer libatomic_ops tweak you supplied first and get back to you tonight.

    Regards,
     
  4. eva2000

    eva2000 Administrator Staff Member

    45,175
    10,275
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,924
    Local Time:
    3:00 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    noticed your configure parameters as
    you're not using cloudflare zlib maybe because your server doesn't support sse4.2 cpu instructions and/or web server motherboard bios having AES-NI disabled ? I added a check for this Beta Branch - additional nginx & php-fpm Cloudflare zlib library prechecks which would force cloudflare zlib to switch to system zlib which you have in your configure paramters

    what is output for
    Code (Text):
    lscpu

    try reverting --with-libatomic=/usr/lib64 back to just --with-libatomic and also try nginx 1.19.0

    just tried on a fresh KVM VPS install with persistent config file as
    Code (Text):
    NGXDYNAMIC_BROTLI='y'
    NGINX_LIBBROTLI='y'
    NGXDYNAMIC_NGXPAGESPEED='y'
    NGINX_PAGESPEED='y'
    

    and it worked
    also tested fine with Nginx 1.18.0
    using VPS with Intel Xeon E5-2643v1 Sandy Bridge processor with AES-NI and SSE4.2 support
    Code (Text):
    lscpu
    Architecture:          x86_64
    CPU op-mode(s):        32-bit, 64-bit
    Byte Order:            Little Endian
    CPU(s):                1
    On-line CPU(s) list:   0
    Thread(s) per core:    1
    Core(s) per socket:    1
    Socket(s):             1
    NUMA node(s):          1
    Vendor ID:             GenuineIntel
    CPU family:            6
    Model:                 45
    Model name:            Intel(R) Xeon(R) CPU E5-2643 0 @ 3.30GHz
    Stepping:              7
    CPU MHz:               3299.998
    BogoMIPS:              6599.99
    Hypervisor vendor:     KVM
    Virtualization type:   full
    L1d cache:             32K
    L1i cache:             32K
    L2 cache:              4096K
    NUMA node0 CPU(s):     0
    Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon rep_good nopl xtopology eagerfpu pni pclmulqdq ssse3 cx16 pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm tsc_adjust xsaveopt arat
    
     
    Last edited: Jun 14, 2020
  5. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Hey, eva2000, I am about to do some testing on the server in a few hours. Do you want me to try your latest suggestions first?

    Basically do not install your custom centmin-libatomic_ops-7.6.10-1.el7.x86_64.rpm - leave the current one as is - and just try an upgrade with your suggest entries in the persistent config file?
     
  6. eva2000

    eva2000 Administrator Staff Member

    45,175
    10,275
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,924
    Local Time:
    3:00 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    custom libatomic_ops rpm is enabled by default with latest 123.09beta01 update at Beta Branch - install newer libatomic_ops library for CentOS 7 64bit in 123.09beta01

    so just run cmupdate command and run centmin.sh menu option 4 with your existing persistent config file settings in place first
     
  7. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Hello eva2000
    I updated centminmod and then attempted to upgrade nginx. libatomic library was updated by the centminmod upgrade. Same error.

    Code:
    yum -q info centmin-libatomic_ops-7.6.10
    Installed Packages
    Name        : centmin-libatomic_ops
    Arch        : x86_64
    Version     : 7.6.10
    Release     : 1.el7
    Size        : 709 k
    Repo        : installed
    From repo   : /centmin-libatomic_ops-7.6.10-1.el7.x86_64
    Summary     : libatomic_ops-7.6.10 for centminmod.com LEMP stack libatomic_ops-7.6.10
    URL         : https://centminmod.com
    License     : unknown
    Description : libatomic_ops-7.6.10 for centminmod.com LEMP stacks
    I then directly added the path in inc/nginx_configure.inc (LIBATOMICOPT=" --with-libatomic=/usr/lib64") as brijendrasial mentioned.

    The upgrade went further but again failed. The error was the same that brijendrasial reported: make[1]: *** [/usr/lib64/Makefile] Error 127

    Here is the error log

    centminmod_123.09beta01.b532_140620-223149_nginx_upgrade.log
     
  8. eva2000

    eva2000 Administrator Staff Member

    45,175
    10,275
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,924
    Local Time:
    3:00 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    don't set --with-libatomic=/usr/lib64 and do centmin.sh menu option 4 run and provide the nginx upgrade log for that run
     
  9. eva2000

    eva2000 Administrator Staff Member

    45,175
    10,275
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,924
    Local Time:
    3:00 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Ok seems I am able to reproduce the libatomic_ops not found issue. It's some how related to when Lua Nginx modules are enabled via persistent config variables NGXDYNAMIC_LUA='y' and ORESTY_LUANGINX='y' combined with GCC 8.3.1 devtoolset-8. The Nginx atomic_ops library check routine is prematurely aborted due to GCC 8 warnings for -Werror=pointer-sign which can be ignored but due to default GCC 8 behaviour after too many -Werror=pointer-sign warnings it aborts process, so Nginx atomic_ops library check is not able to find the libatomic_ops library location. CentOS 7 native GCC 4.8.5 didn't support -Werror=pointer-sign checks so would of ignored the warnings. The fix is to tell GCC 8.3.1 compiler not to abort on the warnings by passing the flag -Wno-error=pointer-sign. Not sure why this problem only started to show now as in past been fine.

    I've updated Centmin Mod 123.09beta01 with the fix, so you can just run cmupdate and re-run centmin.sh menu option 4
     
  10. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Excellent work eva2000.

    I will unset --with-libatomic=/usr/lib64, update centminmod and then upgrade nginx as instructed.

    Regards,
     
  11. dce

    dce New Member

    24
    6
    3
    Feb 21, 2018
    Ratings:
    +6
    Local Time:
    1:00 AM
    Worked. Nginx update was successful and now I am at version 1.19.0. Again, thank you for taking care of this problem.
     
  12. eva2000

    eva2000 Administrator Staff Member

    45,175
    10,275
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,924
    Local Time:
    3:00 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Glad to hear - another bug ironed out :D