Welcome to Centmin Mod Community
Register Now

Nginx upgrade and wp-ffpc to supercache transition

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Peter Downey, Jun 6, 2014.

  1. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    7:19 AM
    Well, it seems I'm a bit behind on my Nginx version. My server is currently running 1.5.8. This will be my first time upgrading it via the menu. Does anyone have any tips on getting through things safely and easily?

    Currently one of my sites uses the nginx + wp-ffpc + pagespeed configuration, the rest of my sites use the Nginx + supercache + autoptimizer configuration. I'd like to move my first site over to supercache. Has anyone done this and what was the easiest way you found to do so?
     
  2. RoldanLT

    RoldanLT Well-Known Member

    3,830
    929
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,258
    Local Time:
    7:19 PM
    1.11
    10.2
  3. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    7:19 AM
  4. RoldanLT

    RoldanLT Well-Known Member

    3,830
    929
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,258
    Local Time:
    7:19 PM
    1.11
    10.2
    The link I gave is the latest and most stable version.
    .06 has a lot of bugs, so do not use it.
     
  5. eva2000

    eva2000 Administrator Staff Member

    29,033
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,782
    Local Time:
    9:19 PM
    Nginx 1.13.x
    MariaDB 5.5
    @RoldanLT actually I snuck the CentALT fixes in and back ported them to .06 stable builds https://github.com/centminmod/centminmod/commit/315c89589c763b5fc6bad04f2fdd7333d4ca9359. :D

    So @Peter Downey, if you redownload the stable .06 into /usr/local/src and remove old centmin-v1.2.3mod directory and extract the .06 stable redownloaded zip should be fine with these commands

    Code:
    cd /usr/local/src
    wget http://centminmod.com/download/centmin-v1.2.3-eva2000.06.zip
    rm -rf centmin-v1.2.3mod
    sed -i 's/enabled=1/enabled=0/g' /etc/yum.repos.d/centalt.repo
    yum clean all
    unzip centmin-v1.2.3-eva2000.06.zip
    cd centmin-v1.2.3mod
    chmod +x centmin.sh
    ./centmin.sh
    select menu option 4 and specify Nginx 1.7.1
     
    • Like Like x 1
  6. RoldanLT

    RoldanLT Well-Known Member

    3,830
    929
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,258
    Local Time:
    7:19 PM
    1.11
    10.2
    pagespeed updates also ported?
     
  7. eva2000

    eva2000 Administrator Staff Member

    29,033
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,782
    Local Time:
    9:19 PM
    Nginx 1.13.x
    MariaDB 5.5
    not all, but updated to 1.8.31-3 beta which fixed some initial issues from jumping from 1.7.30.4 beta to 1.8.31-2 beta
     
    • Like Like x 1
  8. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    7:19 AM
    So I followed your steps, did option 4 and chose 1.7.1, I'm getting this now. Nginx won't start. :(

    nginx: [emerg] "pagespeed" directive "DefaultSharedMemoryCacheKB" cannot be set at this scope. in /usr/local/nginx/conf/pagespeed.conf:35
    nginx: configuration file /usr/local/nginx/conf/nginx.conf test failed
     
  9. eva2000

    eva2000 Administrator Staff Member

    29,033
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,782
    Local Time:
    9:19 PM
    Nginx 1.13.x
    MariaDB 5.5
    Just remove the DefaultSharedMemoryCacheKB line from /usr/local/nginx/conf/pagespeed.conf and restart Nginx

    btw, do you have ngx_pagespeed enabled in your existing server ? with uncommented pagespeed include lines in your specific domain conf file ?
     
  10. Peter Downey

    Peter Downey Member

    62
    23
    8
    May 28, 2014
    Ratings:
    +25
    Local Time:
    7:19 AM
    Bingo, that brought nginx right back up. Thanks.

    I do have pagespeed enabled, but I'm in the process of commenting it back out as only one of my sites is using it and I'm switching it to supercache +autoptimizer per your guide.