Get the most out of your Centmin Mod LEMP stack
Become a Member

Nginx nginx update error.

Discussion in 'Install & Upgrades or Pre-Install Questions' started by jackton, Jun 13, 2017.

  1. jackton

    jackton Premium Member Premium Member

    13
    0
    1
    Sep 24, 2014
    Ratings:
    +1
    Local Time:
    6:48 AM
    1.6.2
    10.0.13
    The server is located in China and cannot link to google.
    Please add another download address
    thank you!
    Code:
    Download ngx-fancyindex-0.4.0.tar.gz ...                                                                                                                                                                                                         
    --2017-06-13 12:32:29--  https://centminmod.com/centminmodparts/nginx/modules/ngx-fancyindex-0.4.0.tar.gz                                                                                                                                       
    Resolving centminmod.com... 45.32.51.237                                                                                                                                                                                                         
    Connecting to centminmod.com|45.32.51.237|:443... connected.                                                                                                                                                                                     
    ERROR: cannot verify centminmod.com's certificate, issued by ‘CN=COMODO RSA Domain Validation Secure Server CA,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB’:                                                                       
      Unable to locally verify the issuer's authority.                                                                                                                                                                                               
    To connect to centminmod.com insecurely, use `--no-check-certificate'.                                                                                                                                                                           
    Error: ngx-fancyindex-0.4.0.tar.gz download failed.                                                                                                                                                                                             
                                                                                                                                                                                                                                                    
    ----------------------------------------------------------------------------------                                                                                                                                                               
    check Centmin Mod log for details at /root/centminlogs/                                                                                                                                                                                         
    Aborting script...                                                                                                                                                                                                                               
    ----------------------------------------------------------------------------------                                                                                                                                                               
    Check for pagespeed nginx module download file                                                                                                                                                                                                   
    Check for pagespeed PSOL library                                                                                                                                                                                                                 
    Download release-1.12.34.2-beta.tar.gz ...                                                                                                                                                                                                       
    release-1.12.34.2-beta.tar.gz Archive found, skipping download...                                                                                                                                                                               
    release-1.12.34.2-beta.tar.gz valid file.                                                                                                                                                                                                       
                                                                                                                                                                                                                                                    
    Download 1.12.34.2.tar.gz PSOL Library...                                                                                                                                                                                                       
    --2017-06-13 12:32:30--  https://dl.google.com/dl/page-speed/psol/1.12.34.2-x64.tar.gz                                                                                                                                                           
    Resolving dl.google.com... 203.208.51.33, 203.208.51.40, 203.208.51.39, ...                                                                                                                                                                     
    Connecting to dl.google.com|203.208.51.33|:443... connected.                                                                                                                                                                                     
    ERROR: cannot verify dl.google.com's certificate, issued by ‘CN=Google Internet Authority G2,O=Google Inc,C=US’:                                                                                                                                 
      Unable to locally verify the issuer's authority.                                                                                                                                                                                               
    To connect to dl.google.com insecurely, use `--no-check-certificate'.                                                                                                                                                                           
    Error: https://dl.google.com/dl/page-speed/psol/1.12.34.2-x64.tar.gz download failed.                                                                                                                                                           
                                                                                                                                                                                                                                                    
    ----------------------------------------------------------------------------------                                                                                                                                                               
    check Centmin Mod log for details at /root/centminlogs/                                                                                                                                                                                         
    Aborting script...                                                                                                                                                                                                                               
    ----------------------------------------------------------------------------------                                                                                                                                                               
    tar (child): 1.12.34.2-x64.tar.gz: Cannot open: No such file or directory                                                                                                                                                                       
    tar (child): Error is not recoverable: exiting now                                                                                                                                                                                               
    tar: Child returned status 2                                                                                                                                                                                                                     
    tar: Error is not recoverable: exiting now                                                                                                                                                                                                       
    Error: 1.12.34.2.tar.gz extraction failed.                                                                                                                                                                                                       
                                                                                                                                                                                                                                                    
    ----------------------------------------------------------------------------------                                                                                                                                                               
    check Centmin Mod log for details at /root/centminlogs/                                                                                                                                                                                         
    Aborting script...                                                                                                                                                                                                                               
    ----------------------------------------------------------------------------------                                                                                                                                                               
    Total Nginx Upgrade Time: 26.262626244 seconds                                              

     
  2. eva2000

    eva2000 Administrator Staff Member

    30,932
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    6:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    Please fill in any relevant information that applies to you:
    • CentOS Version: i.e. CentOS 6 32bit or 64bit / CentOS 7 64bit ?
    • Centmin Mod Version Installed: i.e. 123.08stable or 123.09beta01
    • Nginx Version Installed: i.e. 1.11.10
    • PHP Version Installed: i.e. 5.6.30 or 7.0.15
    • MariaDB MySQL Version Installed: i.e. 10.0.21 or 10.1.21
    • When was last time updated Centmin Mod code base ? : i.e. run centmin.sh menu option 23 submenu option 2
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:

      cat /etc/centminmod/custom_config.inc


      Post output in CODE tags.
    what does command output for
    Code (Text):
    yum list updates
    


    problem isn't with just google, centminmod.com download too
    Code (Text):
    Download ngx-fancyindex-0.4.0.tar.gz ...                                                                                                                                                                                                        
    --2017-06-13 12:32:29--  https://centminmod.com/centminmodparts/nginx/modules/ngx-fancyindex-0.4.0.tar.gz                                                                                                                                      
    Resolving centminmod.com... 45.32.51.237                                                                                                                                                                                                        
    Connecting to centminmod.com|45.32.51.237|:443... connected.                                                                                                                                                                                    
    ERROR: cannot verify centminmod.com's certificate, issued by ‘CN=COMODO RSA Domain Validation Secure Server CA,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB’:                                                                      
      Unable to locally verify the issuer's authority.                                                                                                                                                                                              
    To connect to centminmod.com insecurely, use `--no-check-certificate'.                                                                                                                                                                          
    Error: ngx-fancyindex-0.4.0.tar.gz download failed.
    

    could be your local ca-certs being out of date etc
     
    Last edited: Jun 13, 2017
  3. eva2000

    eva2000 Administrator Staff Member

    30,932
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    6:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    and output for
    Code (Text):
    curl -Iv https://dl.google.com/dl/page-speed/psol/1.12.34.2-x64.tar.gz