Want more timely Centmin Mod News Updates?
Become a Member

Bug nginx id 956 after install

Discussion in 'AlmaLinux 8 & Rocky Linux 8 Beta Testing' started by Benjamin74, Jun 28, 2024.

  1. Benjamin74

    Benjamin74 Member

    75
    7
    8
    May 2, 2016
    Ratings:
    +18
    Local Time:
    1:19 AM
    [SOLVED, see eva's answer below]

    ALMALINUX 8
    fresh installation

    1. Your web host and VPS/dedicated server plan?
    VPS Hetzner CPX31 4CPU 8GB RAM

    2. Centmin Mod installed version info via command below:

    130.00beta01.b671

    3. Provide CPU, memory and disk info via these 3 commands below:

    4 CPU


    Code:
                  total        used        free      shared  buff/cache   available
    Mem:           7507        1398        5482          11         625        5853
    Low:           7507        2024        5482
    High:             0           0           0
    Swap:          4095           0        4095
    Total:        11603        1398        9578
    Code:
    Filesystem     Type      Size  Used Avail Use% Mounted on
    devtmpfs       devtmpfs  3.7G     0  3.7G   0% /dev
    tmpfs          tmpfs     3.7G     0  3.7G   0% /dev/shm
    tmpfs          tmpfs     3.7G  8.7M  3.7G   1% /run
    tmpfs          tmpfs     3.7G     0  3.7G   0% /sys/fs/cgroup
    /dev/sda1      ext4      151G   12G  132G   9% /
    /dev/sda14     vfat       64M  5.9M   59M  10% /boot/efi
    /dev/loop0     ext4      3.9G   84K  3.7G   1% /tmp
    tmpfs          tmpfs     751M     0  751M   0% /run/user/0

    So, after installing, I usually create a pure ftpd user that has rights on the whole /nginx/domains/ folders

    e.g. running:
    Code:
    pure-pw useradd myftpusername -u nginx -g nginx -d /home/nginx/domains/
    pure-pw mkdb && service pure-ftpd restart
    However, this time, after numerous attempt at connecting with my FTP client, I always received 530 Login authentication failed

    Looking at the pure ftps log gave:

    [WARNING] Can't login as [myftpusername]: account disabled (uid < 1000)

    So I checked:

    Code:
    id nginx
    And surprisingly it's returning:

    uid=956(nginx) gid=956(nginx) groups=956(nginx)

    On my past CMM installs, it's 1000 so it seems like their is a permission issue after installation.

    Anyone has seen this before?

    Thanks a lot,
     
    Last edited: Jun 28, 2024
  2. eva2000

    eva2000 Administrator Staff Member

    52,657
    12,071
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,597
    Local Time:
    9:19 AM
    Nginx 1.25.x
    MariaDB 10.x
    This is a change I made a few days ago https://community.centminmod.com/th...ginx-memcached-uid-gid-in-130-00beta01.25528/. Will need to think about how I'll hand such scenarios.

    For now if you do not have any commercial software running on the server that charges per user license fees for uid >1000, you can use 130.00beta01's /usr/local/src/centminmod/tools/switch_user_ids.sh script and edit it's set uid/gid for nginx and memcached from default
    Code (Text):
    NGINX_UID=956
    NGINX_GID=956
    MEMCACHED_UID=957
    MEMCACHED_GID=957
    

    to say previous defaults
    Code (Text):
    NGINX_UID=1000
    NGINX_GID=1000
    MEMCACHED_UID=1001
    MEMCACHED_GID=1001
    

    then run the script to change uid/gid back
    Code (Text):
    /usr/local/src/centminmod/tools/switch_user_ids.sh
     
  3. Benjamin74

    Benjamin74 Member

    75
    7
    8
    May 2, 2016
    Ratings:
    +18
    Local Time:
    1:19 AM
    Thanks, this solved the issue!