Welcome to Centmin Mod Community
Register Now

Nginx Nginx failed to upgrade due to missing download of libressl-3.5.3.tar.gz

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by pamamolf, Jan 23, 2024.

  1. pamamolf

    pamamolf Premium Member Premium Member

    4,067
    427
    83
    May 31, 2014
    Ratings:
    +832
    Local Time:
    6:46 AM
    Nginx-1.25.x
    MariaDB 10.3.x
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 130.00beta01
    • When was last time updated Centmin Mod code base ? : today

    Hi,

    Nginx failed to update to latest version due to missing download:

    Check for missing nginx modules
    US server detected
    HTTP/2 200
    Download libressl-3.5.3.tar.gz ...
    Initializing download: https://cloudflare.cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.5.3.tar.gz
    SSL error: tlsv1 alert protocol version


    Error: libressl-3.5.3.tar.gz download failed.


    Thanks !
     
  2. eva2000

    eva2000 Administrator Staff Member

    52,721
    12,073
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,599
    Local Time:
    1:46 PM
    Nginx 1.25.x
    MariaDB 10.x
    Any reason you switching to LibreSSL for Nginx TLS library? OpenSSL performance is better than LibreSSL.

    Looks like LibreSSL download via axel client doesn't support Cloudflare based LibreSSL mirror CDN configured minimum TLS protocol version. Probably about time I disabled axel client and use wget instead

    edit: just updated 130.00beta01 with LibreSSL routine fixes including disabling axel client for LibreSSL downloads. So running cmupdate on local Centmin Mod 130.00beta01 to update your local Centmin Mod code and you can try again centmin.sh menu option 4.

     
    Last edited: Jan 24, 2024
  3. pamamolf

    pamamolf Premium Member Premium Member

    4,067
    427
    83
    May 31, 2014
    Ratings:
    +832
    Local Time:
    6:46 AM
    Nginx-1.25.x
    MariaDB 10.3.x
    I didn't enable Libressl.

    The previous build also was using OpenSSL.

    built with OpenSSL 1.1.1w

    I updated Centminmod after your fix and i upgrade to Nginx to 1.25.3 and it is build using Openssl as expected.

    No idea why Libressl download was needed but now it's ok :)
     
  4. eva2000

    eva2000 Administrator Staff Member

    52,721
    12,073
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,599
    Local Time:
    1:46 PM
    Nginx 1.25.x
    MariaDB 10.x
    I see. LibreSSL download is done regardless of default Nginx TLS library. But seems download failed. The update fixes the download :)