Welcome to Centmin Mod Community
Become a Member

Nginx nginx.conf thingy

Discussion in 'Bug Reports' started by BobbyWibowo, Aug 11, 2019.

  1. BobbyWibowo

    BobbyWibowo Active Member

    178
    39
    28
    Jul 30, 2015
    Indonesia
    Ratings:
    +62
    Local Time:
    11:05 PM
    1.17.x
    10.1.x
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.17.2
    • When was last time updated Centmin Mod code base?: At the very least yesterday, as I've got the daily cronjob thingy.
    • Persistent Config:
      Code (Text):
      PUREFTPD_DISABLED=y
      NGXDYNAMIC_BROTLI=y
      NGINX_LIBBROTLI=y
      #LETSENCRYPT_DETECT=y
      ZOPCACHEDFT=y
      
    Is it normal that my nginx.conf looks like this in the section that sets the centminmod headers thingy?
    Code (Text):
    # sets Centmin Mod headers via headers more nginx module
    # https://github.com/openresty/headers-more-nginx-module
    # don't remove the first 2 lines as centmin mod checks to see if they're
    # missing and re-adds them anyway. Just uncomment the 3rd & 4th lines
    # which is used to override the Server header to what you want = nginx
    # and remove the X-Powered-By header + restart nginx service
    # do not disable headers more nginx module itself as it's required for
    # other centmin mod features like redis nginx level caching & letsencrypt
    # integration in vhosts created by addons/acmetool.sh
    more_set_headers "Server: nginx centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "Server: nginx";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_set_headers "X-Powered-By: centminmod";
    more_clear_headers "X-Powered-By";
    

     
  2. eva2000

    eva2000 Administrator Staff Member

    41,088
    9,194
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,104
    Local Time:
    2:05 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    see the message highlighted in bold
    so revert nginx.conf to defaults for lines 33-45 outlined at https://github.com/centminmod/centminmod/blob/master/config/nginx/nginx.conf#L33-L45