Join the community today
Become a Member

Master Branch ModSecurity's OWASP Core Rule Set 3.2.0 in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Mar 12, 2020.

  1. eva2000

    eva2000 Administrator Staff Member

    45,728
    10,382
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,112
    Local Time:
    9:25 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    ModSecurity's OWASP Core Rule Set 3.2.0 in 123.09beta01

    - update optional Nginx modsecurity OWASP core rule set from 3.1.1 to 3.2.0 https://github.com/SpiderLabs/owasp-modsecurity-crs/releases when NGINX_MODSECURITY='y' is set in persistent config file /etc/centminmod/custom_config.inc prior to centmin.sh menu option 4 nginx recompiles. By default, NGINX_MODSECURITY='n' is the default so not enabled by default
    - add support for devtoolset-9 GCC 9 when detected as available

    Continue reading...

    Centmin Mod Github Master branch

    Master branch is where most recent commits are made as at May 24, 2015.
     
  2. hazehs

    hazehs New Member

    25
    1
    3
    Jul 18, 2020
    Ratings:
    +5
    Local Time:
    11:25 AM
    NGINX 1.18
    MariaDB 10.4
    3.3 ModSecurity is released. Just wanted to test, but ill maybe wait for the update before compiling.
    Just wanted to say it to you :)
     
  3. eva2000

    eva2000 Administrator Staff Member

    45,728
    10,382
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,112
    Local Time:
    9:25 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x