Join the community today
Register Now

Nginx mod_security is included for nginx?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Josephm, Dec 24, 2014.

Tags:
  1. Josephm

    Josephm Active Member

    126
    43
    28
    Aug 26, 2014
    Ratings:
    +45
    Local Time:
    12:41 PM
    1.9.5
    10.0.21
    Hi eva2000,
    Just like to explore if your nginx config included mod_security same apache?
    I checked the log and it seems it does not have:
    Code:
    configure arguments: --sbin-path=/usr/local/sbin/nginx --conf-path=/usr/local/nginx/conf/nginx.conf --with-http_ssl_module --with-http_gzip_static_module --with-http_stub_status_module --with-http_sub_module --with-http_addition_module --with-http_image_filter_module --with-http_secure_link_module --with-http_flv_module --with-http_realip_module --with-openssl-opt=enable-tlsext --add-module=../ngx-fancyindex-ngx-fancyindex --add-module=../ngx_cache_purge-2.1 --add-module=../headers-more-nginx-module-0.25 --add-module=../nginx-accesskey-2.0.3 --add-module=../nginx-http-concat-master --with-http_dav_module --add-module=../nginx-dav-ext-module-0.0.3 --add-module=../openresty-memc-nginx-module-1518da4 --add-module=../openresty-srcache-nginx-module-ffa9ab7 --add-module=../nginx-sticky-module-1.2.5 --add-module=../nginx_upstream_check_module-0.1.9 --with-openssl=../openssl-1.0.1j --with-libatomic --with-pcre=../pcre-8.36 --with-pcre-jit --with-http_spdy_module --add-module=../ngx_pagespeed-release-1.9.32.1-beta
    
    Can I add this mod_security myself? Have you ever done this?

    Thanks.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,839
    6,903
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,393
    Local Time:
    3:41 PM
    Nginx 1.13.x
    MariaDB 5.5
    I don't have any live practical experience with Nginx + mod_security module, so it makes it harder to implement in Nginx right now.

    If other members or readers here have working Nginx + mod_security setup and would like to chime in on the setup and configuration they do manually, then I can see about automating it.
     
  3. Jimmy

    Jimmy Premium Member Premium Member

    1,165
    256
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +626
    Local Time:
    12:41 AM
    1.13.x
    MariaDB 10.1.x
    Is mod_security installed with CENTMIN?
     
  4. RoldanLT

    RoldanLT Well-Known Member

    3,975
    965
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,329
    Local Time:
    1:41 PM
    1.11
    10.2
    No as far as I know.
     
  5. Jimmy

    Jimmy Premium Member Premium Member

    1,165
    256
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +626
    Local Time:
    12:41 AM
    1.13.x
    MariaDB 10.1.x
    I'm having an issue moving blocks in IPB and everyone on the IPB forum is blaming mod_security. I'm thinking in my head, I don't think that is on my CENTMIN system. Hmm... going to have to look at this one, can't use the Block Manager in IPB4. Everything else is working like a champ and fast... I mean fast. ;)