Discover Centmin Mod today
Register Now

Metro Responsive Style

Discussion in 'Forum Feedback & Suggestions' started by eva2000, May 25, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    I love the Metro look :D

    So selected MoonWalker92's Metro style for the default theme http://xenforo.com/community/resources/metro.3153/.

    In your browser and/or mobile and tablet devices, how does this Metro style fair ?

    Any Bugs ?
     
  2. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    There is a bug (or doesn't look very good) with the quick navigation on the home page.

    upload_2014-5-25_12-12-21.png

    Top post new thread button is inconsistent with the bottom one:
    upload_2014-5-25_12-13-0.png

    Also, the quick navigation icon looks too much like a "back to top" link.
     
  3. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    Hey Matt, thanks looks like I will be fine tuning pagespeed.conf configuration to exclude certain page requests that are Xenforo specific. Updated my forum's pagespeed.conf Disallow list at http://community.centminmod.com/threads/nginx-pagespeed-ngx_pagespeed-module.30/#post-38 which fixes the broken styling for the quick navigation popup :)

    As to the quick nav icon, that's Metro's doing heh. Need to find a better icon I guess.

    The Post New Thread is my own doing as I moved the button further down inline with the title.
     
  4. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    Because you've moved it, it's cutting the bottom border shadow off as well.

    Rather than move it down, I'd just reduce the padding at the top and bottom, as it's currently 15px
     
  5. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    Fixed it by moving it outside of h1 tag :)

    cheers
     
    • Like Like x 1
  6. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    6:31 PM
    1.11
    10.2
    Seriously, I don't like this style :(
    There are a lot more decent styles than this on XenForo Resource Manager.
     
    • Like Like x 1
  7. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    I love Metro .. especially that it's light on http requests out of the box already.

    What don't you guys like about this Metro style ? any specific elements ? or just that it's Metro looking ?
     
  8. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    I do like Metro (I purchased one of the first versions of a metro theme for XenForo....which has since been discontinued as the coder walked away from the seller and they could never fix all the bugs with it).

    [​IMG]
     
  9. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    Getting a bug with the alerts menu:

    upload_2014-5-26_4-4-27.png

    Should look like this
    upload_2014-5-26_4-5-13.png
     
  10. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    changed the pagespeed disallow to

    Code:
    pagespeed Disallow */alerts-popup?&_xfRequestUri=*;
    pagespeed Disallow */popup?&_xfRequestUri=*;
    pagespeed Disallow */?card=1&&_xfRequestUri=*;
    
    see if that works it might have an accompanying css related url but can't find it in developer mode so far
     
    Last edited: May 26, 2014
  11. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    Membercard overlay

    upload_2014-5-26_5-30-12.png

    I've changed my avatar, and it's not refreshed in there. Also, the close button is missing.
     
  12. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 1
  13. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    Ah figured out the problem had the wrong url disallowed for conversation popups, should be

    Code:
    pagespeed Disallow */conversations/popup?&_xfRequestUri=*;
     
  14. Null

    Null New Member

    4
    1
    3
    May 26, 2014
    Leicestershire, UK
    Ratings:
    +1
    Local Time:
    11:31 AM
    1.7.1
    10.0.10
    Damn, there's way too much padding for my liking :eek:!
     
  15. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    seriously ? don't think there's enough myself :D

    let me guess, you're browsing on mobile or tablet device ?

    I'm on 2x Dell U2410 1920x1200 - probably make a difference :)
     
  16. Matt

    Matt Moderator Staff Member

    691
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +444
    Local Time:
    11:31 AM
    1.7.1
    MariaDB 10
    First time browsing on my phone at the minute, and it's not looking "too" bad. Nice and fast though
     
    • Like Like x 1
  17. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    Yeah I tried at 800x480 and 1280x800 on Android 4.3" and 7.7" mobile and tablets. Seems 1280x800 looks the best.
     
  18. Null

    Null New Member

    4
    1
    3
    May 26, 2014
    Leicestershire, UK
    Ratings:
    +1
    Local Time:
    11:31 AM
    1.7.1
    10.0.10
    I'm a very heavy mobile user :p!
     
  19. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    lucky for responsive style then :)

    found another correction the pagespeed disallow for alerts needs /accounts/ tagged to the front :eek:

    Code:
    pagespeed Disallow */account/alerts-popup?&_xfRequestUri=*;
     
  20. eva2000

    eva2000 Administrator Staff Member

    30,160
    6,784
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,135
    Local Time:
    8:31 PM
    Nginx 1.13.x
    MariaDB 5.5
    hmm seems the alerts still sometimes have CSS breakage that resolves itself

    let's see if totally disabling pagespeed for those specific urls would fix it

    Code:
    pagespeed Disallow */conversations/*;
    pagespeed Disallow */account/alerts/*;