Want to subscribe to topics you're interested in?
Become a Member

Matmomo error

Discussion in 'Other Web Apps usage' started by Max, Apr 6, 2020.

  1. Max

    Max Member

    115
    5
    18
    Feb 17, 2018
    Ratings:
    +9
    Local Time:
    10:29 AM
    Hello

    i have installed a fresh matomo. But the admin dashbord not load.
    https://i.icoore.com/plugins/CoreHome/angularjs/notification/notification.directive.html can't load "403 Forbidden"
    Code:
    Error: "[$compile:tpload] http://errors.angularjs.org/1.6.5/$compile/tpload?p0=plugins%2FCoreHome%2Fangularjs%2Fnotification%2Fnotification.directive.html%3Fcb%3Dc0ea77967349dc521568a643c7697f1d&p1=403&p2=Forbidden"
        K https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:126
        g https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:280
        k https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:255
        $digest https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:266
        $apply https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:269
        l https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:221
        onload https://i.icoore.com/index.php?module=Proxy&action=getCoreJs&cb=c0ea77967349dc521568a643c7697f1d:227
    how can i white list notification.directive.html

    thanks


    centos7.6 php 7.4.4
     
  2. Max

    Max Member

    115
    5
    18
    Feb 17, 2018
    Ratings:
    +9
    Local Time:
    10:29 AM
    Hi
    i set in autoprotect.*.com.conf

    location ~* ^/plugins/ { allow 127.0.0.1; deny all; }
    to
    #location ~* ^/plugins/ { allow 127.0.0.1; deny all; }

    and matomo works
     
  3. brijendrasial

    brijendrasial Active Member

    202
    147
    43
    Mar 21, 2018
    Ratings:
    +229
    Local Time:
    2:59 PM
    1.13.9
    10.0.22-MariaDB
    Something like this will work in nginx vhost config file

    location ^~ /plugins/ {
    allow 127.0.0.1;
    deny all;
    }
     
  4. EckyBrazzz

    EckyBrazzz Active Member

    916
    189
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +362
    Local Time:
    6:29 AM
    Latest
    Latest
    I always disable the autoprotect in the vhost and the panel works
     
  5. eva2000

    eva2000 Administrator Staff Member

    52,749
    12,077
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,604
    Local Time:
    7:29 PM
    Nginx 1.27.x
    MariaDB 10.x/11.4+
    yup

    yeah that would work too