Join the community today
Become a Member

Xenforo Mailgun Error

Discussion in 'Forum software usage' started by jackton, Jan 19, 2017.

  1. jackton

    jackton Premium Member Premium Member

    13
    0
    1
    Sep 24, 2014
    Ratings:
    +1
    Local Time:
    3:40 AM
    1.6.2
    10.0.13
    I tried Amazon SES, Mailgun, Mandrill, SendGrid. There will be an error, unable to send mail. I shut down the firewall. I use the curl and smtp method to test the send mail is successful. Only xenforo cannot send mail.

    Code:
    phpinfo()                                                                                                                                                                                   
    PHP Version => 7.0.14                                                                                                                                                                       
    
    System => Linux iZ28mlek4q6Z 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64                                                                                             
    Build Date => Dec 14 2016 13:22:06                                                                                                                                                           
    Configure Command =>  '../configure'  '--enable-fpm' '--enable-opcache' '--enable-intl' '--enable-pcntl' '--with-mcrypt' '--with-snmp' '--with-mhash' '--with-zlib' '--with-gettext' '--enable-
    exif' '--enable-zip' '--with-bz2' '--enable-soap' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-shmop' '--with-pear' '--enable-mbstring' '--with-openss
    l' '--with-mysql=mysqlnd' '--with-libdir=lib64' '--with-mysqli=mysqlnd' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-curl' '--with-gd' '--with-xmlrpc' '--enable-bcmath' '--enable-cal
    endar' '--enable-ftp' '--enable-gd-native-ttf' '--with-freetype-dir=/usr' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-vpx-dir=/usr' '--with-t1lib=/usr' '--enabl
    e-pdo' '--with-pdo-sqlite' '--with-pdo-mysql=mysqlnd' '--enable-inline-optimization' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-readline' '--with-libedit' '--with-gmp' '--with-
    pspell' '--with-tidy' '--with-enchant' '--with-fpm-user=nginx' '--with-fpm-group=nginx' '--disable-fileinfo' '--with-ldap' '--with-ldap-sasl' '--with-config-file-scan-dir=/etc/centminmod/php.
    d' '--with-xsl'                                                                                                                                                                             
    Server API => Command Line Interface                                                                                                                                                         
    Virtual Directory Support => disabled                                                                                                                                                       
    Configuration File (php.ini) Path => /usr/local/lib                                                                                                                                         
    Loaded Configuration File => /usr/local/lib/php.ini                                                                                                                                         
    Scan this dir for additional .ini files => /etc/centminmod/php.d                                                                                                                             
    Additional .ini files parsed => /etc/centminmod/php.d/a_customphp.ini,                                                                                                                       
    /etc/centminmod/php.d/curlcainfo.ini,                                                                                                                                                       
    /etc/centminmod/php.d/geoip.ini,                                                                                                                                                             
    /etc/centminmod/php.d/igbinary.ini,                                                                                                                                                         
    /etc/centminmod/php.d/imagick.ini,                                                                                                                                                           
    /etc/centminmod/php.d/ioncube.ini,                                                                                                                                                           
    /etc/centminmod/php.d/mailparse.ini,                                                                                                                                                         
    /etc/centminmod/php.d/redis.ini,                                                                                                                                                             
    /etc/centminmod/php.d/zendopcache.ini,                                                                                                                                                       
    /etc/centminmod/php.d/zzzz_phpsessions.ini   



    Code:
    Server Error
    
    Unable to Connect to ssl://api.mailgun.net:443. Error #0:
    
    Zend_Http_Client_Adapter_Socket->connect() in Zend/Http/Client.php at line 973
    Zend_Http_Client->request() in bdMails/Transport/Mailgun.php at line 118
    bdMails_Transport_Mailgun->bdMails_getWebhooks() in bdMails/XenForo/ControllerAdmin/Tools.php at line 9
    bdMails_XenForo_ControllerAdmin_Tools->actionMailgunWebhooksAdd() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/domains.com/public/admin.php at line 13

    Code:
    Zend_Http_Client_Adapter_Exception: Email to xxx@xxx.com failed: Unable to Connect to ssl://api.mailgun.net:443. Error #0: - library/Zend/Http/Client/Adapter/Socket.php:235
    Stack
    #0 /home/xxx/public/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('ssl://api.mailg...', 443, true)
    #1 /home/xxx/public/library/bdMails/Transport/Mailgun.php(96): Zend_Http_Client->request('POST')
    #2 /home/xxx/public/library/bdMails/Transport/Abstract.php(31): bdMails_Transport_Mailgun->_bdMails_sendMail()
    #3 /home/xxx/public/library/Zend/Mail/Transport/Abstract.php(348): bdMails_Transport_Abstract->_sendMail()
    #4 /home/xxx/public/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #5 /home/xxx/public/library/XenForo/Deferred/UserEmail.php(168): Zend_Mail->send(Object(bdMails_Transport_Mailgun))
    #6 /home/xxx/public/library/XenForo/Deferred/UserEmail.php(62): XenForo_Deferred_UserEmail->_sendEmail(Array, Array, Object(bdMails_Transport_Mailgun))
    #7 /home/xxx/public/library/XenForo/ControllerAdmin/User.php(1197): XenForo_Deferred_UserEmail->execute(Array, Array, 10, NULL)
    #8 /home/xxx/public/library/XenForo/FrontController.php(351): XenForo_ControllerAdmin_User->actionEmailSend()
    #9 /home/xxx/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 /home/xxx/public/admin.php(13): XenForo_FrontController->run()
    #11 {main}
    
    array(3) {
      ["url"] => string(41) "https://xxxxx/admin.php?users/email-send"
      ["_GET"] => array(1) {
        ["users/email-send"] => string(0) ""
      }
      ["_POST"] => array(10) {
        ["test"] => string(18) "test mail"
        ["criteria"] => string(117) "{"receive_admin_email":"1","email":"demo@123.com","user_state":["valid"],"is_banned":["0"],"no_empty_email":true}"
        ["total"] => string(1) "1"
        ["from_name"] => string(13) "demos"
        ["from_email"] => string(18) "no-reply@*****"
        ["email_title"] => string(11) "23423423423"
        ["email_format"] => string(4) "text"
        ["email_body"] => string(14) "42342342342343"
        ["_xfConfirm"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
      }
    }
    
     
    Last edited: Jan 19, 2017
  2. eva2000

    eva2000 Administrator Staff Member

    29,044
    6,590
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,785
    Local Time:
    3:40 AM
    Nginx 1.13.x
    MariaDB 5.5
    tried disable bdmail addon and using xenforo native smtp feature for mailgun ?