Discover Centmin Mod today
Register Now

MariaDB Log error about unknown ip

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by pamamolf, Jul 5, 2014.

  1. pamamolf

    pamamolf Well-Known Member

    2,659
    240
    63
    May 31, 2014
    Ratings:
    +422
    Local Time:
    9:13 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    Hi

    On log files i got this:

    Code:
    Version: '10.0.12-MariaDB'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MariaDB Server
    140705  0:37:42 [Warning] IP address '184.172.59.146' has been resolved to the host name '184.172.59.146-static.reverse.softlayer.com', which resembles IPv4-address itself.
    140705  4:56:26 [Warning] IP address '119.146.202.126' could not be resolved: Name or service not known
    140705  9:15:45 [Warning] IP address '124.232.147.150' could not be resolved: Name or service not known
    
    But i do not use any if the ip's above and i don't know why i am getting this error :(

    Thanks
     
  2. eva2000

    eva2000 Administrator Staff Member

    29,702
    6,707
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,009
    Local Time:
    4:13 AM
    Nginx 1.13.x
    MariaDB 5.5
    The error is because mysql is trying to resolve and do a reverse ip look up of but the ips listed do not contain a reverse lookup address

    the 2 ips

    2 belongs to china

    http://ip-lookup.net/?119.146.202.126
    http://ip-lookup.net/?124.232.147.15

    and one to softlayer

    http://ip-lookup.net/?184.172.59.146

    where is your server hosted and have you done anything iptable or csf firewall wise i.e. open ports or whitelist certain IP addresses or hostnames to remotely be able to connect to this server's MySQL server ?

    You shouldn't get any of these errors if CSF Firewall is properly installed and configured for out of box Centmin Mod installs, as CSF Firewall protects you from such attacks

    You could also remove the warnings using skip-name-resolve in /etc/my.cnf but that only hides the fact that these remote ips are trying to connect to your server's MySQL server instance (which they should NOT even be able to with CSF Firewall in place protecting the server).

    in /etc/my.cnf and restart mysql server to hide warnings
    Code:
    [mysqld]
    skip-name-resolve
    
    skip-name-resolve http://dev.mysql.com/doc/refman/5.5/en/server-options.html#option_mysqld_skip-name-resolve when set will only allow connections via ip addresses and not hostnames, so remote mysql user grants would need to be done via username@remoteipaddress and NOT username@remotehostname.

    Hence, why CSF Firewall is installed and enabled by default for Centmin Mod installs http://centminmod.com/csf_firewall.html :D
     
    Last edited: Jul 6, 2014
    • Like Like x 1
  3. pamamolf

    pamamolf Well-Known Member

    2,659
    240
    63
    May 31, 2014
    Ratings:
    +422
    Local Time:
    9:13 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    I just disable the server for a minute lol :)

    Yes now is ok no more warnings :)

    Thanks
     
  4. eva2000

    eva2000 Administrator Staff Member

    29,702
    6,707
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,009
    Local Time:
    4:13 AM
    Nginx 1.13.x
    MariaDB 5.5
    disabled server or disabled CSF and hence the above errors ?
     
    • Like Like x 1
  5. pamamolf

    pamamolf Well-Known Member

    2,659
    240
    63
    May 31, 2014
    Ratings:
    +422
    Local Time:
    9:13 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    disabled CSF and got that errors and now i enable it and all errors gone :)
     
    • Like Like x 1
  6. RoldanLT

    RoldanLT Well-Known Member

    3,869
    945
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,284
    Local Time:
    2:13 AM
    1.11
    10.2
    I just enable skip-name-resolve on my.cnf, Thanks Eva.
     
    • Like Like x 1