Join the community today
Become a Member

Linode Linode Private IP Voodoo

Discussion in 'Virtual Private Server (VPS) hosting' started by BamaStangGuy, Oct 24, 2014.

  1. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    What kind of Voodoo do I have to do to get private IPs working on Linode? Requested one on the Remote Tab and then followed the static IP setup. Even rebooted but its not showing up.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    5:27 PM
    Nginx 1.13.x
    MariaDB 5.5
    for private IP i believe you need static IP networking setup not DHCP Linux Static IP Configuration - Linode Guides & Tutorials
     
  3. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    I followed that but still no go. Not sure what I missed. Have a support ticket open so we will see.
     
  4. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    Got the private IP working but now DNS will not resolve and I can not connect via Facebook, Google or Twitter on my forum. Here is what I sent support. Any ideas?

     
  5. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    Error via XenForo:

    Code:
    Server Error Log
    Error Info
    Zend_Http_Client_Adapter_Exception: Unable to Connect to ssl://accounts.google.com:443. Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known - library/Zend/Http/Client/Adapter/Socket.php:235
    Generated By: Unknown Account, 4 minutes ago
    Stack Trace
    #0 /home/nginx/domains/aspiescentral.com/public/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('accounts.google...', 443, true)
    #1 /home/nginx/domains/aspiescentral.com/public/library/XenForo/ControllerPublic/Register.php(1028): Zend_Http_Client->request('POST')
    #2 /home/nginx/domains/aspiescentral.com/public/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionGoogle()
    #3 /home/nginx/domains/aspiescentral.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home/nginx/domains/aspiescentral.com/public/index.php(13): XenForo_FrontController->run()
    #5 {main}
    Request State
    array(3) {
      ["url"] => string(150) "https://www.aspiescentral.com/register/google?code=4/1vXhoXaoe4VMj6FJQ4uUir-R8AktBuG3Liu_6pzgA8s.Yp3lGUg2ocoQ3oEBd8DOtNAFUICGkgI&csrf=1zsCIiBAS9OpSiHe"
      ["_GET"] => array(3) {
        ["/register/google"] => string(0) ""
        ["code"] => string(77) "4/1vXhoXaoe4VMj6FJQ4uUir-R8AktBuG3Liu_6pzgA8s.Yp3lGUg2ocoQ3oEBd8DOtNAFUICGkgI"
        ["csrf"] => string(16) "1zsCIiBAS9OpSiHe"
      }
      ["_POST"] => array(0) {
      }
    }
     
  6. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    3:27 PM
    1.11
    10.2
    Try nano /etc/resolv.conf
    Then paste:
     
  7. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    Still doesn't work when trying to connect to Google. Do I need to restart anything?
     
  8. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    3:27 PM
    1.11
    10.2
  9. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    3:27 PM
    1.11
    10.2
    /etc/init.d/network restart
    or
    service network restart
     
  10. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    That is for Centos 6.5. I am on 7.

    nmcli con reload is the command to restart, which I did.
     
  11. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    Dig works on the url but xenforo doesn't.

    Code:
    root@localhost network-scripts]# dig accounts.google.com:443
    
    ; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7 <<>> accounts.google.com:443
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 9794
    ;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;accounts.google.com:443.    IN    A
    
    ;; AUTHORITY SECTION:
    .            1799    IN    SOA    a.root-servers.net. nstld.verisign-grs.com. 2014102401 1800 900 604800 86400
    
    ;; Query time: 60 msec
    ;; SERVER: 8.8.4.4#53(8.8.4.4)
    ;; WHEN: Fri Oct 24 18:50:08 UTC 2014
    ;; MSG SIZE  rcvd: 127
    
     
  12. BamaStangGuy

    BamaStangGuy Active Member

    470
    137
    43
    May 25, 2014
    Ratings:
    +180
    Local Time:
    2:27 AM
    All I had to do was restart PHP. Was using old cached data.
     
    • Like Like x 2