Want to subscribe to topics you're interested in?
Become a Member

lib.so.6 missing

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by hitman, Feb 3, 2015.

  1. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    8:18 AM
    [root@s1 //]# yum check
    Loaded plugins: downloadonly, fastestmirror, priorities
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.0)
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.1)
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.3)
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    bzip2-libs-1.0.5-7.el6_0.i686 has missing requires of libc.so.6(GLIBC_2.4)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    e2fsprogs-libs-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.7)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    gamin-0.1.10-9.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.2)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.2.3)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.5)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.7)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.8)
    glib2-2.28.8-4.el6.i686 has missing requires of libc.so.6(GLIBC_2.9)
    glib2-2.28.8-4.el6.i686 has missing requires of libdl.so.2
    glib2-2.28.8-4.el6.i686 has missing requires of libdl.so.2(GLIBC_2.0)
    glib2-2.28.8-4.el6.i686 has missing requires of libdl.so.2(GLIBC_2.1)
    glib2-2.28.8-4.el6.i686 has missing requires of libpthread.so.0
    glib2-2.28.8-4.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.0)
    glib2-2.28.8-4.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.1)
    glib2-2.28.8-4.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.2)
    glib2-2.28.8-4.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.3.2)
    glib2-2.28.8-4.el6.i686 has missing requires of libresolv.so.2
    glib2-2.28.8-4.el6.i686 has missing requires of libresolv.so.2(GLIBC_2.2)
    glib2-2.28.8-4.el6.i686 has missing requires of librt.so.1
    glib2-2.28.8-4.el6.i686 has missing requires of librt.so.1(GLIBC_2.2)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    libacl-2.2.49-6.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.2.3)
    libattr-2.4.44-7.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libcom_err-1.41.12-21.el6.i686 has missing requires of ld-linux.so.2
    libcom_err-1.41.12-21.el6.i686 has missing requires of ld-linux.so.2(GLIBC_2.3)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libpthread.so.0
    libcom_err-1.41.12-21.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.0)
    libcom_err-1.41.12-21.el6.i686 has missing requires of libpthread.so.0(GLIBC_2.1)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6(GLIBC_2.0)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6(GLIBC_2.11)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libc.so.6(GLIBC_2.4)
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libm.so.6
    2:libpng-1.2.49-1.el6_2.i686 has missing requires of libm.so.6(GLIBC_2.0)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of ld-linux.so.2
    libselinux-2.0.94-5.8.el6.i686 has missing requires of ld-linux.so.2(GLIBC_2.3)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.2)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.2.3)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.2.4)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libc.so.6(GLIBC_2.8)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libdl.so.2
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libdl.so.2(GLIBC_2.0)
    libselinux-2.0.94-5.8.el6.i686 has missing requires of libdl.so.2(GLIBC_2.1)
    libstdc++-4.4.7-11.el6.i686 has missing requires of ld-linux.so.2
    libstdc++-4.4.7-11.el6.i686 has missing requires of ld-linux.so.2(GLIBC_2.3)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.2)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libstdc++-4.4.7-11.el6.i686 has missing requires of libm.so.6
    libstdc++-4.4.7-11.el6.i686 has missing requires of libm.so.6(GLIBC_2.0)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.0)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.1)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.2)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.3)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.3.2)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.4)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libc.so.6(GLIBC_2.7)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libdl.so.2
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libdl.so.2(GLIBC_2.0)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libdl.so.2(GLIBC_2.1)
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libm.so.6
    libxml2-2.7.6-17.el6_6.1.i686 has missing requires of libm.so.6(GLIBC_2.0)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.2)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.3)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libdl.so.2
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libdl.so.2(GLIBC_2.0)
    ncurses-libs-5.7-3.20090208.el6.i686 has missing requires of libdl.so.2(GLIBC_2.1)
    xz-libs-4.999.9-0.5.beta.20091007git.el6.i686 has missing requires of libc.so.6
    xz-libs-4.999.9-0.5.beta.20091007git.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    xz-libs-4.999.9-0.5.beta.20091007git.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    xz-libs-4.999.9-0.5.beta.20091007git.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    xz-libs-4.999.9-0.5.beta.20091007git.el6.i686 has missing requires of libpthread.so.0
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6(GLIBC_2.0)
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6(GLIBC_2.1)
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6(GLIBC_2.1.3)
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6(GLIBC_2.3.4)
    zlib-1.2.3-29.el6.i686 has missing requires of libc.so.6(GLIBC_2.4)
    Error: check all

    this is what yum check gives me
    i tried
    Code:
    yum install glib*
    but there is no difference
    any help with that and why is it missing?
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,992
    6,919
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,423
    Local Time:
    4:18 PM
    Nginx 1.13.x
    MariaDB 5.5
    should be

    Code:
    yum -y install glibc glibc-common glibc-devel glibc-headers
     
    • Like Like x 1
  3. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    8:18 AM
    in yum.conf its is
    exclude =*.i386 *.i586 *.686 nginx* php* mysql*

    shouldnt i remove the *.686 in order for the libaries to be installed?
    or is there a specific reason why it should stay excluded?
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,992
    6,919
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,423
    Local Time:
    4:18 PM
    Nginx 1.13.x
    MariaDB 5.5
    what VPS platform are you on if on VPS ? Xen or KVM or OpenVZ, those exclusions would only be set it Centmin Mod detects a 64bit = x86_64 OS usually

    what does output of below give
    Code:
    uname -m
    
    if it's i686, then yes remove the *.686 exclusion from yum.conf
     
  5. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    8:18 AM
    uname -m gives
    x86_64
    and i am on openVZ
    centos 6 64bit

    i removed the i686 and run
    Code:
    yum -y update
    and then
    Code:
    yum check
    and the problem persists
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,992
    6,919
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,423
    Local Time:
    4:18 PM
    Nginx 1.13.x
    MariaDB 5.5
  7. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    8:18 AM
    solved,you are my God :D
     
    • Like Like x 1
  8. eva2000

    eva2000 Administrator Staff Member

    30,992
    6,919
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,423
    Local Time:
    4:18 PM
    Nginx 1.13.x
    MariaDB 5.5
    Thanks for the confirmation.... about the fix.. not about God :)

    I should come up with a fix for that when 64bit systems are detected and auto remove those i686 packages :)
     
    • Like Like x 1
  9. eva2000

    eva2000 Administrator Staff Member

    30,992
    6,919
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,423
    Local Time:
    4:18 PM
    Nginx 1.13.x
    MariaDB 5.5