Discover Centmin Mod today
Register Now

PHP-FPM Issues with installing php/updating and mcrypt.h not found.

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by derpyhooves, Oct 25, 2014.

  1. derpyhooves

    derpyhooves New Member

    22
    3
    3
    Oct 25, 2014
    Ratings:
    +3
    Local Time:
    6:48 AM
    Updated my previous post with an issue.
     
  2. eva2000

    eva2000 Administrator Staff Member

    46,223
    10,507
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,290
    Local Time:
    6:48 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    so you tried installing Xcache previously ?

    menu option 9 in centmin.sh to install APC Cache should take care of both errors - missing apc.php and xcache load error as install routine removes the xcache.ini load file
     
  3. derpyhooves

    derpyhooves New Member

    22
    3
    3
    Oct 25, 2014
    Ratings:
    +3
    Local Time:
    6:48 AM
    I have, can I only use one of those two at a time or something?
     
  4. eva2000

    eva2000 Administrator Staff Member

    46,223
    10,507
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,290
    Local Time:
    6:48 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    APC Cache, Xcache and Zend Opcache are PHP opcode cachers, they all do same job so only one at a time. Memcached server isn't a opcode cacher, but data caching so can be used in conjunction with one of the 3 opcode cachers
     
  5. derpyhooves

    derpyhooves New Member

    22
    3
    3
    Oct 25, 2014
    Ratings:
    +3
    Local Time:
    6:48 AM
    That makes sense, thank you so much for your patience :).