Learn about Centmin Mod LEMP Stack today
Register Now

Nginx Is there any way to running multiple php version?

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by bienthuy, Aug 18, 2017.

  1. bienthuy

    bienthuy New Member

    5
    1
    3
    Oct 6, 2015
    Ratings:
    +3
    Local Time:
    9:55 AM
    1.12
    5.5
    As title, do you know anyway to running multiple php version on the same vps run centminmod or without centminmod (LEMP manual)?
    Thank you so much for your support.

    Please fill in any relevant information that applies to you:
    • CentOS Version:CentOS 7.5 64bit ?
    • Centmin Mod Version Installed: 123.08stable
    • Nginx Version Installed: 1.12.1
    • PHP Version Installed: 7.1.8
    • MariaDB MySQL Version Installed: 10.5
    • When was last time updated Centmin Mod code base ? :
    • Persistent Config:

      Post output in CODE tags.
     
  2. eva2000

    eva2000 Administrator Staff Member

    42,743
    9,667
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,920
    Local Time:
    1:55 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    • Like Like x 3
  3. bienthuy

    bienthuy New Member

    5
    1
    3
    Oct 6, 2015
    Ratings:
    +3
    Local Time:
    9:55 AM
    1.12
    5.5
    Wow, great news. Hope to see that feature soon, because sometime, we need to run main site on latest php version but other only can run on lower php version.
    Thank you so much eva2000
     
    • Agree Agree x 2
  4. EckyBrazzz

    EckyBrazzz Active Member

    838
    171
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +312
    Local Time:
    12:55 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Any progress?? Need some sites with different PHP versions due compatibility with 7.3.x
     
  5. pamamolf

    pamamolf Premium Member Premium Member

    3,656
    353
    83
    May 31, 2014
    Ratings:
    +679
    Local Time:
    5:55 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    We all wait for it :)

    But now with Centos 8 coming out tomorrow or after tomorrow i think is most important to make Centminmod work with it first and then try to add the multiple php versions...
     
  6. eva2000

    eva2000 Administrator Staff Member

    42,743
    9,667
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,920
    Local Time:
    1:55 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    None that can be publicly released as I only release stuff I am willing to provide at least basic support for and not at that stage yet. Especially, with pending CentOS 7.7 and 8 releases coming out that will break stuff i.e. python 3 changes/packages.

    Right now best thing to do is have a separate VPS server for other PHP versions especially if those are PHP versions which are EOL i.e. 5.6/7.0.x so that you do not mix outdated php web app sites with sites which can use newer PHP versions 7.2+

    FYI, Centmin Mod 123.09beta01's PHP 7.2+ with PGO enabled is as fast as normal distro's PHP 7.3 versions anyway PHP - PHP 7.3 vs 7.2 vs 7.1 vs 7.0 (PHP-FPM) Benchmarks. As is Centmin Mod PHP 7.1 with PGO being as fast as other distro offered PHP 7.2 etc.

    Yeah CentOS 8 won't be an easy thing to make Centmin Mod compatible with due to many changes in CentOS 8. So will require more time to properly test until it's at a stage I am confident in providing at least basic support for. Afterall, you can't provide support for something you are not familiar with and CentOS 8 has alot of changes - similar to when CentOS 7 came out :)
     
    • Agree Agree x 1