Get the most out of your Centmin Mod LEMP stack
Become a Member

Is there a reason?

Discussion in 'AlmaLinux 8 & Rocky Linux 8 Beta Testing' started by Tracy Perry, Nov 11, 2022.

  1. Tracy Perry

    Tracy Perry Active Member

    276
    115
    43
    Aug 24, 2014
    Texas
    Ratings:
    +205
    Local Time:
    2:45 AM
    1.21.6
    MariaDB 10.3.36
    That both Redis AND MemCache are enabled/installed on a 8GB VPS instance by default?
    Should that not be an optional install? I have Redis running currently and am not using it (as I do have memcached configured for XF currently) and all it's doing is robbing resources.

     
  2. wmtech

    wmtech Active Member

    165
    44
    28
    Jul 22, 2017
    Ratings:
    +125
    Local Time:
    9:45 AM
    Yes, Redis and memcached are installed automatically. Entries to disable install in custom_config file are ignored. I also don't know why.

    But both can be disabled easily after install with:

    Code:
    systemctl stop redis
    systemctl disable redis
    systemctl stop memcached
    systemctl disable memcached
    
     
  3. eva2000

    eva2000 Administrator Staff Member

    52,749
    12,077
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,604
    Local Time:
    5:45 PM
    Nginx 1.27.x
    MariaDB 10.x/11.4+
    Yes both are installed by default as folks may use them. So leave disabling/stopping service to end users :)
    which /etc/centminmod/custom_config.inc entries did you use?
     
  4. wmtech

    wmtech Active Member

    165
    44
    28
    Jul 22, 2017
    Ratings:
    +125
    Local Time:
    9:45 AM
    Code:
    MEMCACHED_DISABLED='y'
    After checking example/custom_config.inc I assume correctly would be:

    Code:
    REDIS_SERVER_INSTALL='n'
    MEMCACHED_INSTALL='n' 
    Will try those next time.
     
  5. eva2000

    eva2000 Administrator Staff Member

    52,749
    12,077
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,604
    Local Time:
    5:45 PM
    Nginx 1.27.x
    MariaDB 10.x/11.4+
    It should be
    Code (Text):
    MEMCACHED_DISABLED='y'        # when set to =y, Memcached server disabled by default via chkconfig off
    

    or
    Code (Text):
    REDIS_DISABLED='y'            # when set to =y, Redis server disabled by default via chkconfig off
    
     
  6. wmtech

    wmtech Active Member

    165
    44
    28
    Jul 22, 2017
    Ratings:
    +125
    Local Time:
    9:45 AM
    This does not work. Memcached is installed and enabled even with it in custom_config. So this seems to be a bug then.
     
  7. eva2000

    eva2000 Administrator Staff Member

    52,749
    12,077
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,604
    Local Time:
    5:45 PM
    Nginx 1.27.x
    MariaDB 10.x/11.4+