Learn about Centmin Mod LEMP Stack today
Become a Member

IPv6 keeps haunting me

Discussion in 'Bug Reports' started by Nik, Mar 5, 2018.

  1. Nik

    Nik Member

    31
    1
    8
    Dec 7, 2015
    Ratings:
    +4
    Local Time:
    8:55 PM
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • When was last time updated Centmin Mod code base ? : today

    Ok, maybe it's user error on my part but every time I do a centmin codebase update I find that ipv6 keeps getting toggled back on causing all sorts of SSL related issues (long story but it's not easily fixable as it's a routing issue with our peering).

    Is there any option to permanently disable ipv6 from centmin or do I have to keep editing /etc/sysctl.conf as I have been doing so far....

    Appreciate the help.
     
    Last edited: Mar 5, 2018
  2. eva2000

    eva2000 Administrator Staff Member

    35,522
    7,834
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,075
    Local Time:
    10:55 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  3. eva2000

    eva2000 Administrator Staff Member

    35,522
    7,834
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,075
    Local Time:
    10:55 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Just added a fix to 123.09beta01 so update and see if that solves it :)
     
  4. Nik

    Nik Member

    31
    1
    8
    Dec 7, 2015
    Ratings:
    +4
    Local Time:
    8:55 PM
    ifconfig -a shows IPV6 address assigned. Also I immediately start getting google SSL timeouts. :) I've also added

    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1

    to a new file 00-sysctl.conf in etc/sysctl.d. I'm not sure how these are loaded priority wise. I'm assuming lower prefix takes priority but doesn't seem to override anything at the moment.

    Perfect, thanks. I'll update now and check.
     
  5. Nik

    Nik Member

    31
    1
    8
    Dec 7, 2015
    Ratings:
    +4
    Local Time:
    8:55 PM
    Updated, nope, puts it back in again into /etc/sysctl.conf after updating codebase (option 23 then option 2)... :(

    Is there a centmin disable IPV6 option I should be setting somewhere? I see in inc/cpcheck.inc you're looking for a flag..

    @eva2000
     
    Last edited: Mar 6, 2018
  6. eva2000

    eva2000 Administrator Staff Member

    35,522
    7,834
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,075
    Local Time:
    10:55 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    that's where it is meant to be - remove the other references and see

    yes there is for DISABLE_IPVSIX='y' in persistent config file Beta Branch - update fix for checkipvsix function + add DISABLE_IPVSIX variable you can try that too but it still works with /etc/sysctl.conf
     
..