Want more timely Centmin Mod News Updates?
Become a Member

Wordpress Installing WebP Express Wordpress Plugin on Centmin Mod Nginx

Discussion in 'Blogs & CMS usage' started by eva2000, May 11, 2019.

  1. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    WebP Express interesting indeed but seems to use .htaccess apache rewrite rules for conditional browser webp supported rewrites which nginx doesn't support .htaccess. But Centmin Mod Nginx in 123.09beta01 natively can rewrite with instructions at https://centminmod.com/webp/. You'd have to used mingled destination folder mode though for Centmin Mod Nginx's webp to pick up the converted webp version

    upload_2019-5-11_2-8-48.png

    Also make sure you select append .webp in WebP Express plugin and not set .webp for extension

    webp-express-working-centminmod-nginx-03.png

    Don't enable Alter HTML section options as it is not required at all. Best performance is letting Nginx do the webP conditional detection and serving to webP supported web browsers and not let WebP Express PHP code do the work. For Centmin Mod Nginx config outlined in this thread, WebP Express wordpress plugin's only task is to auto convert images to WebP at upload time.

    also centmin.sh menu option 22 installed wordpress wpsecure whitelisting is needed as php files can't be run in WebP Express doing conversion test = 403 no permission as per https://community.centminmod.com/threads/wordpress-403-permission-denied-errors.11215/

    upload_2019-5-11_2-11-40.png

    added whitelist exception in my test domain's (funky.domain.com) wpsecure include file /usr/local/nginx/conf/wpincludes/funky.domain.com/wpsecure_funky.domain.com.confright after the last whitelist exception location context

    replace all references to funky.domain.com with your domain name :)
    Code (Text):
    # Whitelist Exception for webp-express
    location ~ ^/wp-content/plugins/webp-express/ {
      include /usr/local/nginx/conf/php.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      # below include file needs to be manually created at that path and to be uncommented
      # by removing the hash # in front of below line to take effect. This wpwhitelist_common.conf
      # allows you to add commonly shared settings to all wp plugin location matches which
      # whitelist php processing access at /usr/local/nginx/conf/wpincludes/funky.domain.com/wpsecure_funky.domain.com.conf
      #include /usr/local/nginx/conf/wpincludes/funky.domain.com/wpwhitelist_common.conf;
    }
    

    then restart php-fpm service and now test conversions work. This wpsecure whitelisting allows you finer grain control over which wordpress plugins can run php code from /wp-content/plugins/yourpluginname directory.

    upload_2019-5-11_2-18-43.png

    test media image upload to see if it converts to webp file

    upload_2019-5-11_2-33-59.png


    nice
    Code (Text):
    find /home/nginx/domains/funky.domain.com/public/wp-content/uploads -type f -name "*.webp"
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-100x100.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-300x114.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-150x150.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-324x304.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-768x292.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01-416x158.png.webp
    /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/epyc2-cray-8180m-01.png.webp
    

    Code (Text):
    ls -lah /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/
    total 692K
    drwxr-sr-x 2 nginx nginx 4.0K May 10 16:32 .
    drwxr-sr-x 3 nginx nginx 4.0K May  9 06:41 ..
    -rw-r--r-- 1 nginx nginx 4.7K May  9 08:37 avatar-100x100.png
    -rw-r--r-- 1 nginx nginx 2.1K May  9 08:37 avatar.png
    -rw-r--r-- 1 nginx nginx  15K May 10 16:32 epyc2-cray-8180m-01-100x100.png
    -rw-r--r-- 1 nginx nginx 1.7K May 10 16:32 epyc2-cray-8180m-01-100x100.png.webp
    -rw-r--r-- 1 nginx nginx  29K May 10 16:32 epyc2-cray-8180m-01-150x150.png
    -rw-r--r-- 1 nginx nginx 2.9K May 10 16:32 epyc2-cray-8180m-01-150x150.png.webp
    -rw-r--r-- 1 nginx nginx  55K May 10 16:32 epyc2-cray-8180m-01-300x114.png
    -rw-r--r-- 1 nginx nginx 5.8K May 10 16:32 epyc2-cray-8180m-01-300x114.png.webp
    -rw-r--r-- 1 nginx nginx  34K May 10 16:32 epyc2-cray-8180m-01-324x304.png
    -rw-r--r-- 1 nginx nginx 8.6K May 10 16:32 epyc2-cray-8180m-01-324x304.png.webp
    -rw-r--r-- 1 nginx nginx  96K May 10 16:32 epyc2-cray-8180m-01-416x158.png
    -rw-r--r-- 1 nginx nginx 9.1K May 10 16:32 epyc2-cray-8180m-01-416x158.png.webp
    -rw-r--r-- 1 nginx nginx 258K May 10 16:32 epyc2-cray-8180m-01-768x292.png
    -rw-r--r-- 1 nginx nginx  22K May 10 16:32 epyc2-cray-8180m-01-768x292.png.webp
    -rw-r--r-- 1 nginx nginx  82K May 10 16:32 epyc2-cray-8180m-01.png
    -rw-r--r-- 1 nginx nginx  27K May 10 16:32 epyc2-cray-8180m-01.png.webp
    


    all that is left is setup Centmin Mod Nginx's conditional .webp extension rewrite for browsers that support webp as per https://centminmod.com/webp/. Centmin Mod 123.09beta01 already has setup instructed /usr/local/nginx/conf/webp.conf include file in nginx.conf.

    you can do that by editing wpsecure for your wordpress site i.e. for my funky.domain.com wordpress site would be at
    /usr/local/nginx/conf/wpincludes/funky.domain.com/wpsecure_funky.domain.com.conf
    and adding right after nginx-helper log blocking location context the following
    Code (Text):
    # webp extension support if you are converting /uploads images to webp
    location ~ ^/wp-content/uploads/ {
      #pagespeed off;
      #pagespeed unplugged;
      #autoindex on;
      #add_header X-Robots-Tag "noindex, nofollow";
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {
       expires 30d;
       add_header Vary "Accept-Encoding";
       add_header Cache-Control "public, no-transform";
       try_files $uri$webp_extension $uri =404;
      }
    }
    

    so in wpsecure include file right after block nginx-helper log context
    Code (Text):
    # Block nginx-help log from public viewing
    location ~* /wp-content/uploads/nginx-helper/ { deny all; }
    
    # webp extension support if you are converting /uploads images to webp
    location ~ ^/wp-content/uploads/ {
      #pagespeed off;
      #pagespeed unplugged;
      #autoindex on;
      #add_header X-Robots-Tag "noindex, nofollow";
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {
        expires 30d;
        add_header Vary "Accept-Encoding";
        add_header Cache-Control "public, no-transform";
        try_files $uri$webp_extension $uri =404;
      }
    }
    

    then restart nginx + php-fpm
    Code (Text):
    nprestart
    

    inspecting Chrome devtools network tab

    webp-express-working-centminmod-nginx-01.png
    if you see images with content-type = image/webp then Centmin Mod Nginx is serving the webP version of your image converted via WebP Express wordpress plugin when you uploaded the image to wordpress media/gallery.

    webp-express-working-centminmod-nginx-02.png
     
    Last edited: May 11, 2019
  2. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Work perfect, just did some testing and it change the all to webp.
    Just noticed a point. Uploaded 5 slides for testing and they got converted to webp, but see the image.

    WebEpress6.png
     
    • Like Like x 1
  3. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Good to hear - thanks for heads up on WebP Express wordpress plugin, seems like a good candidate for centmin.sh menu option 22 auto installation or at least prompt end user to whether they want it installed :)

    Interesting that WebP Express's FAQ for Nginx setup is very complex compared to what is really needed to conditionally server WebP images to supported browsers only WebP Express

    Also note for use with Cloudflare
    Basically, if using Cloudflare Pro and higher paid plans, you do not need WebP Express wordpress plugin as Cloudflare can do on the fly WebP conversion of your images when it's beneficial to do so.
     
    Last edited: May 11, 2019
    style="display:inline-block;min-width:400px;max-width:970px;width:95%;height:90px" data-ad-client="ca-pub-6669518204467592" data-ad-slot="4024536743" data-ad-format="auto">
  4. Max

    Max Member

    79
    4
    8
    Feb 17, 2018
    Ratings:
    +7
    Local Time:
    5:50 PM
    Hello

    how can is set cache for webp images?. i have the same failed max-age or expires

    Thanks
    Code:
    FAILED - (No max-age or expires) - https://rvlove.co/wp-content/uploads/2019/05/Landweg-indien-hippie-trail-2-1400x533.jpg.webp
    FAILED - (No max-age or expires) - https://rvlove.co/wp-content/uploads/2019/05/Istanbul-Ausgangspunkt-Indien-Roadtrip-1.jpg.webp
    FAILED - (No max-age or expires) - https://rvlove.co/wp-content/uploads/2019/05/indien-gegesaetze-1.jpg.webp
    FAILED - (No max-age or expires) - https://rvlove.co/wp-content/uploads/2019/05/hippie-trail-indien-pin-1.jpeg.webp
     
  5. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    If you setup in your own wpsecure /usr/local/nginx/conf/wpincludes/funky.domain.com/wpsecure_funky.domain.com.conf - change funky.domain.com to your domain name include file the setting
    Code (Text):
    # webp extension support if you are converting /uploads images to webp
    location ~ ^/wp-content/uploads/ {
      #pagespeed off;
      #pagespeed unplugged;
      #autoindex on;
      #add_header X-Robots-Tag "noindex, nofollow";
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {
       expires 30d;
       add_header Vary "Accept-Encoding";
       add_header Cache-Control "public, no-transform";
       try_files $uri$webp_extension $uri =404;
      }
    }
    

    and restarted nginx + php-fpm services, webp images should be cached - it is for me in webpagetest.org tests

    upload_2019-5-13_9-10-55.png

    both expires and cache-control headers present for webp content-type = image/webp mime type

    upload_2019-5-13_9-12-54.png
     
  6. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Guess I'm going back to ngx_pagespeed. Did several test but still get a low score. Even tried to convert them to base64, but that did not resolve it.

    Gone use the setup as above, but with ngx_pagespeed. That gives me after severe testing the best result.
    Only need to finetune ngx_pagespeed a bit, but that won't be a problem.

    So keeping the WebP from the plugin, disable it in ngx_pagespeed, convert them to base64 cause the WebP is small so the base64 is small also.

    @eva2000 in your image on line #3 the image is not converted to WebP, in my configuration all are converted to WebP. But I uploaded the test slides again to be sure so maybe you forgot to upload them again so that they didn't get converted

    As with all things in life, your results my vary, but mine are set.
     
    Last edited: May 13, 2019
  7. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Don't look at the extension of the file, look at content-type mime = image/webp that indicates if webP is working as the nginx rewrite rule redirects .png to .png.web if working properly. You can see same at https://centminmod.com/webp/
    You can verify by size of webp image reported in chrome network tab for 300x114.png.webp = 5.8KB (5842 bytes content length) which is approximate size of it as 5.8KB versus 300x114.png non-webp png fille at 55KB.

    also verify that cache control header is set to 30 day expiry = 2592000 seconds with public, no-transform as per
    Code (Text):
    add_header Cache-Control "public, no-transform";
    


    webp-express-working-centminmod-nginx-02.png
    Code (Text):
    ls -lah /home/nginx/domains/funky.domain.com/public/wp-content/uploads/2019/05/
    total 692K
    drwxr-sr-x 2 nginx nginx 4.0K May 10 16:32 .
    drwxr-sr-x 3 nginx nginx 4.0K May  9 06:41 ..
    -rw-r--r-- 1 nginx nginx 4.7K May  9 08:37 avatar-100x100.png
    -rw-r--r-- 1 nginx nginx 2.1K May  9 08:37 avatar.png
    -rw-r--r-- 1 nginx nginx  15K May 10 16:32 epyc2-cray-8180m-01-100x100.png
    -rw-r--r-- 1 nginx nginx 1.7K May 10 16:32 epyc2-cray-8180m-01-100x100.png.webp
    -rw-r--r-- 1 nginx nginx  29K May 10 16:32 epyc2-cray-8180m-01-150x150.png
    -rw-r--r-- 1 nginx nginx 2.9K May 10 16:32 epyc2-cray-8180m-01-150x150.png.webp
    -rw-r--r-- 1 nginx nginx  55K May 10 16:32 epyc2-cray-8180m-01-300x114.png
    -rw-r--r-- 1 nginx nginx 5.8K May 10 16:32 epyc2-cray-8180m-01-300x114.png.webp
    -rw-r--r-- 1 nginx nginx  34K May 10 16:32 epyc2-cray-8180m-01-324x304.png
    -rw-r--r-- 1 nginx nginx 8.6K May 10 16:32 epyc2-cray-8180m-01-324x304.png.webp
    -rw-r--r-- 1 nginx nginx  96K May 10 16:32 epyc2-cray-8180m-01-416x158.png
    -rw-r--r-- 1 nginx nginx 9.1K May 10 16:32 epyc2-cray-8180m-01-416x158.png.webp
    -rw-r--r-- 1 nginx nginx 258K May 10 16:32 epyc2-cray-8180m-01-768x292.png
    -rw-r--r-- 1 nginx nginx  22K May 10 16:32 epyc2-cray-8180m-01-768x292.png.webp
    -rw-r--r-- 1 nginx nginx  82K May 10 16:32 epyc2-cray-8180m-01.png
    -rw-r--r-- 1 nginx nginx  27K May 10 16:32 epyc2-cray-8180m-01.png.webp
    


    If using other wp plugins which enable webp support, i.e. keycdn cache enabler, disable that option within such plugins as you want nginx to have full control over serving webp via nginx rewrite rule and not via wp plugins.
     
    Last edited: May 13, 2019
  8. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    li
    Yeah, ngx_pagespeed does this... Disabled it again, followed the manual and guess, no result

    But, To verify, here is my config. I really don't get it anymore. Followed exactly the setup on https://centminmod.com/webp/

    WebP1.png

    WebP2.png

    WebP2.png

    WebP3.png

    WebP4.png

    Code (Text):
    ls -lah /home/nginx/domains/$vhost/public/wp-content/uploads/2019/05/
    total 1.2M
    drwxr-sr-x 2 nginx nginx 8.0K May 10 20:41 .
    drwxr-sr-x 4 nginx nginx   26 Apr 30 23:34 ..
    -rw-r--r-- 1 nginx nginx  16K May 10 19:35 1180x355px-Slide1-1024x308.jpg
    -rw-r--r-- 1 nginx nginx 4.6K May 10 19:35 1180x355px-Slide1-1024x308.webp
    -rw-r--r-- 1 nginx nginx 3.2K May 10 19:35 1180x355px-Slide1-146x146.jpg
    -rw-r--r-- 1 nginx nginx 1.3K May 10 19:35 1180x355px-Slide1-146x146.webp
    -rw-r--r-- 1 nginx nginx 3.2K May 10 19:35 1180x355px-Slide1-150x150.jpg
    -rw-r--r-- 1 nginx nginx 1.3K May 10 19:35 1180x355px-Slide1-150x150.webp
    -rw-r--r-- 1 nginx nginx 4.6K May 10 19:35 1180x355px-Slide1-237x175.jpg
    -rw-r--r-- 1 nginx nginx 1.7K May 10 19:35 1180x355px-Slide1-237x175.webp
    -rw-r--r-- 1 nginx nginx 4.2K May 10 19:35 1180x355px-Slide1-300x90.jpg
    -rw-r--r-- 1 nginx nginx 1.7K May 10 19:35 1180x355px-Slide1-300x90.webp
    -rw-r--r-- 1 nginx nginx  14K May 10 19:35 1180x355px-Slide1-676x390.jpg
    -rw-r--r-- 1 nginx nginx 3.8K May 10 19:35 1180x355px-Slide1-676x390.webp
    -rw-r--r-- 1 nginx nginx  12K May 10 19:35 1180x355px-Slide1-768x231.jpg
    -rw-r--r-- 1 nginx nginx 3.6K May 10 19:35 1180x355px-Slide1-768x231.webp
    -rw-r--r-- 1 nginx nginx 1.7K May 10 19:35 1180x355px-Slide1-80x80.jpg
    -rw-r--r-- 1 nginx nginx  782 May 10 19:35 1180x355px-Slide1-80x80.webp
    -rw-r--r-- 1 nginx nginx  20K May 10 19:35 1180x355px-Slide1.jpg
    -rw-r--r-- 1 nginx nginx 5.5K May 10 19:35 1180x355px-Slide1.webp
    -rw-r--r-- 1 nginx nginx  17K May 10 19:36 1180x355px-Slide2-1024x308.jpg
    -rw-r--r-- 1 nginx nginx 5.3K May 10 19:36 1180x355px-Slide2-1024x308.webp
    -rw-r--r-- 1 nginx nginx 3.2K May 10 19:36 1180x355px-Slide2-146x146.jpg
    -rw-r--r-- 1 nginx nginx 1.3K May 10 19:36 1180x355px-Slide2-146x146.webp
    -rw-r--r-- 1 nginx nginx 3.2K May 10 19:36 1180x355px-Slide2-150x150.jpg
    -rw-r--r-- 1 nginx nginx 1.3K May 10 19:36 1180x355px-Slide2-150x150.webp
    -rw-r--r-- 1 nginx nginx 4.6K May 10 19:36 1180x355px-Slide2-237x175.jpg
    -rw-r--r-- 1 nginx nginx 1.7K May 10 19:36 1180x355px-Slide2-237x175.webp
    -rw-r--r-- 1 nginx nginx 4.4K May 10 19:36 1180x355px-Slide2-300x90.jpg
    -rw-r--r-- 1 nginx nginx 1.8K May 10 19:36 1180x355px-Slide2-300x90.webp
    -rw-r--r-- 1 nginx nginx  14K May 10 19:36 1180x355px-Slide2-676x390.jpg
    -rw-r--r-- 1 nginx nginx 3.9K May 10 19:36 1180x355px-Slide2-676x390.webp
    -rw-r--r-- 1 nginx nginx  12K May 10 19:36 1180x355px-Slide2-768x231.jpg
    -rw-r--r-- 1 nginx nginx 4.2K May 10 19:36 1180x355px-Slide2-768x231.webp
    -rw-r--r-- 1 nginx nginx 1.7K May 10 19:36 1180x355px-Slide2-80x80.jpg
    -rw-r--r-- 1 nginx nginx  782 May 10 19:36 1180x355px-Slide2-80x80.webp
    


    What else can I post?

    haha, CMM does me feel like when I was a little child, unwrapping my Xmas presents, at Xmas evening, so happy that I have it and the presents won't stop. :) :) Takes a while, but guess when this is fixed I'm feeling like that little boy again!
     
  9. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Just created a new site (with punny code, so there is no webpagetest.org restult) and it worked almost out of the box. So with old instalations it gives errors. Noticed some difference in the size of the vhost, so going to check out if the error is there.

    And YES there is : https://www.diffchecker.com/5gbLEBub
    But removing this extra entry in the vhost did not make a difference.

    So still no Idea whats wrong.

    WebP5.png
     
    Last edited: May 14, 2019
  10. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    the nginx rules outlined in that page are slightly different to one listed for this wordpress thread - the location context to match images in this thread are for wordpress specifically
    Code (Text):
    # webp extension support if you are converting /uploads images to webp
    location ~ ^/wp-content/uploads/ {
      #pagespeed off;
      #pagespeed unplugged;
      #autoindex on;
      #add_header X-Robots-Tag "noindex, nofollow";
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {
       expires 30d;
       add_header Vary "Accept-Encoding";
       add_header Cache-Control "public, no-transform";
       try_files $uri$webp_extension $uri =404;
      }
    }
    

    so adjust your old install to this version and it should work in theory

    I'll update the web site example with a 2nd example for wordpress to clarify things.

    this part is specific to wordpress while one of web site is a generic example
    Code (Text):
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {

    and this specific one is added by default to new centmin mod 123.09beta01's centmin.sh menu option 22 wordpress installer so that is why you're seeing it work on fresh new site install via centmin.sh menu option 22 :)

    haha, Centmin Mod is the gift that keeps on giving :D
     
  11. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Already compared the new and old file and the look identical.

    Code (Text):
    # webp extension support if you are converting /uploads images to webp
    location ~ ^/wp-content/uploads/ {
      #pagespeed off;
      #pagespeed unplugged;
      #autoindex on;
      #add_header X-Robots-Tag "noindex, nofollow";
      location ~* ^/wp-content/uploads/(.+/)?(.+)\.(png|jpe?g)$ {
        expires 30d;
        add_header Vary "Accept-Encoding";
        add_header Cache-Control "public, no-transform";
        try_files $uri$webp_extension $uri =404;
      }
    }
    
     
  12. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    strange then, i'd do a diff compare of the wpsecure files to see too.
     
  13. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
  14. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    there's your problem you have unwanted wpsecure in whitelist for web-express for old install

    upload_2019-5-14_6-44-11.png

    edit: oh looks like that was a line wrap of commented out entry heh or is it a line wrap or newline break, might double check considering the diff is reported for it
     
  15. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Removed it :) nprestart and cleared cach. incognito window but, (see image)
    WebP7.png
     
  16. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    verified if those images do have the converted .jpg.webp extension versions ?
     
  17. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    looks like they don't use append .webp extension but set .webp extension
    Code (Text):
    ls -lah /home/nginx/domains/$vhost/public/wp-content/uploads/2019/05/
    total 1.2M
    drwxr-sr-x 2 nginx nginx 8.0K May 10 20:41 .
    drwxr-sr-x 4 nginx nginx   26 Apr 30 23:34 ..
    -rw-r--r-- 1 nginx nginx  16K May 10 19:35 1180x355px-Slide1-1024x308.jpg
    -rw-r--r-- 1 nginx nginx 4.6K May 10 19:35 1180x355px-Slide1-1024x308.webp
    

    make sure you select append .webp in WebP Express plugin and not set .webp for extension as you want converted webp images to have naming format of filename.jpg.webp

    webp-express-working-centminmod-nginx-03.png
     
  18. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Code (Text):
    ls -lah /home/nginx/domains/$vhost/public/wp-content/uploads/2019/05/
    total 1.2M
    drwxr-sr-x 2 nginx nginx 8.0K May 10 20:41 .
    drwxr-sr-x 4 nginx nginx   26 Apr 30 23:34 ..
    -rw-r--r-- 1 nginx nginx  16K May 10 19:35 1180x355px-Slide1-1024x308.jpg
    -rw-r--r-- 1 nginx nginx 4.6K May 10 19:35 1180x355px-Slide1-1024x308.webp
    


    Resolved I hope, they don't. How to fix it?

    The new site has it correctly
    Code (Text):
    
     ls -lah /home/nginx/domains/$vhost_new/public/wp-content/uploads/2019/05/
    total 736K
    drwxr-sr-x 2 nginx nginx 8.0K May 13 17:40 .
    drwxr-sr-x 3 nginx nginx   16 May 13 16:46 ..
    -rw-r--r-- 1 nginx nginx  16K May 13 17:31 1180x355px-Slide1-1024x308.jpg
    -rw-r--r-- 1 nginx nginx 4.6K May 13 17:31 1180x355px-Slide1-1024x308.jpg.webp
    
     
  19. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    2:50 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    You can remove the .webp set images and re-run batch conversion in WebP for append .webp configuration to create the proper .jpg.webp or .png.webp converted images. Or if both sites have exact same images, just copy over the /wp-content/uploads directory from working copy to other one :)
     
  20. EckyBrazzz

    EckyBrazzz Active Member

    459
    90
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +170
    Local Time:
    1:50 PM
    1.17.x
    10.3.x
    Posted the config with image at the begin. But finaly resolved. > Just have to do it and double check it. Up to the next issue..;). Currious when we get the next beta.10
     
    • Like Like x 1