Discover Centmin Mod today
Register Now

ImportError: No module named _internal.cli.main

Discussion in 'Bug Reports' started by rdan, Jul 23, 2020.

  1. rdan

    rdan Well-Known Member

    4,990
    1,188
    113
    May 25, 2014
    Ratings:
    +1,810
    Local Time:
    10:56 PM
    Mainline
    10.2
    • CentOS Version: i.e. CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.19.1
    • PHP Version Installed: 7.3.x
    • When was last time updated Centmin Mod code base ? : cmupdate command
    I got this error after running centmin:

     
  2. rdan

    rdan Well-Known Member

    4,990
    1,188
    113
    May 25, 2014
    Ratings:
    +1,810
    Local Time:
    10:56 PM
    Mainline
    10.2
    I tried:
     
  3. eva2000

    eva2000 Administrator Staff Member

    45,436
    10,312
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,992
    Local Time:
    12:56 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    what output do you get for the following commands
    Code (Text):
    pip -V
    pip2 -V
    pip3 -V
    

    and
    Code (Text):
    which pip
    which pip2
    which pip3
    

    and for
    Code (Text):
    pip install --upgrade pip
    pip2 install --upgrade pip
    pip3 install --upgrade pip
    
     
  4. rdan

    rdan Well-Known Member

    4,990
    1,188
    113
    May 25, 2014
    Ratings:
    +1,810
    Local Time:
    10:56 PM
    Mainline
    10.2
    Output, thanks.

     
  5. eva2000

    eva2000 Administrator Staff Member

    45,436
    10,312
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,992
    Local Time:
    12:56 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    and output for
    Code (Text):
    yum versionlock list
    

    Code (Text):
    yum -q list python2-pip --showduplicates --disableplugin=versionlock | tr -s ' ' | column -t
    

    example
    Code (Text):
    yum -q list python2-pip --showduplicates --disableplugin=versionlock | tr -s ' ' | column -t 
    Installed           Packages
    python2-pip.noarch  8.1.2-10.el7  @epel
    
     
  6. eva2000

    eva2000 Administrator Staff Member

    45,436
    10,312
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,992
    Local Time:
    12:56 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    also output for
    Code (Text):
    pip list
    pip2 list
    pip3 list
    

    and
    Code (Text):
    yum -q provides /usr/bin/pip