Join the community today
Register Now

Magento I have a problem

Discussion in 'Ecommerce / Shopping cart usage' started by computer19852007, Jul 20, 2018.

  1. computer19852007

    computer19852007 Member

    80
    8
    8
    Jun 25, 2014
    Ratings:
    +8
    Local Time:
    5:56 AM
    Centmin Mod 1.2.3-eva2000.06
    MariaDB 5.5.34
    I have used Cloudflare, and run tool /usr/local/src/centminmod/tools/csfcf.sh auto
    ---
    I have setup magento 2.2.5, Varnish Cache, Redis Server, and it working. (i have install via your tuts: centminmod/centminmod-magento2 )
    I have setup CDN CloudFront. and it have a problem:
    1) If i have disable (turn off) CloudFlare in my Domain: My Wesite and CloudFront is Working
    2) If i have Enable (turn on) CloudFlare in my Domain: My Wesite and CloudFront is NOT Working, and it show error:

    Code:
    502 ERROR
    The request could not be satisfied.
    CloudFront wasn't able to connect to the origin.
    For more information on how to troubleshoot this error, please refer to the CloudFront documentation (https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/http-502-bad-gateway.html). 
    Please Help me
     
  2. eva2000

    eva2000 Administrator Staff Member

    35,522
    7,833
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,074
    Local Time:
    8:56 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Why use Cloudfront when Cloudflare is already a CDN itself and performs better generally ?

    Have you checked the linked guide at HTTP 502 Status Code (Bad Gateway) - Amazon CloudFront ?

    I assume Cloudfront is being run off a custom subdomain CNAME alias ? i.e. cdn.domain.com ?

    You may need to check at each layer that the proper visitor real IP addresses are being forwarded to the next layer in the chains depending on how you have Cloudfront CDN configured and which IP origin it's looking towards i.e. Nginx non-HTTPS backend, Nginx HTTPS backend, Cloudflare frontend etc. Especially if you have enabled and setup Cloudflare Authenticated Origin Pulls which would only allow Cloudflare to talk to your Centmin Mod Nginx origin backend.

    Centmin Mod is provide as is, so short of scripted related bugs or issues, any further optimisation to the web stack components - nginx, php-fpm, mariadb mysql, csf firewall etc or web app specific configurations are left to the Centmin Mod user to deal with. So I do not provide any free support for such. My advice just use Cloudflare native CDN as it would be less costly and performs better anyway.

    However, Centmin Mod users are free to help each other out and ask questions or give answers on this community forum. My hopes are that this community forum evolves so that more veteran long time Centmin Mod users help new Centmin Mod users out :)
     
  3. computer19852007

    computer19852007 Member

    80
    8
    8
    Jun 25, 2014
    Ratings:
    +8
    Local Time:
    5:56 AM
    Centmin Mod 1.2.3-eva2000.06
    MariaDB 5.5.34
  4. eva2000

    eva2000 Administrator Staff Member

    35,522
    7,833
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,074
    Local Time:
    8:56 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    elaborate in more detail as to what is 'not working' .. error code/messages ? if there's error codes try searching CF knowledge base at Cloudflare Support
     
  5. computer19852007

    computer19852007 Member

    80
    8
    8
    Jun 25, 2014
    Ratings:
    +8
    Local Time:
    5:56 AM
    Centmin Mod 1.2.3-eva2000.06
    MariaDB 5.5.34
    I'm sorry this show:
    1) If i turn off cloudflare, it show: 502 ERROR (same First Post)
    2) If i turn on cloudfalre it show:
    Code:
    Error 1000
    
    DNS points to a prohibited IP
    
    You've requested a page on a website<website URL> that is on the Cloudflare network. Unfortunately, it is resolving to an IP address that is creating a conflict within Cloudflare's system.
    
    If you are the owner of this website, you should login to Cloudflare and change the DNS A records for <website URL> to resolve to a different IP address.
    Thanks you
     
..